summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorNeena Busireddy <neena.busireddy@freescale.com>2015-01-23 22:44:03 -0600
committerOtavio Salvador <otavio@ossystems.com.br>2015-01-27 09:10:44 -0200
commitda0581341a58dfe393a829b3c402330c73589963 (patch)
tree226cc9794a7a149ccc4333420307be163ba5357f /recipes-graphics
parentf0440193ddb3eafa1b00aed294ed6dbd3e4d604d (diff)
downloadmeta-fsl-arm-da0581341a58dfe393a829b3c402330c73589963.tar.gz
xf86-video-imxfb-vivante: Add autohdmi utility
This utility is used to monitor hdmi display hot plug and reconfigure xserver (through exa driver) if it detects the display change. Signed-off-by: Neena Busireddy <neena.busireddy@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/rc.autohdmi32
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_3.10.53-1.1.0.bb26
2 files changed, 55 insertions, 3 deletions
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/rc.autohdmi b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/rc.autohdmi
new file mode 100644
index 0000000..3a49e22
--- /dev/null
+++ b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/rc.autohdmi
@@ -0,0 +1,32 @@
1#! /bin/sh
2### BEGIN INIT INFO
3# Provides: rc.autohdmi
4# Required-Start: $all
5# Required-Stop:
6# Default-Start: 2 3 4 5
7# Default-Stop:
8### END INIT INFO
9
10PATH=/sbin:/usr/sbin:/bin:/usr/bin
11
12do_start() {
13 export DISPLAY=:0
14 autohdmi &
15 exit 0
16}
17
18case "$1" in
19 start)
20 do_start
21 ;;
22 restart|reload|force-reload)
23 echo "Error: argument '$1' not supported" >&2
24 exit 3
25 ;;
26 stop)
27 ;;
28 *)
29 echo "Usage: $0 start|stop" >&2
30 exit 3
31 ;;
32esac
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_3.10.53-1.1.0.bb b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_3.10.53-1.1.0.bb
index 0b5e9ff..266ca56 100644
--- a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_3.10.53-1.1.0.bb
+++ b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_3.10.53-1.1.0.bb
@@ -6,17 +6,22 @@ require recipes-graphics/xorg-driver/xorg-driver-video.inc
6 6
7PE = "3" 7PE = "3"
8 8
9inherit autotools-brokensep 9inherit autotools-brokensep update-rc.d pkgconfig
10 10
11DEPENDS += "virtual/xserver virtual/libx11 virtual/libgal-x11 imx-gpu-viv pixman" 11DEPENDS += "virtual/xserver virtual/libx11 virtual/libgal-x11 imx-gpu-viv pixman"
12 12
13LIC_FILES_CHKSUM = "file://EXA/src/vivante_fbdev/vivante.h;endline=19;md5=95cf961a2ceacdf7cf43caef25766779" 13LIC_FILES_CHKSUM = "file://EXA/src/vivante_fbdev/vivante.h;endline=19;md5=95cf961a2ceacdf7cf43caef25766779"
14 14
15SRC_URI = "${FSL_MIRROR}/xserver-xorg-video-imx-viv-${PV}.tar.gz" 15SRC_URI = "${FSL_MIRROR}/xserver-xorg-video-imx-viv-${PV}.tar.gz \
16 file://rc.autohdmi"
17
16SRC_URI[md5sum] = "3ffa0f66bc0935a50cda9ebd5240ee2d" 18SRC_URI[md5sum] = "3ffa0f66bc0935a50cda9ebd5240ee2d"
17SRC_URI[sha256sum] = "f5836d86944a667f9fd1789911cdb7d8c54f6158a7776d28124942c4a94ddff6" 19SRC_URI[sha256sum] = "f5836d86944a667f9fd1789911cdb7d8c54f6158a7776d28124942c4a94ddff6"
18 20
19EXTRA_OEMAKE += "-C EXA/src -f makefile.linux prefix=${D}/usr \ 21INITSCRIPT_NAME = "rc.autohdmi"
22INITSCRIPT_PARAMS = "start 99 2 3 4 5 ."
23
24EXTRA_OEMAKE += "-C ${S} -d -f Makefile prefix=${D}/usr \
20 sysroot=${STAGING_DIR_TARGET} \ 25 sysroot=${STAGING_DIR_TARGET} \
21 BUSID_HAS_NUMBER=1 \ 26 BUSID_HAS_NUMBER=1 \
22 BUILD_IN_YOCTO=1 \ 27 BUILD_IN_YOCTO=1 \
@@ -28,6 +33,8 @@ CFLAGS += "-I${STAGING_INCDIR}/xorg \
28 33
29S = "${WORKDIR}/xserver-xorg-video-imx-viv-${PV}/" 34S = "${WORKDIR}/xserver-xorg-video-imx-viv-${PV}/"
30 35
36PACKAGES =+ "xserver-xorg-extension-viv-autohdmi"
37
31# FIXME: The Freescale provided Makefile has hardcodec include paths 38# FIXME: The Freescale provided Makefile has hardcodec include paths
32# and this does not work in case prefix is different than /usr, 39# and this does not work in case prefix is different than /usr,
33# sed it. 40# sed it.
@@ -47,6 +54,10 @@ do_install_append () {
47 install -d ${D}${includedir} 54 install -d ${D}${includedir}
48 cp -axr ${S}/EXA/src/vivante_gal/vivante_priv.h ${D}${includedir} 55 cp -axr ${S}/EXA/src/vivante_gal/vivante_priv.h ${D}${includedir}
49 cp -axr ${S}/EXA/src/vivante_gal/vivante_gal.h ${D}${includedir} 56 cp -axr ${S}/EXA/src/vivante_gal/vivante_gal.h ${D}${includedir}
57
58 install -d ${D}/${sysconfdir}/init.d
59 install -m 755 ${WORKDIR}/rc.autohdmi ${D}/${sysconfdir}/init.d/rc.autohdmi
60
50 find ${D}${includedir} -type f -exec chmod 660 {} \; 61 find ${D}${includedir} -type f -exec chmod 660 {} \;
51} 62}
52 63
@@ -57,5 +68,14 @@ RDEPENDS_${PN} += "libvivante-dri-mx6 \
57 xserver-xorg-extension-dri2 \ 68 xserver-xorg-extension-dri2 \
58 xserver-xorg-extension-glx" 69 xserver-xorg-extension-glx"
59 70
71REALSOLIBS := "${SOLIBS}"
72SOLIBS = "${SOLIBSDEV}"
73
74FILES_${PN} = "${libdir}/*/*/*/vivante_drv${SOLIBS}"
75FILES_${PN}-dev = "${includedir} /usr/src ${libdir}/libfsl_x11_ext${SOLIBSDEV}"
76FILES_${PN}-dbg = "${libdir}/*/*/*/.debug ${libdir}/.debug/libfsl_x11_ext${SOLIBS} ${exec_prefix}/bin/.debug/autohdmi"
77
78FILES_xserver-xorg-extension-viv-autohdmi = " ${libdir}/libfsl_x11_ext${SOLIBS} ${exec_prefix}/bin/autohdmi ${sysconfdir}/init.d/rc.autohdmi"
79
60PACKAGE_ARCH = "${MACHINE_SOCARCH}" 80PACKAGE_ARCH = "${MACHINE_SOCARCH}"
61COMPATIBLE_MACHINE = "(mx6)" 81COMPATIBLE_MACHINE = "(mx6)"