summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2013-08-31 18:06:18 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2013-09-03 13:40:22 -0300
commitc3c1d2616e59ba314c6ff602b99909da632a11d5 (patch)
tree4a712efa05d428dbf9d2589de63b47975a86e3bc /recipes-graphics
parentbd14ad22740de5cac3063ef32ba8c00d34199825 (diff)
downloadmeta-fsl-arm-c3c1d2616e59ba314c6ff602b99909da632a11d5.tar.gz
xf86-video-imxfb-vivante: Remove unused patches
Following patches were not being used: - Makefile-fix-cross-compile.patch - Makefile.am-remove-prefixed-include-path.patch - build-Don-t-force-things-decided-by-build-system.patch Those were included when working on 3.5.7-1.0.0-alpha release but not removed, by mistake, when updating for 3.5.7-1.0.0-alpha.2 release. Change-Id: Ib99562eaaa2d50845782f53a5b3ad3334cb9f48a Reported-by: Evan Kotara <evan.kotara@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/Makefile-fix-cross-compile.patch23
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/Makefile.am-remove-prefixed-include-path.patch31
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/build-Don-t-force-things-decided-by-build-system.patch82
3 files changed, 0 insertions, 136 deletions
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/Makefile-fix-cross-compile.patch b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/Makefile-fix-cross-compile.patch
deleted file mode 100644
index ce3a9ae..0000000
--- a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/Makefile-fix-cross-compile.patch
+++ /dev/null
@@ -1,23 +0,0 @@
1diff --git a/EXA/src/makefile.linux b/EXA/src/makefile.linux
2index 12cb8f3..005b002 100644
3--- a/EXA/src/makefile.linux
4+++ b/EXA/src/makefile.linux
5@@ -1,9 +1,6 @@
6
7 .PHONY: all clean install
8
9-CC := $(CROSS_COMPILE)gcc
10-LD := $(CROSS_COMPILE)gcc
11-
12 target := vivante_drv.so
13
14 OBJS := vivante_gal/vivante_gal_blit.o \
15@@ -63,7 +60,7 @@ LFLAGS += -L$(sysroot)/usr/lib -lm -ldl -lGAL -Wl,-soname -Wl,vivante_drv.so
16 all: $(target)
17
18 $(target): $(OBJS)
19- $(LD) -shared -fPIC -o $(target) $(OBJS) $(LFLAGS)
20+ $(CC) -shared -fPIC -o $(target) $(OBJS) $(LFLAGS)
21
22 clean:
23 -@rm $(target) $(OBJS)
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/Makefile.am-remove-prefixed-include-path.patch b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/Makefile.am-remove-prefixed-include-path.patch
deleted file mode 100644
index c44f01a..0000000
--- a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/Makefile.am-remove-prefixed-include-path.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1From 230acf40ab9ed8ab5f291ff6644160b3f3859d69 Mon Sep 17 00:00:00 2001
2From: Adrian Alonso <aalonso00@gmail.com>
3Date: Fri, 15 Jun 2012 00:46:28 -0500
4Subject: [PATCH] Makefile.am remove prefixed include path
5
6* Remove prefixed include path, use ${STAGING_INCDIR}
7 to locate drm headers.
8
9Upstream-Status: Pending
10
11Signed-off-by: Adrian Alonso <aalonso00@gmail.com>
12---
13 src/Makefile.am | 2 +-
14 1 files changed, 1 insertions(+), 1 deletions(-)
15
16diff --git a/src/Makefile.am b/src/Makefile.am
17index 820278b..4acdf6a 100644
18--- a/src/Makefile.am
19+++ b/src/Makefile.am
20@@ -50,7 +50,7 @@ VIVSRC_CFLAGS = \
21 -I./vivante_util \
22 -I./vivante_exa
23
24-AM_CFLAGS = @XORG_CFLAGS@ $(VIVSRC_CFLAGS) -I/usr/include/drm
25+AM_CFLAGS = @XORG_CFLAGS@ $(VIVSRC_CFLAGS) ${CFLAGS}
26 vivante_drv_la_LTLIBRARIES = vivante_drv.la
27 vivante_drv_la_LDFLAGS = -module -avoid-version
28 vivante_drv_ladir = @moduledir@/drivers
29--
301.7.7.6
31
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/build-Don-t-force-things-decided-by-build-system.patch b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/build-Don-t-force-things-decided-by-build-system.patch
deleted file mode 100644
index 5fda33c..0000000
--- a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/build-Don-t-force-things-decided-by-build-system.patch
+++ /dev/null
@@ -1,82 +0,0 @@
1From bc46bc886c79246065cf779a7b4e197b80acd9b1 Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Thu, 18 Jul 2013 19:52:11 -0300
4Subject: [PATCH] build: Don't force things decided by build system
5
6The build system should't enforce build flags and linking flags which
7are not really necessary so it build system can do the "Right Thing"
8automatically.
9
10Upstream-Status: Pending
11
12Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
13---
14 DRI_1.10.4/src/makefile.linux | 20 +-------------------
15 EXA/src/makefile.linux | 9 +--------
16 2 files changed, 2 insertions(+), 27 deletions(-)
17
18diff --git a/DRI_1.10.4/src/makefile.linux b/DRI_1.10.4/src/makefile.linux
19index 86aa903..9188432 100644
20--- a/DRI_1.10.4/src/makefile.linux
21+++ b/DRI_1.10.4/src/makefile.linux
22@@ -37,29 +37,11 @@ ifeq ($(SWAP_SINGLE_PARAMETER),1)
23 CFLAGS += -DSWAP_SINGLE_PARAMETER
24 endif
25
26-ifeq ($(BUILD_HARD_VFP),1)
27-CFLAGS += -mfpu=neon -mfloat-abi=hard
28-else
29-CFLAGS += -mfpu=vfp -mfloat-abi=softfp
30-endif
31-
32 CFLAGS += -fvisibility=hidden -fPIC -DPIC
33 CFLAGS += -I. -I.. -I$(sysroot)/usr/include -I$(sysroot)/usr/include/xorg -I$(sysroot)/usr/include/$(PIXMAN)
34 CFLAGS += -I../../EXA/src/vivante_gal
35-ifeq ($(YOCTO),1)
36-# Yocto: compile will fail (does not support ldrex/strexeq/...)
37-# specify armv6 to walkaround it
38-# armv7: not supported by the toolchain
39-CFLAGS += -march=armv6
40-else
41-CFLAGS += -marm
42-# -Wa,-mimplicit-it=thumb
43-endif
44-
45
46-#LFLAGS += -lGAL -lm -ldl -ldrm -lX11 -module -Wl,-soname -Wl,$(target) -Wl,-rpath,/usr/lib/xorg/modules/extensions
47-#LFLAGS += -lGAL -lm -ldl -ldrm -lX11 -module -Wl,-soname -Wl,$(target)
48-LFLAGS += -L$(sysroot)/usr/lib -lGAL -lm -ldl -ldrm -lX11 -Wl,-soname -Wl,$(target)
49+LFLAGS += -lGAL -lm -ldl -ldrm -lX11 -Wl,-soname -Wl,$(target)
50
51 all: $(target)
52
53diff --git a/EXA/src/makefile.linux b/EXA/src/makefile.linux
54index eb56de5..bfaf314 100644
55--- a/EXA/src/makefile.linux
56+++ b/EXA/src/makefile.linux
57@@ -57,12 +57,6 @@ ifeq ($(BUSID_HAS_NUMBER),1)
58 CFLAGS += -DBUSID_HAS_NUMBER
59 endif
60
61-ifeq ($(BUILD_HARD_VFP),1)
62-CFLAGS += -mfpu=neon -mfloat-abi=hard
63-else
64-CFLAGS += -mfpu=vfp -mfloat-abi=softfp
65-endif
66-
67 # macro FREESCALE_EXTENSION is reserved for future use
68 CFLAGS += -fvisibility=hidden -fPIC -DPIC -O2 -DFREESCALE_EXTENSION
69 CFLAGS += -I. -I.. -I$(sysroot)/usr/include -I$(sysroot)/usr/include/xorg -I$(sysroot)/usr/include/$(PIXMAN)
70@@ -73,8 +67,7 @@ CFLAGS += -marm
71 #CFLAGS += -mimplicit-it=thumb
72
73 LFLAGS += -fPIC
74-#LFLAGS += -Wl,--no-allow-shlib-undefined -lX11
75-LFLAGS += -L$(sysroot)/usr/lib -lm -ldl -lGAL -Wl,-soname -Wl,vivante_drv.so
76+LFLAGS += -lm -ldl -lGAL -Wl,-soname -Wl,vivante_drv.so
77
78
79 all: $(target)
80--
811.8.3.2
82