summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2014-11-24 13:18:58 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2014-11-24 18:33:23 -0200
commit90953e08b59fa4e4ddb55f0084881adff7391381 (patch)
tree4fbfce331bfbe0a0911e1fcb8ea66b92515d3bf6 /recipes-graphics
parent5593081ccc97633c1b2b7d12b1827a20498e7f0e (diff)
downloadmeta-fsl-arm-90953e08b59fa4e4ddb55f0084881adff7391381.tar.gz
weston: Remove "Desktop-shell-Don-t-assume-there-is-a-pointer.patch"
This patch is applied upstream and can be removed now. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland/weston/0004-Desktop-shell-Don-t-assume-there-is-a-pointer.patch36
-rw-r--r--recipes-graphics/wayland/weston_%.bbappend1
2 files changed, 0 insertions, 37 deletions
diff --git a/recipes-graphics/wayland/weston/0004-Desktop-shell-Don-t-assume-there-is-a-pointer.patch b/recipes-graphics/wayland/weston/0004-Desktop-shell-Don-t-assume-there-is-a-pointer.patch
deleted file mode 100644
index f6ef253..0000000
--- a/recipes-graphics/wayland/weston/0004-Desktop-shell-Don-t-assume-there-is-a-pointer.patch
+++ /dev/null
@@ -1,36 +0,0 @@
1From 1194ccebc0db14ba681bd8272e01715b3e7008cc Mon Sep 17 00:00:00 2001
2From: Yong Gan <b45748@freescale.com>
3Date: Fri, 27 Jun 2014 11:33:53 +0800
4Subject: [PATCH] ENGR00320189 desktop-shell: Don't assume there is a pointer
5 when resizing
6
7Fixes a crash on touch devices without a pointer, when touching
8the window frame of a client.
9cherry-pick from 5872b6821be7c9c0a17a0de962e3f4a04f5d0c6f
10
11Date: Jun 27, 2014
12
13Upstream Status: N/A
14
15Signed-off-by Yong Gan <B45748@freescale.com>
16---
17 desktop-shell/shell.c | 3 ++-
18 1 file changed, 2 insertions(+), 1 deletion(-)
19
20diff --git a/desktop-shell/shell.c b/desktop-shell/shell.c
21index 84f5c83..d965618 100644
22--- a/desktop-shell/shell.c
23+++ b/desktop-shell/shell.c
24@@ -1784,7 +1784,8 @@ common_surface_resize(struct wl_resource *resource,
25 struct shell_surface *shsurf = wl_resource_get_user_data(resource);
26 struct weston_surface *surface;
27
28- if (seat->pointer->button_count == 0 ||
29+ if (seat->pointer == NULL ||
30+ seat->pointer->button_count == 0 ||
31 seat->pointer->grab_serial != serial ||
32 seat->pointer->focus == NULL)
33 return;
34--
351.7.9.5
36
diff --git a/recipes-graphics/wayland/weston_%.bbappend b/recipes-graphics/wayland/weston_%.bbappend
index 7b50283..01773d2 100644
--- a/recipes-graphics/wayland/weston_%.bbappend
+++ b/recipes-graphics/wayland/weston_%.bbappend
@@ -3,7 +3,6 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3SRC_URI_append_mx6 = " file://0001-ENGR00314805-1-Add-Vivante-EGL-support.patch \ 3SRC_URI_append_mx6 = " file://0001-ENGR00314805-1-Add-Vivante-EGL-support.patch \
4 file://0002-ENGR00314805-2-Add-Vivante-GAL2D-support.patch \ 4 file://0002-ENGR00314805-2-Add-Vivante-GAL2D-support.patch \
5 file://0003-Distorted-line-and-shadow-if-use-2d-com.patch \ 5 file://0003-Distorted-line-and-shadow-if-use-2d-com.patch \
6 file://0004-Desktop-shell-Don-t-assume-there-is-a-pointer.patch \
7 file://0005-Enable-GAL2D-compositor-in-SoloLite.patch \ 6 file://0005-Enable-GAL2D-compositor-in-SoloLite.patch \
8 file://0006-Change-GAL2D-compositor-to-be-default-i.patch \ 7 file://0006-Change-GAL2D-compositor-to-be-default-i.patch \
9 " 8 "