summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-04-23 09:59:31 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2012-04-23 10:07:40 -0300
commit1f84c1fd36c0e7a08f02ad4e0796b944ae11f112 (patch)
treef5a154ae6d36279dd5e0225140dcfd50707ea188 /recipes-graphics
parent0359d775e6ca41b2babe2fe78b3d5a1970e378ba (diff)
downloadmeta-fsl-arm-1f84c1fd36c0e7a08f02ad4e0796b944ae11f112.tar.gz
xserver-xf86-config: merge imx53qsb and imx53ard onto mx5
This avoids meta-data duplication and easy code reuse for external boards as they only need to make the board machine configuration from mx5 SOC_FAMILY to properly configure Xorg. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config/imx53qsb/xorg.conf45
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config/mx5/xorg.conf (renamed from recipes-graphics/xorg-xserver/xserver-xf86-config/imx53ard/xorg.conf)0
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend2
3 files changed, 1 insertions, 46 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/imx53qsb/xorg.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/imx53qsb/xorg.conf
deleted file mode 100644
index bbb1f53..0000000
--- a/recipes-graphics/xorg-xserver/xserver-xf86-config/imx53qsb/xorg.conf
+++ /dev/null
@@ -1,45 +0,0 @@
1Section "InputDevice"
2 Identifier "Generic Keyboard"
3 Driver "kbd"
4 Option "XkbRules" "xorg"
5 Option "XkbModel" "pc105"
6 Option "XkbLayout" "us"
7EndSection
8
9Section "InputDevice"
10 Identifier "Configured Mouse"
11 Driver "mouse"
12 Option "CorePointer"
13EndSection
14
15Section "InputClass"
16 Identifier "eGalax"
17 MatchIsTouchscreen "on"
18 MatchDevicePath "/dev/input/event*"
19 Driver "evdev"
20EndSection
21
22Section "Device"
23 Identifier "i.MX Accelerated Framebuffer Device"
24 Driver "imx"
25 Option "fbdev" "/dev/fb0"
26 # This option only recognized when "mxc_epdc_fb" frame buffer driver in
27 # use. Values are "RGB565" (default, 16-bit RGB), "Y8" (8-bit gray),
28 # and "Y8INV" (8-bit gray inverted).
29 Option "FormatEPDC" "Y8INV"
30EndSection
31
32Section "Monitor"
33 Identifier "Configured Monitor"
34EndSection
35
36Section "Screen"
37 Identifier "Default Screen"
38 Monitor "Configured Monitor"
39 Device "i.MX Accelerated Framebuffer Device"
40EndSection
41
42Section "ServerLayout"
43 Identifier "Default Layout"
44 Screen "Default Screen"
45EndSection
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/imx53ard/xorg.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/mx5/xorg.conf
index bbb1f53..bbb1f53 100644
--- a/recipes-graphics/xorg-xserver/xserver-xf86-config/imx53ard/xorg.conf
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config/mx5/xorg.conf
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
index 56cb294..761eac9 100644
--- a/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
@@ -1,4 +1,4 @@
1# Append path for freescale layer to include bsp xorg.conf 1# Append path for freescale layer to include bsp xorg.conf
2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3 3
4PRINC := "${@int(PRINC) + 1}" 4PRINC := "${@int(PRINC) + 2}"