summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorLauren Post <lauren.post@freescale.com>2013-12-16 16:20:58 -0600
committerOtavio Salvador <otavio@ossystems.com.br>2014-03-03 15:01:52 -0300
commit12530197b2cae0eefda6baadee1a5548ce02c967 (patch)
treef9ba4c50729e7be0a573d1b1880196ddebbb5d44 /recipes-graphics
parentc40ccaa359b21170254788e9fc12f4da421de38f (diff)
downloadmeta-fsl-arm-12530197b2cae0eefda6baadee1a5548ce02c967.tar.gz
gpu-viv-bin-mx6q: Upgrade to 3.10.17-1.0.0_beta version
This includes support for p13 vivante upgrade and support for webGL rendering Signed-off-by: Lauren Post <lauren.post@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc20
-rw-r--r--recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/directfbrc10
-rw-r--r--recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.10.17-1.0.0-hfp.bb9
-rw-r--r--recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.10.17-1.0.0-sfp.bb9
-rw-r--r--recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.10.9-1.0.0-hfp.bb9
-rw-r--r--recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.10.9-1.0.0-sfp.bb9
6 files changed, 44 insertions, 22 deletions
diff --git a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc
index f661539..32867e7 100644
--- a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc
+++ b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc
@@ -1,5 +1,5 @@
1# Copyright (C) 2012-2013 Freescale Semiconductor 1# Copyright (C) 2012-2013 Freescale Semiconductor
2# Copyright (C) 2012-2013 O.S. Systems Software LTDA. 2# Copyright (C) 2012-2014 O.S. Systems Software LTDA.
3# Released under the MIT license (see COPYING.MIT for the terms) 3# Released under the MIT license (see COPYING.MIT for the terms)
4 4
5DESCRIPTION = "GPU driver and apps for imx6" 5DESCRIPTION = "GPU driver and apps for imx6"
@@ -13,7 +13,8 @@ PE = "1"
13 13
14inherit fsl-eula-unpack 14inherit fsl-eula-unpack
15 15
16SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true \ 16# FIXME: Drop 'beta' suffix for GA release
17SRC_URI = "${FSL_MIRROR}/${PN}-${@'${PV}'.replace('1.0.0', '1.0.0-beta')}.bin;fsl-eula=true \
17 file://egl.pc \ 18 file://egl.pc \
18 file://egl_x11.pc \ 19 file://egl_x11.pc \
19 file://glesv1_cm.pc \ 20 file://glesv1_cm.pc \
@@ -25,7 +26,9 @@ SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true \
25 file://gc_wayland_protocol.pc \ 26 file://gc_wayland_protocol.pc \
26 file://wayland-egl.pc \ 27 file://wayland-egl.pc \
27 file://wayland-viv.pc \ 28 file://wayland-viv.pc \
29 file://directfbrc \
28 " 30 "
31S = "${WORKDIR}/${PN}-${@'${PV}'.replace('1.0.0', '1.0.0-beta')}"
29 32
30PACKAGES =+ "libclc-mx6 libclc-mx6-dev libclc-mx6-dbg \ 33PACKAGES =+ "libclc-mx6 libclc-mx6-dev libclc-mx6-dbg \
31 libgl-mx6 libgl-mx6-dev libgl-mx6-dbg \ 34 libgl-mx6 libgl-mx6-dev libgl-mx6-dbg \
@@ -141,6 +144,9 @@ do_install () {
141 install -m 0644 ${WORKDIR}/vg.pc ${D}${libdir}/pkgconfig/vg.pc 144 install -m 0644 ${WORKDIR}/vg.pc ${D}${libdir}/pkgconfig/vg.pc
142 145
143 if [ "${USE_DFB}" = "yes" ]; then 146 if [ "${USE_DFB}" = "yes" ]; then
147 install -d ${D}/${sysconfdir}
148 install -m 644 ${WORKDIR}/directfbrc ${D}/${sysconfdir}/directfbrc
149
144 cp -r ${S}/usr/lib/directfb-1.6-0 ${D}${libdir} 150 cp -r ${S}/usr/lib/directfb-1.6-0 ${D}${libdir}
145 backend=dfb 151 backend=dfb
146 else 152 else
@@ -160,6 +166,12 @@ do_install () {
160 mv ${D}${libdir}/libGAL-${backend}.so ${D}${libdir}/libGAL.so 166 mv ${D}${libdir}/libGAL-${backend}.so ${D}${libdir}/libGAL.so
161 mv ${D}${libdir}/libVIVANTE-${backend}.so ${D}${libdir}/libVIVANTE.so 167 mv ${D}${libdir}/libVIVANTE-${backend}.so ${D}${libdir}/libVIVANTE.so
162 168
169 # update libglesv2 as backend dependent
170 rm -rf ${D}${libdir}/libGLESv2*
171 cp -a ${S}/usr/lib/libGLESv2-${backend}.so ${D}${libdir}/libGLESv2.so.2.0.0
172 ln -sf libGLESv2.so.2.0.0 ${D}${libdir}/libGLESv2.so.2
173 ln -sf libGLESv2.so.2.0.0 ${D}${libdir}/libGLESv2.so
174
163 for backend in wl x11 fb dfb; do 175 for backend in wl x11 fb dfb; do
164 find ${D}${libdir} -name "*-$backend.so" -exec rm '{}' ';' 176 find ${D}${libdir} -name "*-$backend.so" -exec rm '{}' ';'
165 done 177 done
@@ -168,8 +180,6 @@ do_install () {
168 find ${D}${includedir} -type f -exec chmod 644 {} \; 180 find ${D}${includedir} -type f -exec chmod 644 {} \;
169} 181}
170 182
171S = "${WORKDIR}/${PN}-${PV}"
172
173FILES_${PN} += "/opt" 183FILES_${PN} += "/opt"
174FILES_${PN}-dev = "${includedir}" 184FILES_${PN}-dev = "${includedir}"
175FILES_${PN}-dbg = "${libdir}/.debug /opt/viv_samples/*/*/.debug" 185FILES_${PN}-dbg = "${libdir}/.debug /opt/viv_samples/*/*/.debug"
@@ -243,4 +253,6 @@ FILES_libgc-wayland-protocol-mx6-dbg = "${libdir}/libgc_wayland_protocol${SOLIBS
243 253
244FILES_libwayland-egl-mx6-dev = "${libdir}/pkgconfig/wayland-egl.pc" 254FILES_libwayland-egl-mx6-dev = "${libdir}/pkgconfig/wayland-egl.pc"
245 255
256FILES_libvivante-dfb-mx6 += "${sysconfdir}/directfbrc"
257
246COMPATIBLE_MACHINE = "(mx6)" 258COMPATIBLE_MACHINE = "(mx6)"
diff --git a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/directfbrc b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/directfbrc
new file mode 100644
index 0000000..bae398c
--- /dev/null
+++ b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q/directfbrc
@@ -0,0 +1,10 @@
1# directfbrc begin
2system=fbdev
3mode=1024x768 # display size (change to fit your needs)
4desktop-buffer-mode=frontonly # if no double buffering in framebuffer driver
5depth=16
6pixelformat=RGB16
7#no-hardware # disable hardware acceleration
8#no-software # disable software fallbacks
9# directfbrc end
10
diff --git a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.10.17-1.0.0-hfp.bb b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.10.17-1.0.0-hfp.bb
new file mode 100644
index 0000000..58b1f0f
--- /dev/null
+++ b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.10.17-1.0.0-hfp.bb
@@ -0,0 +1,9 @@
1# Copyright (C) 2013, 2014 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4require gpu-viv-bin-mx6q.inc
5
6SRC_URI[md5sum] = "11e844bb6ba04295cdcd78731076c96d"
7SRC_URI[sha256sum] = "863d20ecba3ed5865c12a77717aa61b492ff93c9c81f6bb3f051322291631e0c"
8
9PACKAGE_FP_TYPE = "hardfp"
diff --git a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.10.17-1.0.0-sfp.bb b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.10.17-1.0.0-sfp.bb
new file mode 100644
index 0000000..e48695b
--- /dev/null
+++ b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.10.17-1.0.0-sfp.bb
@@ -0,0 +1,9 @@
1# Copyright (C) 2013, 2014 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4require gpu-viv-bin-mx6q.inc
5
6SRC_URI[md5sum] = "7bc440bd2adf2cb2c463f41f01e0412e"
7SRC_URI[sha256sum] = "c6fc0b387879f5826edbb0d51ea2726eb16031a3aed77e88833d3fb7de445a7a"
8
9PACKAGE_FP_TYPE = "softfp"
diff --git a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.10.9-1.0.0-hfp.bb b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.10.9-1.0.0-hfp.bb
deleted file mode 100644
index 56610fb..0000000
--- a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.10.9-1.0.0-hfp.bb
+++ /dev/null
@@ -1,9 +0,0 @@
1# Copyright (C) 2013 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4require gpu-viv-bin-mx6q.inc
5
6SRC_URI[md5sum] = "52f5ebbb6a9b5d0eafdb952246de584e"
7SRC_URI[sha256sum] = "8b0386e13d4a7c770f8bc8e7a6119629c5ed379488dd5ef635bc92353f906003"
8
9PACKAGE_FP_TYPE = "hardfp"
diff --git a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.10.9-1.0.0-sfp.bb b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.10.9-1.0.0-sfp.bb
deleted file mode 100644
index e2fc01c..0000000
--- a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.10.9-1.0.0-sfp.bb
+++ /dev/null
@@ -1,9 +0,0 @@
1# Copyright (C) 2013 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4require gpu-viv-bin-mx6q.inc
5
6SRC_URI[md5sum] = "1ff2249a2633635ea8c375d9e83ca520"
7SRC_URI[sha256sum] = "b0e3c84f749aac3dab4ec328d19dbd3bba06ccc6ef8b7d4eefe3d79474be5055"
8
9PACKAGE_FP_TYPE = "softfp"