summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorNeena Busireddy <neena.busireddy@freescale.com>2014-08-26 14:44:17 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2014-11-10 18:55:23 -0200
commit0f412cded7b8bc78e9c93f2ed328fc9be3995d55 (patch)
tree8ca54c69f2d851cfbe7e991d172f614e5b108e21 /recipes-graphics
parentdebdd9744743799b91d359d4fce880bdb7d73d75 (diff)
downloadmeta-fsl-arm-0f412cded7b8bc78e9c93f2ed328fc9be3995d55.tar.gz
mesa-demos: Include patch to add extension header
This is the fix for the new OpenGL ES 1.1 header from khronos.org. The change moved some definitions to extension header. Signed-off-by: Neena Busireddy <neena.busireddy@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/mesa/mesa-demos/fix-clear-build-break.patch17
-rw-r--r--recipes-graphics/mesa/mesa-demos_%.bbappend3
2 files changed, 19 insertions, 1 deletions
diff --git a/recipes-graphics/mesa/mesa-demos/fix-clear-build-break.patch b/recipes-graphics/mesa/mesa-demos/fix-clear-build-break.patch
new file mode 100644
index 0000000..eb541d6
--- /dev/null
+++ b/recipes-graphics/mesa/mesa-demos/fix-clear-build-break.patch
@@ -0,0 +1,17 @@
1mesa-demos: Add extension header to fix build break now that gl1 is removed
2
3Upstream Status: Pending
4
5diff --git a/src/egl/opengles1/clear.c b/src/egl/opengles1/clear.c
6index 9fe1b5291e1905fd6fe572063ed707d59ce45a81..ca9954a21b5f475709dbdef07f90b900962fcbc7 100644
7--- a/src/egl/opengles1/clear.c
8+++ b/src/egl/opengles1/clear.c
9@@ -34,7 +34,7 @@
10 #include <stdio.h>
11 #include <EGL/egl.h>
12 #include <GLES/gl.h>
13-
14+#include <GLES/glext.h>
15 #include "eglut.h"
16
17 typedef void (GL_APIENTRY *type_ClearColor)(GLclampf red, GLclampf green, GLclampf blue, GLclampf alpha);
diff --git a/recipes-graphics/mesa/mesa-demos_%.bbappend b/recipes-graphics/mesa/mesa-demos_%.bbappend
index 221a3c0..9f675a2 100644
--- a/recipes-graphics/mesa/mesa-demos_%.bbappend
+++ b/recipes-graphics/mesa/mesa-demos_%.bbappend
@@ -1,5 +1,6 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3SRC_URI_append_mx6 = " file://Replace-glWindowPos2iARB-calls-with-glWindowPos2i.patch" 3SRC_URI_append_mx6 = " file://Replace-glWindowPos2iARB-calls-with-glWindowPos2i.patch \
4 file://fix-clear-build-break.patch"
4 5
5PACKAGECONFIG_remove_mx6sl = "gles1 gles2" 6PACKAGECONFIG_remove_mx6sl = "gles1 gles2"