summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorSimon Braunschmidt <sb@emlix.com>2013-07-18 13:19:25 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2013-07-18 16:41:25 -0300
commitea8d00398843abe64c80bd89a9bdfede72afffd1 (patch)
tree5993945a9c803e43fbd10e172f7b9cfe64c2b0f8 /recipes-graphics
parent86a7cf6aa5cbf79378148700b1d98426a187503e (diff)
downloadmeta-fsl-arm-ea8d00398843abe64c80bd89a9bdfede72afffd1.tar.gz
gpu-viv-bin-mx6q, mesa: fix virtual/libgl dependencies
Fixes [YOCTO #4850] findings: * meta-fsl-arm/recipes-graphics/mesa/mesa_9.1.3.bbappend is used to delete libGL.* after compilation of mesa * ./recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_3.0.35-4.0.0.bb, via gpu-viv-bin-mx6q.inc, provides its own version of libGL * gpu-viv-bin-mx6q does not advertise "virtual/libgl" in "PROVIDES +=" * but mesa (via mesa.inc) does: PROVIDES = "virtual/libgl virtual/libgles1 virtual/libgles2 virtual/egl" * so the statement in imx-base.inc PREFERRED_PROVIDER_virtual/libgl_mx6 ?= "gpu-viv-bin-mx6q" does not have effect, because mesa is still the only provider of virtual/libgl * packages depending on virtual/libgl only get mesa, which will not contain the libGL library * in fact, we still use the gl headers from mesa, but the binary blob library from gpu-viv-bin-mx6q (gpu-viv-bin-mx6q does not provide the headers), so a package compiling against GL needs both mesa and gpu-viv-bin-mx6q conclusion: * so i suggest having gpu-viv-bin-mx6q depend on mesa to draw in the gl header package, advertising "virtual/libgl" for gpu-viv-bin-mx6q via "PROVIDES +=" and not advertising virtual/libgl for mesa via the .bbappend file Signed-off-by: Simon Braunschmidt <sb@emlix.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc4
-rw-r--r--recipes-graphics/mesa/mesa_9.1.3.bbappend2
2 files changed, 3 insertions, 3 deletions
diff --git a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc
index b007079..3354854 100644
--- a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc
+++ b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc
@@ -6,8 +6,8 @@ DESCRIPTION = "GPU driver and apps for imx6"
6SECTION = "libs" 6SECTION = "libs"
7LICENSE = "Proprietary" 7LICENSE = "Proprietary"
8LIC_FILES_CHKSUM = "file://usr/include/gc_vdk.h;endline=11;md5=19f5925343fa3da65596eeaa4ddb5fd3" 8LIC_FILES_CHKSUM = "file://usr/include/gc_vdk.h;endline=11;md5=19f5925343fa3da65596eeaa4ddb5fd3"
9DEPENDS += "${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxdamage libxext libxfixes', '', d)}" 9DEPENDS += "${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxdamage libxext libxfixes', '', d)} mesa"
10PROVIDES += "virtual/libgal-x11 virtual/egl virtual/libgles1 virtual/libgles2" 10PROVIDES += "virtual/libgl virtual/libgal-x11 virtual/egl virtual/libgles1 virtual/libgles2"
11 11
12INC_PR = "r5" 12INC_PR = "r5"
13 13
diff --git a/recipes-graphics/mesa/mesa_9.1.3.bbappend b/recipes-graphics/mesa/mesa_9.1.3.bbappend
index b0535a7..9308952 100644
--- a/recipes-graphics/mesa/mesa_9.1.3.bbappend
+++ b/recipes-graphics/mesa/mesa_9.1.3.bbappend
@@ -23,7 +23,7 @@ python __anonymous () {
23 23
24 # Remove itens from provides 24 # Remove itens from provides
25 provides = d.getVar('PROVIDES', True).split() 25 provides = d.getVar('PROVIDES', True).split()
26 take_out = ['virtual/libgles1', 'virtual/libgles2', 'virtual/egl'] 26 take_out = ['virtual/libgles1', 'virtual/libgles2', 'virtual/egl', 'virtual/libgl']
27 new_provides = [] 27 new_provides = []
28 for i in provides: 28 for i in provides:
29 if i not in take_out: 29 if i not in take_out: