diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2013-03-23 09:54:39 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2013-03-26 09:20:45 -0300 |
commit | a891aa7087485a17e15624e2448e133829ebce69 (patch) | |
tree | 900546ffa2219e6690b35f337005f60b27c856bd /recipes-graphics | |
parent | d358966891915de7d6a8d2ac2f00b9c91cf37872 (diff) | |
download | meta-fsl-arm-a891aa7087485a17e15624e2448e133829ebce69.tar.gz |
gpu-viv-bin-mx6q: Respect X11, DirectFB, FrameBuffer distro features
As we cannot allow concurrent build of applications targetting
different backends we use the distro features to package the need
libraries for the backend. Currently it does:
X11 support, if 'x11' feature is enabled
DirectFB support, if 'x11' is not enabled AND 'directfb is enabled
FrameBuffer, fallback
As 1.1.0 version of the Vivante libraries are build against DirectFB
1.4 we cannot support it for now, so we explicitly disable it for this
version so it is easy to add it back when new version, supporting
newer DirectFB, is released.
Change-Id: Ia8973b8107155b8a5f7fadc50d2290c1d5f28363
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc | 25 | ||||
-rw-r--r-- | recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_1.1.0.bb | 4 |
2 files changed, 20 insertions, 9 deletions
diff --git a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc index ce23f2e..e8e491e 100644 --- a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc +++ b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q.inc | |||
@@ -41,8 +41,8 @@ PACKAGES =+ "libclc-mx6 libclc-mx6-dev libclc-mx6-dbg \ | |||
41 | ${@base_contains("DISTRO_FEATURES", "directfb", "${GPU_DFBLIBS}", "", d)} \ | 41 | ${@base_contains("DISTRO_FEATURES", "directfb", "${GPU_DFBLIBS}", "", d)} \ |
42 | " | 42 | " |
43 | 43 | ||
44 | KEEP_XLIBS = "${@base_contains("DISTRO_FEATURES", "x11", "yes", "no", d)}" | 44 | USE_X11 = "${@base_contains("DISTRO_FEATURES", "x11", "yes", "no", d)}" |
45 | KEEP_DFBLIBS = "${@base_contains("DISTRO_FEATURES", "directfb", "yes", "no", d)}" | 45 | USE_DFB = "${@base_contains("DISTRO_FEATURES", "directfb", "yes", "no", d)}" |
46 | 46 | ||
47 | # Inhibit warnings about files being stripped. | 47 | # Inhibit warnings about files being stripped. |
48 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | 48 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" |
@@ -69,19 +69,26 @@ do_install () { | |||
69 | rm -r ${D}${includedir}/GL | 69 | rm -r ${D}${includedir}/GL |
70 | cp -axr ${S}/opt ${D} | 70 | cp -axr ${S}/opt ${D} |
71 | 71 | ||
72 | if [ "${KEEP_XLIBS}" = "no" ]; then | ||
73 | rm ${D}${libdir}/*-x11.so | ||
74 | fi | ||
75 | if [ "${KEEP_DFBLIBS}" = "no" ]; then | ||
76 | rm ${D}${libdir}/*-dfb.so | ||
77 | fi | ||
78 | |||
79 | # FIXME: Drop default library as we need to explicit link to one | 72 | # FIXME: Drop default library as we need to explicit link to one |
80 | # of supported backends | 73 | # of supported backends |
81 | rm ${D}${libdir}/libEGL.so \ | 74 | rm ${D}${libdir}/libEGL.so \ |
82 | ${D}${libdir}/libGAL.so \ | 75 | ${D}${libdir}/libGAL.so \ |
83 | ${D}${libdir}/libVIVANTE.so | 76 | ${D}${libdir}/libVIVANTE.so |
84 | 77 | ||
78 | if [ "${USE_X11}" = "yes" ]; then | ||
79 | find ${D}${libdir} -name '*-dfb.so' -exec rm '{}' ';' | ||
80 | find ${D}${libdir} -name '*-fb.so' -exec rm '{}' ';' | ||
81 | else | ||
82 | if [ "${USE_DFB}" = "yes" ]; then | ||
83 | find ${D}${libdir} -name '*-x11.so' -exec rm '{}' ';' | ||
84 | find ${D}${libdir} -name '*-fb.so' -exec rm '{}' ';' | ||
85 | else | ||
86 | # Regular framebuffer | ||
87 | find ${D}${libdir} -name '*-x11.so' -exec rm '{}' ';' | ||
88 | find ${D}${libdir} -name '*-dfb.so' -exec rm '{}' ';' | ||
89 | fi | ||
90 | fi | ||
91 | |||
85 | find ${D}${libdir} -type f -exec chmod 644 {} \; | 92 | find ${D}${libdir} -type f -exec chmod 644 {} \; |
86 | find ${D}${includedir} -type f -exec chmod 644 {} \; | 93 | find ${D}${includedir} -type f -exec chmod 644 {} \; |
87 | } | 94 | } |
diff --git a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_1.1.0.bb b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_1.1.0.bb index 3de9555..994c11c 100644 --- a/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_1.1.0.bb +++ b/recipes-graphics/gpu-viv-bin-mx6q/gpu-viv-bin-mx6q_1.1.0.bb | |||
@@ -8,3 +8,7 @@ include gpu-viv-bin-mx6q.inc | |||
8 | 8 | ||
9 | SRC_URI[md5sum] = "60f4ba65f557fc63fde6dacfeef205a8" | 9 | SRC_URI[md5sum] = "60f4ba65f557fc63fde6dacfeef205a8" |
10 | SRC_URI[sha256sum] = "4238b72a6dad2d075d159bb1e86fb68bbed7c27894ce82c546a8e7c58ae5d683" | 10 | SRC_URI[sha256sum] = "4238b72a6dad2d075d159bb1e86fb68bbed7c27894ce82c546a8e7c58ae5d683" |
11 | |||
12 | # FIXME: 1.1.0 BSP release uses DirectFB 1.4 and Yocto has 1.6 so | ||
13 | # disable it for now | ||
14 | USE_DFB = "no" | ||