summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/xorg-driver
diff options
context:
space:
mode:
authorAdrian Alonso <b38018@freescale.com>2011-08-24 17:32:39 -0500
committerAdrian Alonso <b38018@freescale.com>2011-08-24 17:32:39 -0500
commitea62737c4f32eb64eb6d7751b067f9c5bdccdb9a (patch)
tree44172a64c0d2f33e5eb9160e71719f845bdc1a47 /recipes-graphics/xorg-driver
parentdf51c6e89dfff4223ea8f834b64e4961c0bef0ff (diff)
downloadmeta-fsl-arm-ea62737c4f32eb64eb6d7751b067f9c5bdccdb9a.tar.gz
xf86-video-imxfb: framebuffer driver for iMx targets
* Framebuffer driver for iMx targets boards * Fix m4 macros lookup location; remove /usr/share/aclocal path This patchs allows to use Yocto sysroot settings and avoid conflicts by using host tools. Signed-off-by: Adrian Alonso <b38018@freescale.com>
Diffstat (limited to 'recipes-graphics/xorg-driver')
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imxfb/xf86-video-imxfb-fix-m4-hardcodded-paths.patch53
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imxfb_11.05.01.bb26
2 files changed, 79 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb/xf86-video-imxfb-fix-m4-hardcodded-paths.patch b/recipes-graphics/xorg-driver/xf86-video-imxfb/xf86-video-imxfb-fix-m4-hardcodded-paths.patch
new file mode 100644
index 0000000..64af773
--- /dev/null
+++ b/recipes-graphics/xorg-driver/xf86-video-imxfb/xf86-video-imxfb-fix-m4-hardcodded-paths.patch
@@ -0,0 +1,53 @@
1From 5b348e7be67957f4be6fcfa4942128c04f6db905 Mon Sep 17 00:00:00 2001
2From: Adrian Alonso <b38018@freescale.com>
3Date: Thu, 4 Aug 2011 14:24:26 -0500
4Subject: [PATCH] xf86-video-imxfb: fix m4 hardcodded paths
5
6* Fix m4 macros lookup location; remove /usr/share/aclocal path
7
8Signed-off-by: Adrian Alonso <b38018@freescale.com>
9---
10 Makefile.am | 2 +-
11 Makefile.in | 2 +-
12 configure.ac | 2 +-
13 3 files changed, 3 insertions(+), 3 deletions(-)
14
15diff --git a/Makefile.am b/Makefile.am
16index 6752256..e205657 100644
17--- a/Makefile.am
18+++ b/Makefile.am
19@@ -20,4 +20,4 @@
20
21 AUTOMAKE_OPTIONS = foreign
22 SUBDIRS = src
23-ACLOCAL_AMFLAGS = -I /usr/share/aclocal
24+ACLOCAL_AMFLAGS = -I m4
25diff --git a/Makefile.in b/Makefile.in
26index 5c0ba0e..f829db7 100644
27--- a/Makefile.in
28+++ b/Makefile.in
29@@ -243,7 +243,7 @@ top_builddir = @top_builddir@
30 top_srcdir = @top_srcdir@
31 AUTOMAKE_OPTIONS = foreign
32 SUBDIRS = src
33-ACLOCAL_AMFLAGS = -I /usr/share/aclocal
34+ACLOCAL_AMFLAGS = -I m4
35 all: config.h
36 $(MAKE) $(AM_MAKEFLAGS) all-recursive
37
38diff --git a/configure.ac b/configure.ac
39index a1ac73b..0078b86 100644
40--- a/configure.ac
41+++ b/configure.ac
42@@ -29,7 +29,7 @@ AC_INIT([xf86-video-imx],
43 AC_CONFIG_SRCDIR([Makefile.am])
44 AM_CONFIG_HEADER([config.h])
45 AC_CONFIG_AUX_DIR(.)
46-AC_CONFIG_MACRO_DIR([/usr/share/aclocal])
47+AC_CONFIG_MACRO_DIR([m4])
48
49 AM_INIT_AUTOMAKE([dist-bzip2])
50
51--
521.7.4.1
53
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb_11.05.01.bb b/recipes-graphics/xorg-driver/xf86-video-imxfb_11.05.01.bb
new file mode 100644
index 0000000..a77e4ab
--- /dev/null
+++ b/recipes-graphics/xorg-driver/xf86-video-imxfb_11.05.01.bb
@@ -0,0 +1,26 @@
1# Copyright (C) 2011 Freescale
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "X.Org X server -- Freescale iMx framebuffer driver"
5LICENSE = "MIT-X"
6RDEPENDS = "amd-gpu-x11-bin-mx51"
7DEPENDS = "virtual/xserver-xf86 virtual/libx11 xproto randrproto util-macros amd-gpu-x11-bin-mx51"
8LIC_FILES_CHKSUM = "file://COPYING;md5=f7bdc0c63080175d1667091b864cb12c"
9
10inherit autotools pkgconfig
11
12PR = "r0"
13SRC_URI = "http://opensource.freescale.com/pub/scm/imx/xserver-xorg-video-imx-${PV}.tar.gz \
14 file://xf86-video-imxfb-fix-m4-hardcodded-paths.patch"
15
16FILES_${PN} += " ${libdir}/xorg/modules/drivers/*.so"
17FILES_${PN}-dbg += " ${libdir}/xorg/modules/drivers/.debug"
18EXTRA_OECONF_armv7a = " --enable-neon "
19CFLAGS += " -I${STAGING_INCDIR}/xorg "
20
21S = "${WORKDIR}/xserver-xorg-video-imx-${REL}"
22
23do_install_append () {
24 # driver's la files are not packaged
25 rm -f ${D}${libdir}/xorg/modules/drivers/*.la
26}