summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_3.10.17-1.0.1.bb
diff options
context:
space:
mode:
authorLauren Post <lauren.post@freescale.com>2014-08-14 14:17:30 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2014-08-22 10:32:00 -0300
commita0f657554d97d489d3479adc14ebafaa9780f19f (patch)
treed01c2762f91a54773bb6a8f4a778f92fa79d42eb /recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_3.10.17-1.0.1.bb
parentc7c410d7b6a0a8a96fa845d78e76b0a15157b19a (diff)
downloadmeta-fsl-arm-a0f657554d97d489d3479adc14ebafaa9780f19f.tar.gz
xf86-video-imxfb-vivante: Upgrade to 3.10.17-1.0.1
For 2D GPU cores there is a potential need to manage the maximum number of outstanding return requests from the memory subsystem. The proper way to manage these for 2D cores with this configuration is to use a FLUSH. The patch does a FLUSH after every DRAW, the pipe will not overfill and the scenario which may lead to a stall will not occur. Signed-off-by: Lauren Post <lauren.post@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_3.10.17-1.0.1.bb')
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_3.10.17-1.0.1.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_3.10.17-1.0.1.bb b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_3.10.17-1.0.1.bb
new file mode 100644
index 0000000..a4440de
--- /dev/null
+++ b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_3.10.17-1.0.1.bb
@@ -0,0 +1,62 @@
1# Copyright (C) 2012-2014 Freescale Semiconductor
2# Copyright (C) 2012-2014 O.S. Systems Software LTDA.
3# Released under the MIT license (see COPYING.MIT for the terms)
4
5require recipes-graphics/xorg-driver/xorg-driver-video.inc
6
7PE = "3"
8
9inherit autotools-brokensep
10
11DEPENDS += "virtual/xserver virtual/libx11 virtual/libgal-x11 gpu-viv-bin-mx6q pixman"
12
13LIC_FILES_CHKSUM = "file://EXA/src/vivante_fbdev/vivante.h;endline=19;md5=641ac6e6d013833e36290797f4d7089c"
14
15SRC_URI = "${FSL_MIRROR}/xserver-xorg-video-imx-viv-${PV}.tar.gz"
16
17SRC_URI[md5sum] = "974f33945dc96e876907541906297798"
18SRC_URI[sha256sum] = "5602266ac493c580386562068522b2fde43f24aa91c61ab6aaa62bb37a6cb672"
19
20EXTRA_OEMAKE += "-C EXA/src -f makefile.linux prefix=${D}/usr \
21 sysroot=${STAGING_DIR_TARGET} \
22 BUSID_HAS_NUMBER=1 \
23 BUILD_IN_YOCTO=1 \
24 XSERVER_GREATER_THAN_13=1"
25
26CFLAGS += "-I${STAGING_INCDIR}/xorg \
27 -I${STAGING_INCDIR}/drm \
28 -I../../DRI_1.10.4/src"
29
30S = "${WORKDIR}/xserver-xorg-video-imx-viv-${PV}/"
31
32# FIXME: The Freescale provided Makefile has hardcodec include paths
33# and this does not work in case prefix is different than /usr,
34# sed it.
35do_configure_prepend () {
36 sed -i 's,$(sysroot)/usr/include,${STAGING_INCDIR},g' \
37 ${S}EXA/src/makefile.linux
38}
39
40# FIXME: This is need as Freescale didn't use standard Makefile filename
41# thus oe_runmame thinks nothing is need to be done, use ln to
42# workaround it.
43base_do_compile () {
44 oe_runmake || die "make failed"
45}
46
47do_install_append () {
48 install -d ${D}${includedir}
49 cp -axr ${S}/EXA/src/vivante_gal/vivante_priv.h ${D}${includedir}
50 cp -axr ${S}/EXA/src/vivante_gal/vivante_gal.h ${D}${includedir}
51 find ${D}${includedir} -type f -exec chmod 660 {} \;
52}
53
54RDEPENDS_${PN} += "libvivante-dri-mx6 \
55 xserver-xorg-module-exa \
56 mesa-driver-swrast \
57 xserver-xorg-extension-dri \
58 xserver-xorg-extension-dri2 \
59 xserver-xorg-extension-glx"
60
61PACKAGE_ARCH = "${MACHINE_SOCARCH}"
62COMPATIBLE_MACHINE = "(mx6)"