summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/amd-gpu-x11-bin
diff options
context:
space:
mode:
authorAdrian Alonso <b38018@freescale.com>2011-08-24 17:16:50 -0500
committerAdrian Alonso <b38018@freescale.com>2011-08-24 17:16:50 -0500
commitbf736a64daf8e0237b96b4268ce14f01f82bffbf (patch)
treee935d65474c6a0b3550754b2cb44446921504b26 /recipes-graphics/amd-gpu-x11-bin
parentea7c43820dc9ab741f547c266241e02dc859eb90 (diff)
downloadmeta-fsl-arm-bf736a64daf8e0237b96b4268ce14f01f82bffbf.tar.gz
libz160: deploy shared lib and headers
* Deploy libz160 shared library * Deploys libz160 include headers, this are needed for xorg-video-imxfb driver Signed-off-by: Adrian Alonso <b38018@freescale.com>
Diffstat (limited to 'recipes-graphics/amd-gpu-x11-bin')
-rw-r--r--recipes-graphics/amd-gpu-x11-bin/libz160_11.05.01.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-graphics/amd-gpu-x11-bin/libz160_11.05.01.bb b/recipes-graphics/amd-gpu-x11-bin/libz160_11.05.01.bb
new file mode 100644
index 0000000..4257bcd
--- /dev/null
+++ b/recipes-graphics/amd-gpu-x11-bin/libz160_11.05.01.bb
@@ -0,0 +1,24 @@
1# Copyright (C) 2011 Freescale
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "AMD libz160 gpu driver"
5LICENSE = "MIT"
6SECTION = "libs"
7PR = "r0"
8
9#todo: Replace for correct AMD license
10LIC_FILES_CHKSUM = "file://usr/include/z160.h;endline=28;md5=65dd44cd769091092f38e34cd52cc271"
11RDEPENDS_${PN}-dev = ""
12
13SRC_URI = "http://auslxsc01.mtwk.freescale.net/ppp/${PN}-bin-${PV}.tar.gz"
14SRC_URI[md5sum] = "f934ab967285aad10ec4bb0263ad549f"
15SRC_URI[sha256sum] = "ead4aab7eecad85a591e72996f785057846a7f9801e86ad6441c47862cceac93"
16
17do_install () {
18 install -d ${D}${libdir}
19 install -d ${D}${includedir}
20 install -m 0755 ${S}/usr/lib/* ${D}${libdir}
21 install -m 0644 ${S}/usr/include/* ${D}${includedir}
22}
23
24S = "${WORKDIR}/${PN}-bin-${PV}"