summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/amd-gpu-x11-bin
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-08-18 15:02:23 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2012-09-06 10:43:51 -0300
commit020edff04a8098796a84eb9a053f01acf7c65a2b (patch)
tree250d596c2e9452b24f3d9d2d34101e90a2909d89 /recipes-graphics/amd-gpu-x11-bin
parentea39e05eb6ad6111388862d08fc64c7b06158d9a (diff)
downloadmeta-fsl-arm-020edff04a8098796a84eb9a053f01acf7c65a2b.tar.gz
amd-gpu-x11-bin-mx51: Proper detect the building on Linux
GCC defines __linux__ when running on Linux but the headers where checking by _LINUX define hence enforcing explicit definition by build system; we patch the headers to check for __linux__ and then ensure it "Just Work (TM)". Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Acked-by: Rogerio Pimentel <rogerio.pimentel@freescale.com>
Diffstat (limited to 'recipes-graphics/amd-gpu-x11-bin')
-rw-r--r--recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51/fix-linux-build-check.patch54
-rw-r--r--recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb5
2 files changed, 57 insertions, 2 deletions
diff --git a/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51/fix-linux-build-check.patch b/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51/fix-linux-build-check.patch
new file mode 100644
index 0000000..946bfac
--- /dev/null
+++ b/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51/fix-linux-build-check.patch
@@ -0,0 +1,54 @@
1diff -Nur amd-gpu-x11-bin-mx51-11.09.01.orig/usr/include/EGL/eglext.h amd-gpu-x11-bin-mx51-11.09.01/usr/include/EGL/eglext.h
2--- amd-gpu-x11-bin-mx51-11.09.01.orig/usr/include/EGL/eglext.h 2012-08-18 12:43:19.431788396 -0300
3+++ amd-gpu-x11-bin-mx51-11.09.01/usr/include/EGL/eglext.h 2012-08-18 12:43:50.799909873 -0300
4@@ -164,11 +164,11 @@
5 * nanoseconds (unadjusted standard time). Here, it is defined as
6 * appropriate for an ISO C compiler.
7 */
8-#ifndef _LINUX
9+#ifndef __linux__
10 typedef uint64_t EGLTimeKHR;
11-#else // _LINUX
12+#else // __linux__
13 typedef unsigned long long EGLTimeKHR;
14-#endif // _LINUX
15+#endif // __linux__
16
17 #define EGL_SYNC_PRIOR_COMMANDS_COMPLETE_KHR 0xFFF8
18 #define EGL_SYNC_STATUS_KHR 0xFFF7
19diff -Nur amd-gpu-x11-bin-mx51-11.09.01.orig/usr/include/EGL/eglfslext.h amd-gpu-x11-bin-mx51-11.09.01/usr/include/EGL/eglfslext.h
20--- amd-gpu-x11-bin-mx51-11.09.01.orig/usr/include/EGL/eglfslext.h 2012-08-18 12:43:19.431788396 -0300
21+++ amd-gpu-x11-bin-mx51-11.09.01/usr/include/EGL/eglfslext.h 2012-08-18 12:43:50.759785714 -0300
22@@ -65,7 +65,7 @@
23 } eglYUVInfo;
24 #endif
25
26-#ifdef _LINUX
27+#ifdef __linux__
28 struct EGLImageInfoFSL
29 {
30 void *mem_virt[3]; //virtual addresses for Y/U/V planes
31diff -Nur amd-gpu-x11-bin-mx51-11.09.01.orig/usr/include/VG/ext.h amd-gpu-x11-bin-mx51-11.09.01/usr/include/VG/ext.h
32--- amd-gpu-x11-bin-mx51-11.09.01.orig/usr/include/VG/ext.h 2012-08-18 12:43:19.431788396 -0300
33+++ amd-gpu-x11-bin-mx51-11.09.01/usr/include/VG/ext.h 2012-08-18 12:43:50.799909873 -0300
34@@ -15,7 +15,7 @@
35 extern "C" {
36 #endif
37
38-#ifndef _LINUX
39+#ifndef __linux__
40 #include <VG/openvg.h>
41 #else
42 #include "openvg.h"
43diff -Nur amd-gpu-x11-bin-mx51-11.09.01.orig/usr/include/VG/openvg.h amd-gpu-x11-bin-mx51-11.09.01/usr/include/VG/openvg.h
44--- amd-gpu-x11-bin-mx51-11.09.01.orig/usr/include/VG/openvg.h 2012-08-18 12:43:19.431788396 -0300
45+++ amd-gpu-x11-bin-mx51-11.09.01/usr/include/VG/openvg.h 2012-08-18 12:43:50.799909873 -0300
46@@ -449,7 +449,7 @@
47 # endif
48 # elif defined(__APPLE__)
49 # define VG_API_CALL extern
50-# elif defined(_LINUX)
51+# elif defined(__linux__)
52 # if defined (OPENVG_DLL_EXPORTS)
53 # define VG_API_CALL extern
54 # else
diff --git a/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb b/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb
index 6bf610b..49fdaab 100644
--- a/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb
+++ b/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb
@@ -4,14 +4,15 @@
4DESCRIPTION = "GPU driver and apps for x11 on mx51" 4DESCRIPTION = "GPU driver and apps for x11 on mx51"
5LICENSE = "MIT" 5LICENSE = "MIT"
6SECTION = "libs" 6SECTION = "libs"
7PR = "r7" 7PR = "r8"
8 8
9#todo: Replace for correct AMD license 9#todo: Replace for correct AMD license
10LIC_FILES_CHKSUM = "file://usr/include/VG/openvg.h;endline=30;md5=b0109611dd76961057d4c45ae6519802" 10LIC_FILES_CHKSUM = "file://usr/include/VG/openvg.h;endline=30;md5=b0109611dd76961057d4c45ae6519802"
11DEPENDS = "virtual/libx11 libz160" 11DEPENDS = "virtual/libx11 libz160"
12RDEPENDS = "libz160" 12RDEPENDS = "libz160"
13 13
14SRC_URI = "file://${PN}-${PV}.tar.gz" 14SRC_URI = "file://${PN}-${PV}.tar.gz \
15 file://fix-linux-build-check.patch"
15SRC_URI[md5sum] = "499a2cc08dd48a6c5f7db8d231428548" 16SRC_URI[md5sum] = "499a2cc08dd48a6c5f7db8d231428548"
16SRC_URI[sha256sum] = "6150d3d72a3f8abb26df1e31cee0f07f53c106c8d5de014c1175c8cb721fac29" 17SRC_URI[sha256sum] = "6150d3d72a3f8abb26df1e31cee0f07f53c106c8d5de014c1175c8cb721fac29"
17 18