summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorAdrian Alonso <b38018@freescale.com>2011-08-24 17:05:11 -0500
committerAdrian Alonso <b38018@freescale.com>2011-08-24 17:05:11 -0500
commit6ead7f3e752d988040de55ac0c01540ee7e8d395 (patch)
tree49e2457dbbc696e766ba87f491db94147020a59a /recipes-bsp
parent8dca17285f6493c71d3ec85b5795d2113c48304f (diff)
downloadmeta-fsl-arm-6ead7f3e752d988040de55ac0c01540ee7e8d395.tar.gz
u-boot-imx: bootloader for imx targets
* u-boot-imx package build descriptor for imx targets version 2009.08 Signed-off-by: Adrian Alonso <b38018@freescale.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/uboot/u-boot-imx_2009.08.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-bsp/uboot/u-boot-imx_2009.08.bb b/recipes-bsp/uboot/u-boot-imx_2009.08.bb
new file mode 100644
index 0000000..a2d5105
--- /dev/null
+++ b/recipes-bsp/uboot/u-boot-imx_2009.08.bb
@@ -0,0 +1,27 @@
1# Copyright (C) 2011 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "bootloader for imx platforms"
5require recipes-bsp/uboot/u-boot.inc
6
7LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=4c6cde5df68eff615d36789dc18edd3b"
9#DEPENDS = "elftosb-native"
10PR = "r0"
11
12REL = "11.05.01"
13SRC_URI = "http://opensource.freescale.com/pub/scm/imx/u-boot-${PV}.tar.bz2;name=source \
14 http://opensource.freescale.com/pub/scm/imx/u-boot-v${PV}-imx_${REL}.tar.bz2;name=patchs"
15SRC_URI[source.md5sum] = "cd4788ea1c6ac4f9b100b888a1063a6b"
16SRC_URI[source.sha256sum] = "858fd04efd5b98e99fd1a074998b1a8ac5fbd07b176de1d20d8eb148492d949d"
17SRC_URI[patchs.md5sum] = "951b962a64dbf51da2761b8fab8ed2de"
18SRC_URI[patchs.sha256sum] = "94772a4ffc0de00740802c8acbae339051c85d5eb878bbe202c6c25d66ed255c"
19
20do_patch() {
21 # Apply distributed patchs
22 cd ${S}
23 ln -s ../patches
24 ./patches/patch-uboot.sh
25}
26
27S = "${WORKDIR}/u-boot-${PV}"