summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorEric Bénard <eric@eukrea.com>2012-04-01 15:15:04 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2012-04-01 17:37:22 +0000
commitea694a8ed8804612f9df16261aca74eca8506a77 (patch)
tree7387e4bd6b809f4a6540037b2fb20f9f6ec4410f /recipes-bsp
parent077c1794f2fffaa9d34a03ba4b6810d3cb76c186 (diff)
downloadmeta-fsl-arm-ea694a8ed8804612f9df16261aca74eca8506a77.tar.gz
bootloaders: fix linking when ld-is-gold
Signed-off-by: Eric Bénard <eric@eukrea.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/barebox/barebox.inc3
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2009.08.bb6
-rw-r--r--recipes-bsp/u-boot/u-boot_git.bb6
3 files changed, 15 insertions, 0 deletions
diff --git a/recipes-bsp/barebox/barebox.inc b/recipes-bsp/barebox/barebox.inc
index 1272259..5902f15 100644
--- a/recipes-bsp/barebox/barebox.inc
+++ b/recipes-bsp/barebox/barebox.inc
@@ -26,6 +26,9 @@ do_configure_prepend() {
26} 26}
27 27
28do_compile () { 28do_compile () {
29 if [ "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then
30 sed -i 's/$(CROSS_COMPILE)ld/$(CROSS_COMPILE)ld.bfd/g' Makefile
31 fi
29 unset LDFLAGS 32 unset LDFLAGS
30 unset CFLAGS 33 unset CFLAGS
31 unset CPPFLAGS 34 unset CPPFLAGS
diff --git a/recipes-bsp/u-boot/u-boot-imx_2009.08.bb b/recipes-bsp/u-boot/u-boot-imx_2009.08.bb
index 3471d36..02f2e3e 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2009.08.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2009.08.bb
@@ -16,3 +16,9 @@ SRC_URI = "git://opensource.freescale.com/pub/scm/imx/uboot-imx.git;tag=rel_imx_
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17 17
18PACKAGE_ARCH = "${MACHINE_ARCH}" 18PACKAGE_ARCH = "${MACHINE_ARCH}"
19
20do_compile_prepend() {
21 if [ "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then
22 sed -i 's/$(CROSS_COMPILE)ld/$(CROSS_COMPILE)ld.bfd/g' config.mk
23 fi
24}
diff --git a/recipes-bsp/u-boot/u-boot_git.bb b/recipes-bsp/u-boot/u-boot_git.bb
index 112f6fa..7c1febf 100644
--- a/recipes-bsp/u-boot/u-boot_git.bb
+++ b/recipes-bsp/u-boot/u-boot_git.bb
@@ -22,3 +22,9 @@ SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git \
22S = "${WORKDIR}/git" 22S = "${WORKDIR}/git"
23 23
24PACKAGE_ARCH = "${MACHINE_ARCH}" 24PACKAGE_ARCH = "${MACHINE_ARCH}"
25
26do_compile_prepend() {
27 if [ "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then
28 sed -i 's/$(CROSS_COMPILE)ld/$(CROSS_COMPILE)ld.bfd/g' config.mk
29 fi
30}