summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorLauren Post <lauren.post@freescale.com>2015-01-23 10:28:16 -0600
committerOtavio Salvador <otavio@ossystems.com.br>2015-01-27 09:10:43 -0200
commitb9b853939a28dc499485e9eaaa4fdb32a71dd593 (patch)
tree5b9dbe43204fbb7549f3ff2a0cacb054fd0e13a9 /recipes-bsp
parentdcc441b249607ef4c03c2cfd9073d232223fd3cc (diff)
downloadmeta-fsl-arm-b9b853939a28dc499485e9eaaa4fdb32a71dd593.tar.gz
imx-test: Upgrade to 3.10.53-1.1.0_GA release
- Update makefiles to work with toolchain changes from dizzy on. - mxc-asrc: Enlarge the buffer size, change audio files - mxc-securebooth: Change the u-boot pad len calculation - mcc: Change the dword signing in to be string - memtool: Add auto complete feature for memtool - vpu: H.264 VUI encoding, - gpu: Add debug scripts - mmdc: Enable 16/32 bit system suport for tool mmdc2 - als_test: Get input event index correctly - uart: Add stress test amd fix bugs - pxp v4l2: Add UYVY and YUV444 support Remove parts of Fix-build-in-OpenEmbedded-Core-environment.patch that are invalid with 3.10.53 Makefile changes. Imx-test Makefiles corrected to load the standard libraries correctly for mxc_vpu, memtool and mmdc tests. Signed-off-by: Lauren Post <lauren.post@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch39
-rw-r--r--recipes-bsp/imx-test/imx-test_3.10.31-1.1.0.bb18
-rw-r--r--recipes-bsp/imx-test/imx-test_3.10.53-1.1.0.bb15
3 files changed, 15 insertions, 57 deletions
diff --git a/recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch b/recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch
index c5daa69..7497e91 100644
--- a/recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch
+++ b/recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch
@@ -25,45 +25,6 @@ index 92e2901..75d3e78 100755
25 25
26 clean: 26 clean:
27 rm -f *.o hciattach-ar3k.bin 27 rm -f *.o hciattach-ar3k.bin
28diff --git a/test/make.rules b/test/make.rules
29index 8982f36..7ff8b38 100755
30--- a/test/make.rules
31+++ b/test/make.rules
32@@ -33,7 +33,7 @@ $(OBJDIR)/%.out : $(SRCDIR)/%.c
33 $(OBJDIR)/%.out : $(SRCDIR)/%.s
34 @mkdir -p `dirname $@`
35 @echo " Building $@"
36- $(VERBOSE)$(CC) -g $(INC) $(CFLAGS) -DASSEMBLER $< -o $@
37+ $(VERBOSE)$(CC) -g $(INC) $(CFLAGS)-DASSEMBLER $< -o $@
38
39 $(OBJDIR)/%.out : $(SRCDIR)/%.S
40 @mkdir -p `dirname $@`
41diff --git a/test/memtool/Makefile b/test/memtool/Makefile
42index 7a72803..c3083a0 100644
43--- a/test/memtool/Makefile
44+++ b/test/memtool/Makefile
45@@ -20,7 +20,7 @@ CFLAGS+= -Os
46 all : $(TARGET)
47
48 $(TARGET):$(OBJ)
49- $(LINK) -o $(TARGET) $(OBJ) -Os
50+ $(LINK) -o $(TARGET) $(OBJ) $(LDFLAGS) -Os
51 $(STRIP) $(TARGET)
52
53 .PHONY: clean
54diff --git a/test/mxc_vpu_test/Makefile b/test/mxc_vpu_test/Makefile
55index 6ab989c..985b311 100644
56--- a/test/mxc_vpu_test/Makefile
57+++ b/test/mxc_vpu_test/Makefile
58@@ -23,7 +23,7 @@ endif
59 all: $(TARGET)
60
61 $(TARGET): $(OBJ)
62- $(LINK) -o $(TARGET) $(OBJ) ${LIBS} -lvpu -lipu -lrt -lpthread
63+ $(LINK) -o $(TARGET) $(OBJ) ${LIBS} $(LDFLAGS) -lvpu -lipu -lrt -lpthread
64 mkdir -p $(OBJDIR)
65 mv $(TARGET) $(OBJDIR)
66 cp autorun-vpu.sh $(OBJDIR)
67-- 28--
682.1.4 292.1.4
69 30
diff --git a/recipes-bsp/imx-test/imx-test_3.10.31-1.1.0.bb b/recipes-bsp/imx-test/imx-test_3.10.31-1.1.0.bb
deleted file mode 100644
index b5b5024..0000000
--- a/recipes-bsp/imx-test/imx-test_3.10.31-1.1.0.bb
+++ /dev/null
@@ -1,18 +0,0 @@
1# Copyright (C) 2013, 2014 Freescale Semiconductor
2
3include imx-test.inc
4
5# FIXME: Drop 'beta' suffix for GA release
6SRC_URI = "${FSL_MIRROR}/${PN}-${PV}-beta.tar.gz \
7 file://Fix-build-in-OpenEmbedded-Core-environment.patch"
8S = "${WORKDIR}/${PN}-${PV}-beta"
9
10SRC_URI_append_mx5 = " file://revert_epdc_hdr_change.patch \
11 file://clocks.sh"
12SRC_URI_append_mxs = " file://revert_epdc_hdr_change.patch \
13 file://clocks.sh"
14
15SRC_URI[md5sum] = "6170af41652f1f213d1a86340e103797"
16SRC_URI[sha256sum] = "6aa33ef21932ca0349dbda05b6b151d5d705663180abc5f860670293251aef54"
17
18COMPATIBLE_MACHINE = "(mxs|mx5|mx6)"
diff --git a/recipes-bsp/imx-test/imx-test_3.10.53-1.1.0.bb b/recipes-bsp/imx-test/imx-test_3.10.53-1.1.0.bb
new file mode 100644
index 0000000..e7b80b5
--- /dev/null
+++ b/recipes-bsp/imx-test/imx-test_3.10.53-1.1.0.bb
@@ -0,0 +1,15 @@
1# Copyright (C) 2013-2015 Freescale Semiconductor
2
3include imx-test.inc
4
5SRC_URI += "file://Fix-build-in-OpenEmbedded-Core-environment.patch"
6
7SRC_URI_append_mx5 = " file://revert_epdc_hdr_change.patch \
8 file://clocks.sh"
9SRC_URI_append_mxs = " file://revert_epdc_hdr_change.patch \
10 file://clocks.sh"
11
12SRC_URI[md5sum] = "9a866ceb8c4f5fd2b3bdc7f054544987"
13SRC_URI[sha256sum] = "a578c773ec3314572e56e8c5984dc5aec9d7195958d4aae47c225df8ca0fbdd7"
14
15COMPATIBLE_MACHINE = "(mxs|mx5|mx6)"