summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-01-19 17:24:14 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2015-01-22 14:03:14 -0200
commit4241de6adfb509b3d306ae6d9cf6e5af188a712d (patch)
tree24a8066fd0e3fadf89f2e20603f4a3e35bddd2dd /recipes-bsp
parent0ed4d4fc48820912b30df6c59ff99960777d79ed (diff)
downloadmeta-fsl-arm-4241de6adfb509b3d306ae6d9cf6e5af188a712d.tar.gz
imx-test: Fix linking failures of test utilities
Some of the unit-tests were not being built due to differences on how the build system behaves when running inside of the OE-Core. This fixes those minor issues and increases the number of tests available. This increases the number of tests which build successfully. The new built tests, when building for i.MX6Q are: ,---- | /unit_tests/hciattach-ar3k.bin | /unit_tests/config_dec | /unit_tests/akiyo.mp4 | /unit_tests/config_net | /unit_tests/mxc_vpu_test.out | /unit_tests/config_encdec | /unit_tests/autorun-vpu.sh | /unit_tests/memtool | /unit_tests/config_enc `---- When building for i.MX53 those are: ,---- | /unit_tests/hciattach-ar3k.bin | /unit_tests/memtool `---- And when building for i.MX28 those are: ,---- | /unit_tests/mxc_pf_test.out | /unit_tests/mmdc2 | /unit_tests/key_slot_tests.sh | /unit_tests/mxc_isl29023.out | /unit_tests/partition_tests.sh | /unit_tests/fail_mode_tests.sh | /unit_tests/scc_test | /unit_tests/scc2_setup.sh | /unit_tests/autorun-scc2.sh | /unit_tests/autorun-scc.sh | /unit_tests/encrypt_decrypt_tests.sh | /unit_tests/mxc_fb_test.out | /unit_tests/memtool | /unit_tests/scc2_test.out | /unit_tests/autorun.sh | /unit_tests/mxc_mlb_test.out | /unit_tests/scc_setup.sh | /unit_tests/test_subs.sh | /unit_tests/all-suite.txt `---- Change-Id: I58882adc22990d9ec53dc9ead034e85acd64375e Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/imx-test/imx-test.inc3
-rw-r--r--recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch69
-rw-r--r--recipes-bsp/imx-test/imx-test_3.10.31-1.1.0.bb5
3 files changed, 74 insertions, 3 deletions
diff --git a/recipes-bsp/imx-test/imx-test.inc b/recipes-bsp/imx-test/imx-test.inc
index 6832498..6e41f61 100644
--- a/recipes-bsp/imx-test/imx-test.inc
+++ b/recipes-bsp/imx-test/imx-test.inc
@@ -35,7 +35,8 @@ do_make_scripts[deptask] = "do_populate_sysroot"
35do_make_scripts[depends] += "virtual/kernel:do_install" 35do_make_scripts[depends] += "virtual/kernel:do_install"
36 36
37do_compile() { 37do_compile() {
38 unset LDFLAGS 38 CFLAGS="${TOOLCHAIN_OPTIONS}"
39 LDFLAGS="${TOOLCHAIN_OPTIONS} -L${STAGING_LIBDIR}"
39 oe_runmake V=1 VERBOSE='' \ 40 oe_runmake V=1 VERBOSE='' \
40 CROSS_COMPILE=${TARGET_PREFIX} \ 41 CROSS_COMPILE=${TARGET_PREFIX} \
41 INC="-I${STAGING_INCDIR} \ 42 INC="-I${STAGING_INCDIR} \
diff --git a/recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch b/recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch
new file mode 100644
index 0000000..c5daa69
--- /dev/null
+++ b/recipes-bsp/imx-test/imx-test/Fix-build-in-OpenEmbedded-Core-environment.patch
@@ -0,0 +1,69 @@
1From fd826140db0f2a867ef588cccf2e5322cc77126a Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Mon, 19 Jan 2015 16:56:29 -0200
4Subject: [PATCH] Fix build in OpenEmbedded-Core environment
5Organization: O.S. Systems Software LTDA.
6
7Some of the unit-tests were not being built due to differences on how
8the build system behaves when running inside of the OE-Core. This
9fixes those minor issues and increases the number of tests available.
10
11Upstream-Status: Pending
12
13Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
14
15diff --git a/test/ar3k_bt/Makefile b/test/ar3k_bt/Makefile
16index 92e2901..75d3e78 100755
17--- a/test/ar3k_bt/Makefile
18+++ b/test/ar3k_bt/Makefile
19@@ -21,7 +21,7 @@ all: $(OBJS)
20 CFLAGS += -lbluetooth
21
22 $(OBJDIR)/hciattach-ar3k.bin :
23- $(CC) ${INC} -Wall -lbluetooth -g hciattach_ath3k.c hciattach.c hciattach_qualcomm.c hciattach_st.c hciattach_tialt.c hciattach_ti.c -o hciattach-ar3k.bin
24+ $(CC) ${INC} -Wall -lbluetooth -g hciattach_ath3k.c hciattach.c hciattach_qualcomm.c hciattach_st.c hciattach_tialt.c hciattach_ti.c -o $(OBJDIR)/hciattach-ar3k.bin
25
26 clean:
27 rm -f *.o hciattach-ar3k.bin
28diff --git a/test/make.rules b/test/make.rules
29index 8982f36..7ff8b38 100755
30--- a/test/make.rules
31+++ b/test/make.rules
32@@ -33,7 +33,7 @@ $(OBJDIR)/%.out : $(SRCDIR)/%.c
33 $(OBJDIR)/%.out : $(SRCDIR)/%.s
34 @mkdir -p `dirname $@`
35 @echo " Building $@"
36- $(VERBOSE)$(CC) -g $(INC) $(CFLAGS) -DASSEMBLER $< -o $@
37+ $(VERBOSE)$(CC) -g $(INC) $(CFLAGS)-DASSEMBLER $< -o $@
38
39 $(OBJDIR)/%.out : $(SRCDIR)/%.S
40 @mkdir -p `dirname $@`
41diff --git a/test/memtool/Makefile b/test/memtool/Makefile
42index 7a72803..c3083a0 100644
43--- a/test/memtool/Makefile
44+++ b/test/memtool/Makefile
45@@ -20,7 +20,7 @@ CFLAGS+= -Os
46 all : $(TARGET)
47
48 $(TARGET):$(OBJ)
49- $(LINK) -o $(TARGET) $(OBJ) -Os
50+ $(LINK) -o $(TARGET) $(OBJ) $(LDFLAGS) -Os
51 $(STRIP) $(TARGET)
52
53 .PHONY: clean
54diff --git a/test/mxc_vpu_test/Makefile b/test/mxc_vpu_test/Makefile
55index 6ab989c..985b311 100644
56--- a/test/mxc_vpu_test/Makefile
57+++ b/test/mxc_vpu_test/Makefile
58@@ -23,7 +23,7 @@ endif
59 all: $(TARGET)
60
61 $(TARGET): $(OBJ)
62- $(LINK) -o $(TARGET) $(OBJ) ${LIBS} -lvpu -lipu -lrt -lpthread
63+ $(LINK) -o $(TARGET) $(OBJ) ${LIBS} $(LDFLAGS) -lvpu -lipu -lrt -lpthread
64 mkdir -p $(OBJDIR)
65 mv $(TARGET) $(OBJDIR)
66 cp autorun-vpu.sh $(OBJDIR)
67--
682.1.4
69
diff --git a/recipes-bsp/imx-test/imx-test_3.10.31-1.1.0.bb b/recipes-bsp/imx-test/imx-test_3.10.31-1.1.0.bb
index 2d29eb7..b5b5024 100644
--- a/recipes-bsp/imx-test/imx-test_3.10.31-1.1.0.bb
+++ b/recipes-bsp/imx-test/imx-test_3.10.31-1.1.0.bb
@@ -3,8 +3,9 @@
3include imx-test.inc 3include imx-test.inc
4 4
5# FIXME: Drop 'beta' suffix for GA release 5# FIXME: Drop 'beta' suffix for GA release
6SRC_URI = "${FSL_MIRROR}/${PN}-${PV}-beta.tar.gz" 6SRC_URI = "${FSL_MIRROR}/${PN}-${PV}-beta.tar.gz \
7S="${WORKDIR}/${PN}-${PV}-beta" 7 file://Fix-build-in-OpenEmbedded-Core-environment.patch"
8S = "${WORKDIR}/${PN}-${PV}-beta"
8 9
9SRC_URI_append_mx5 = " file://revert_epdc_hdr_change.patch \ 10SRC_URI_append_mx5 = " file://revert_epdc_hdr_change.patch \
10 file://clocks.sh" 11 file://clocks.sh"