summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorDaiane Angolini <daiane.angolini@freescale.com>2014-11-20 17:17:57 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2014-11-24 18:38:55 -0200
commit21df40d9fae3be09f15de488790cc30eb4e08236 (patch)
tree506d18421df947f3b80a9226802143c35aea1355 /recipes-bsp
parent3bdd3bd04214e0941b31231e02a8636a6aba101e (diff)
downloadmeta-fsl-arm-21df40d9fae3be09f15de488790cc30eb4e08236.tar.gz
u-boot-*: Rework LOCALVERSION depending on SRCBRANCH
LOCALVERSION is used in FSL Community BSP Release Notes and should highlight which are the _release version_ for that particular provider. In addition LOCALVERSION makes it easy to track where the binary running on a target is from. Both reasons make LOCALVERSION a very important information. The overall rule is that LOCALVERSION would point to SRCBRANCH, unless in a case of explicit exception. Signed-off-by: Daiane Angolini <daiane.angolini@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2009.08.bb2
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2013.04.bb2
-rw-r--r--recipes-bsp/u-boot/u-boot-ls1.inc2
-rw-r--r--recipes-bsp/u-boot/u-boot-ls1_2013.10.bb2
4 files changed, 5 insertions, 3 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx_2009.08.bb b/recipes-bsp/u-boot/u-boot-imx_2009.08.bb
index c067999..5a831ec 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2009.08.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2009.08.bb
@@ -56,7 +56,7 @@ EXTRA_OEMAKE += 'HOSTSTRIP=true'
56 56
57inherit fsl-u-boot-localversion 57inherit fsl-u-boot-localversion
58 58
59LOCALVERSION = "+imx" 59LOCALVERSION ?= "-${SRCBRANCH}"
60 60
61do_compile_prepend() { 61do_compile_prepend() {
62 if [ "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then 62 if [ "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then
diff --git a/recipes-bsp/u-boot/u-boot-imx_2013.04.bb b/recipes-bsp/u-boot/u-boot-imx_2013.04.bb
index 28574f8..676fc5b 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2013.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2013.04.bb
@@ -16,7 +16,7 @@ S = "${WORKDIR}/git"
16 16
17inherit fsl-u-boot-localversion 17inherit fsl-u-boot-localversion
18 18
19LOCALVERSION = "+imx" 19LOCALVERSION ?= "-${SRCBRANCH}"
20 20
21PACKAGE_ARCH = "${MACHINE_ARCH}" 21PACKAGE_ARCH = "${MACHINE_ARCH}"
22COMPATIBLE_MACHINE = "(mx6)" 22COMPATIBLE_MACHINE = "(mx6)"
diff --git a/recipes-bsp/u-boot/u-boot-ls1.inc b/recipes-bsp/u-boot/u-boot-ls1.inc
index 371773f..9e10ea5 100644
--- a/recipes-bsp/u-boot/u-boot-ls1.inc
+++ b/recipes-bsp/u-boot/u-boot-ls1.inc
@@ -12,4 +12,6 @@ SRCBRANCH = "LS1-dev"
12SRC_URI = "git://git.freescale.com/layerscape/ls1021a/u-boot.git;branch=${SRCBRANCH}" 12SRC_URI = "git://git.freescale.com/layerscape/ls1021a/u-boot.git;branch=${SRCBRANCH}"
13SRCREV = "50d684801cd05ed6b77d52d1ca9ed00fefeac469" 13SRCREV = "50d684801cd05ed6b77d52d1ca9ed00fefeac469"
14 14
15LOCALVERSION ?= "-${SRCBRANCH}"
16
15S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
diff --git a/recipes-bsp/u-boot/u-boot-ls1_2013.10.bb b/recipes-bsp/u-boot/u-boot-ls1_2013.10.bb
index f50c144..06f6d2f 100644
--- a/recipes-bsp/u-boot/u-boot-ls1_2013.10.bb
+++ b/recipes-bsp/u-boot/u-boot-ls1_2013.10.bb
@@ -2,7 +2,7 @@ require recipes-bsp/u-boot/u-boot.inc
2require u-boot-ls1.inc 2require u-boot-ls1.inc
3inherit fsl-u-boot-localversion 3inherit fsl-u-boot-localversion
4 4
5LOCALVERSION ?= "+ls1" 5LOCALVERSION ?= "-SDK-V1.3"
6 6
7DEPENDS += "u-boot-ls1-tools-native" 7DEPENDS += "u-boot-ls1-tools-native"
8PROVIDES += "u-boot" 8PROVIDES += "u-boot"