summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2014-10-10 19:18:10 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2014-10-23 22:48:00 -0200
commit1621191e108c046ec3dd2612f6e5df25f61f23f4 (patch)
tree74c77647b72429303d6d2e3f39c7316ba1ab95ec /recipes-bsp
parentb760d70e3d4cf3e7242c9dc58814c15bb68b21ca (diff)
downloadmeta-fsl-arm-1621191e108c046ec3dd2612f6e5df25f61f23f4.tar.gz
u-boot-fslc: Update to 2014.10 upcoming release
This updates the U-Boot to the 2014.10 based branch. On top of the original code we still have following changes applied: 75ce95e embestmx6boards: Change default bootenv configuration 472bfb3 ot1200: add sata support 4e8b5ee ot1200: fix sf detection 857ccfd ARM: i.MX6: include prototype for get_board_rev() 2b542e6 video: ipu_disp: remove pixclk fixup 499a8ca video: ipu: fix debug and comment c970aa2 lcd: Fix build error with CONFIG_LCD_BMP_RLE8 37a6b36 mx6sabre_common: Add HDMI config to common code 56f29bf mx6qsabreauto: Add HDMI support 2878ac3 ot1200: remove superfluous "string" tag d2104d6 ARM: i.MX video: declare displays and display_count publicly 2d6e2ec ARM: i.MX: provide declaration for board_spi_cs_gpio d09ced3 ARM: prevent compiler warnings from bootm.c 34fd658 wandboard: Use 32bit color depth for Fusion LCD 92e4fa9 mx6sabresd: Use LDO dtb file until LDO bypass support is added d859ee7 mx6slevk: Use LDO dtb file until LDO bypass support is added 47ac5b6 mx6sabresd: Use mmcblk0 for CONFIG_MMCROOT Due the changes on the way U-Boot works now, heavily relying on kconfig, it is required to use the 'configure' step to properly setup it for the 'sandbox' before building the tools. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mxsboot_2014.10.bb (renamed from recipes-bsp/u-boot/u-boot-fslc-mxsboot_2014.07.bb)12
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc.inc2
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2014.07.bb6
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2014.10.bb6
4 files changed, 15 insertions, 11 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2014.07.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2014.10.bb
index 76a8409..e4aaf36 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2014.07.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2014.10.bb
@@ -1,14 +1,14 @@
1DESCRIPTION = "U-boot bootloader mxsboot tool" 1DESCRIPTION = "U-boot bootloader mxsboot tool"
2LICENSE = "GPLv2+" 2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb" 3LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
4SECTION = "bootloader" 4SECTION = "bootloader"
5DEPENDS = "openssl" 5DEPENDS = "openssl"
6PROVIDES = "u-boot-mxsboot" 6PROVIDES = "u-boot-mxsboot"
7 7
8PV = "v2014.07" 8PV = "v2014.10+git${SRCPV}"
9 9
10SRCREV = "e36968af0a033e9d66535928886103370620cb4d" 10SRCREV = "75ce95e627609c9b9e537e935e69c4ecef26c8f7"
11SRCBRANCH = "patches-2014.07" 11SRCBRANCH = "patches-2014.10"
12SRC_URI = "git://github.com/Freescale/u-boot-imx.git;branch=${SRCBRANCH}" 12SRC_URI = "git://github.com/Freescale/u-boot-imx.git;branch=${SRCBRANCH}"
13 13
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
@@ -17,6 +17,10 @@ inherit fsl-u-boot-localversion
17 17
18EXTRA_OEMAKE = 'HOSTCC="${CC} ${CPPFLAGS}" HOSTLDFLAGS="-L${libdir} -L${base_libdir}" HOSTSTRIP=true CONFIG_MX28=y' 18EXTRA_OEMAKE = 'HOSTCC="${CC} ${CPPFLAGS}" HOSTLDFLAGS="-L${libdir} -L${base_libdir}" HOSTSTRIP=true CONFIG_MX28=y'
19 19
20do_configure () {
21 oe_runmake sandbox_defconfig
22}
23
20do_compile () { 24do_compile () {
21 oe_runmake tools-only 25 oe_runmake tools-only
22} 26}
diff --git a/recipes-bsp/u-boot/u-boot-fslc.inc b/recipes-bsp/u-boot/u-boot-fslc.inc
index a1e4de8..e598b1f 100644
--- a/recipes-bsp/u-boot/u-boot-fslc.inc
+++ b/recipes-bsp/u-boot/u-boot-fslc.inc
@@ -7,7 +7,7 @@ inherit fsl-u-boot-localversion
7 7
8DESCRIPTION = "U-boot bootloader for Freescale ARM platforms" 8DESCRIPTION = "U-boot bootloader for Freescale ARM platforms"
9LICENSE = "GPLv2+" 9LICENSE = "GPLv2+"
10LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb" 10LIC_FILES_CHKSUM = "file://Licenses/README;md5=c7383a594871c03da76b3707929d2919"
11COMPATIBLE_MACHINE = "(mxs|mx3|mx5|mx6|vf60)" 11COMPATIBLE_MACHINE = "(mxs|mx3|mx5|mx6|vf60)"
12 12
13DEPENDS_mxs += "elftosb-native openssl-native" 13DEPENDS_mxs += "elftosb-native openssl-native"
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2014.07.bb b/recipes-bsp/u-boot/u-boot-fslc_2014.07.bb
deleted file mode 100644
index 6991baa..0000000
--- a/recipes-bsp/u-boot/u-boot-fslc_2014.07.bb
+++ /dev/null
@@ -1,6 +0,0 @@
1include u-boot-fslc.inc
2
3PV = "v2014.07"
4
5SRCREV = "e36968af0a033e9d66535928886103370620cb4d"
6SRCBRANCH = "patches-2014.07"
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2014.10.bb b/recipes-bsp/u-boot/u-boot-fslc_2014.10.bb
new file mode 100644
index 0000000..860e9a4
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc_2014.10.bb
@@ -0,0 +1,6 @@
1include u-boot-fslc.inc
2
3PV = "v2014.10+git${SRCPV}"
4
5SRCREV = "75ce95e627609c9b9e537e935e69c4ecef26c8f7"
6SRCBRANCH = "patches-2014.10"