summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorDaiane Angolini <daiane.angolini@freescale.com>2013-03-15 14:24:00 -0300
committerDaiane Angolini <daiane.angolini@freescale.com>2013-03-22 07:01:34 -0500
commitd471ff8a53fbe7307133380ca105099b6b3bf74c (patch)
treeaf7fd839dd8a98900c0d42edb4f10decd450ff9f /recipes-bsp/u-boot
parent56320cff219bcb234794992733b9e6c552a42853 (diff)
downloadmeta-fsl-arm-d471ff8a53fbe7307133380ca105099b6b3bf74c.tar.gz
u-boot (2009.08): Add imx6slevk support
iMX6SL EVK u-boot from Freescale 3.0.0 BSP Change-Id: Iedb942f3f1669991711c3b6bffb409ed288180e8 Signed-off-by: Daiane Angolini <daiane.angolini@freescale.com>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot-imx/mx6sl_evk-Fix-the-patch-for-the-default-environment-.patch67
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2009.08.bb8
2 files changed, 74 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx/mx6sl_evk-Fix-the-patch-for-the-default-environment-.patch b/recipes-bsp/u-boot/u-boot-imx/mx6sl_evk-Fix-the-patch-for-the-default-environment-.patch
new file mode 100644
index 0000000..5d3f868
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-imx/mx6sl_evk-Fix-the-patch-for-the-default-environment-.patch
@@ -0,0 +1,67 @@
1From bf99fdddbca321f7e74ed82febbe4b5539e3ac66 Mon Sep 17 00:00:00 2001
2From: Daiane Angolini <daiane.angolini@freescale.com>
3Date: Thu, 14 Mar 2013 16:35:35 -0300
4Subject: [PATCH] mx6sl_evk: Change the patch for the default environment
5 variable
6
7Upstream-Status: Pending
8
9Signed-off-by: Daiane Angolini <daiane.angolini@freescale.com>
10---
11 include/configs/mx6sl_evk.h | 40 ++++++++++++++++++++++++----------------
12 1 file changed, 24 insertions(+), 16 deletions(-)
13
14diff --git a/include/configs/mx6sl_evk.h b/include/configs/mx6sl_evk.h
15index 4c327bc..dfb6374 100644
16--- a/include/configs/mx6sl_evk.h
17+++ b/include/configs/mx6sl_evk.h
18@@ -122,22 +122,30 @@
19 #define CONFIG_RD_LOADADDR 0x81000000
20
21 #define CONFIG_EXTRA_ENV_SETTINGS \
22- "netdev=eth0\0" \
23- "ethprime=FEC0\0" \
24- "uboot=u-boot.bin\0" \
25- "kernel=uImage\0" \
26- "nfsroot=/opt/eldk/arm\0" \
27- "bootargs_base=setenv bootargs console=ttymxc0,115200\0"\
28- "bootargs_nfs=setenv bootargs ${bootargs} root=/dev/nfs "\
29- "ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp\0"\
30- "bootcmd_net=run bootargs_base bootargs_nfs; " \
31- "tftpboot ${loadaddr} ${kernel}; bootm\0" \
32- "bootargs_mmc=setenv bootargs ${bootargs} " \
33- "root=/dev/mmcblk0p1 rootwait\0" \
34- "bootcmd_mmc=run bootargs_base bootargs_mmc; " \
35- "mmc dev 1; " \
36- "mmc read ${loadaddr} 0x800 0x2000; bootm\0" \
37- "bootcmd=run bootcmd_mmc\0" \
38+ "script=boot.scr\0" \
39+ "uimage=uImage\0" \
40+ "mmcdev=1\0" \
41+ "mmcpart=1\0" \
42+ "mmcroot=/dev/mmcblk0p2 rw\0" \
43+ "mmcrootfstype=ext3 rootwait\0" \
44+ "mmcargs=setenv bootargs console=ttymxc0,${baudrate} " \
45+ "root=${mmcroot} " \
46+ "rootfstype=${mmcrootfstype}\0" \
47+ "loadbootscript=" \
48+ "fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${script};\0" \
49+ "bootscript=echo Running bootscript from mmc ...; " \
50+ "source\0" \
51+ "loaduimage=fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${uimage}\0" \
52+ "mmcboot=echo Booting from mmc ...; " \
53+ "run mmcargs; " \
54+ "bootm\0" \
55+ "netargs=setenv bootargs console=ttymxc0,${baudrate} " \
56+ "root=/dev/nfs " \
57+ "ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp\0" \
58+ "netboot=echo Booting from net ...; " \
59+ "run netargs; " \
60+ "dhcp ${uimage}; bootm\0" \
61+ "bootcmd=run loaduimage; run mmcboot;\0" \
62
63
64 #define CONFIG_ARP_TIMEOUT 200UL
65--
661.7.10.4
67
diff --git a/recipes-bsp/u-boot/u-boot-imx_2009.08.bb b/recipes-bsp/u-boot/u-boot-imx_2009.08.bb
index 2ddbd15..cd413d6 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2009.08.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2009.08.bb
@@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4c6cde5df68eff615d36789dc18edd3b"
11 11
12DEPENDS_mxs += "elftosb-native" 12DEPENDS_mxs += "elftosb-native"
13 13
14PR = "r12" 14PR = "r13"
15 15
16# Revision of imx_2.6.35_10.12.01 branch 16# Revision of imx_2.6.35_10.12.01 branch
17SRCREV_mxs = "e4437f1c192a1a68028e6fcff3f50ff50352041d" 17SRCREV_mxs = "e4437f1c192a1a68028e6fcff3f50ff50352041d"
@@ -29,6 +29,11 @@ SRC_URI_append_mx6 = " \
29 file://mx6q_sabresd-Change-default-environment-to-work-with.patch \ 29 file://mx6q_sabresd-Change-default-environment-to-work-with.patch \
30" 30"
31 31
32# Revision of imx_3.0.35_3.0.0 branch
33SRCREV_mx6sl = "d4057eba315edbc8335c138c0c9edbe2109ea36e"
34SRC_URI_append_mx6sl = " \
35 file://mx6sl_evk-Fix-the-patch-for-the-default-environment-.patch \
36"
32 37
33SRC_URI = "git://git.freescale.com/imx/uboot-imx.git" 38SRC_URI = "git://git.freescale.com/imx/uboot-imx.git"
34 39
@@ -38,6 +43,7 @@ UBOOT_MACHINE_imx51evk = "mx51_bbg_config"
38UBOOT_MACHINE_imx6qsabrelite = "mx6q_sabrelite_config" 43UBOOT_MACHINE_imx6qsabrelite = "mx6q_sabrelite_config"
39UBOOT_MACHINE_imx6qsabreauto = "mx6q_sabreauto_config" 44UBOOT_MACHINE_imx6qsabreauto = "mx6q_sabreauto_config"
40UBOOT_MACHINE_imx6qsabresd = "mx6q_sabresd_config" 45UBOOT_MACHINE_imx6qsabresd = "mx6q_sabresd_config"
46UBOOT_MACHINE_imx6slevk = "mx6sl_evk_config"
41UBOOT_MACHINE_imx28evk = "mx28_evk_config" 47UBOOT_MACHINE_imx28evk = "mx28_evk_config"
42 48
43UBOOT_MAKE_TARGET = "u-boot.bin" 49UBOOT_MAKE_TARGET = "u-boot.bin"