summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorLauren Post <lauren.post@freescale.com>2014-09-04 08:13:00 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2014-11-10 18:55:22 -0200
commita4a12cfc16ee25f0843a3a9bb4611f428790f084 (patch)
treee0cb67973942794e4cc0308adc8cc44d63431ffa /recipes-bsp/u-boot
parent7bdeb7b460552d5ad4fa221877cbb3174cb02707 (diff)
downloadmeta-fsl-arm-a4a12cfc16ee25f0843a3a9bb4611f428790f084.tar.gz
u-boot-fslc: Add patch to work with 3.10.31-1.1.0_beta kernel
3.10.31 linux-imx has update to work with fixed mmc blocks Without this patch the community u-boot will not boot on some mx6 boards. Signed-off-by: Lauren Post <lauren.post@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc/iMX6-Change-mmcroot-to-use-fixed-mmc-block-index-for.patch92
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2014.10.bb3
2 files changed, 95 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc/iMX6-Change-mmcroot-to-use-fixed-mmc-block-index-for.patch b/recipes-bsp/u-boot/u-boot-fslc/iMX6-Change-mmcroot-to-use-fixed-mmc-block-index-for.patch
new file mode 100644
index 0000000..b1a8b8a
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc/iMX6-Change-mmcroot-to-use-fixed-mmc-block-index-for.patch
@@ -0,0 +1,92 @@
1From 6148f4558952fd04d76ec5494447a678df9d79d4 Mon Sep 17 00:00:00 2001
2From: "Ye.Li" <Ye.Li@freescale.com>
3Date: Mon, 1 Sep 2014 10:33:47 +0800
4Subject: [PATCH] iMX6: Change mmcroot to use fixed mmc block index for USDHC
5Organization: O.S. Systems Software LTDA.
6
7Kernel changed to use fixed mmcblk index for USDHC, which is
8mmcblk0 --> USDHC1
9mmcblk1 --> USDHC2
10mmcblk2 --> USDHC3
11mmcblk3 --> USDHC4
12Thus, change the default mmcroot in u-boot to fit the changes in kernel.
13
14Upstream-Status: Pending
15
16Signed-off-by: Ye.Li <Ye.Li@freescale.com>
17---
18 include/configs/mx6qarm2.h | 2 +-
19 include/configs/mx6qsabreauto.h | 2 +-
20 include/configs/mx6sabresd.h | 2 +-
21 include/configs/mx6slevk.h | 2 +-
22 include/configs/mx6sxsabresd.h | 2 +-
23 5 files changed, 5 insertions(+), 5 deletions(-)
24
25diff --git a/include/configs/mx6qarm2.h b/include/configs/mx6qarm2.h
26index 6e01fa0..b1719b9 100644
27--- a/include/configs/mx6qarm2.h
28+++ b/include/configs/mx6qarm2.h
29@@ -83,7 +83,7 @@
30 "ip_dyn=yes\0" \
31 "mmcdev=1\0" \
32 "mmcpart=1\0" \
33- "mmcroot=/dev/mmcblk0p2 rootwait rw\0" \
34+ "mmcroot=/dev/mmcblk3p2 rootwait rw\0" \
35 "mmcargs=setenv bootargs console=${console},${baudrate} " \
36 "root=${mmcroot}\0" \
37 "loadbootscript=" \
38diff --git a/include/configs/mx6qsabreauto.h b/include/configs/mx6qsabreauto.h
39index 0ab3127..cca9c8f 100644
40--- a/include/configs/mx6qsabreauto.h
41+++ b/include/configs/mx6qsabreauto.h
42@@ -17,7 +17,7 @@
43 #elif defined CONFIG_MX6DL
44 #define CONFIG_DEFAULT_FDT_FILE "imx6dl-sabreauto.dtb"
45 #endif
46-#define CONFIG_MMCROOT "/dev/mmcblk0p2"
47+#define CONFIG_MMCROOT "/dev/mmcblk2p2"
48 #define PHYS_SDRAM_SIZE (2u * 1024 * 1024 * 1024)
49
50 /* USB Configs */
51diff --git a/include/configs/mx6sabresd.h b/include/configs/mx6sabresd.h
52index 21ff2bc..635cfc3 100644
53--- a/include/configs/mx6sabresd.h
54+++ b/include/configs/mx6sabresd.h
55@@ -15,7 +15,7 @@
56 #define CONFIG_MACH_TYPE 3980
57 #define CONFIG_MXC_UART_BASE UART1_BASE
58 #define CONFIG_CONSOLE_DEV "ttymxc0"
59-#define CONFIG_MMCROOT "/dev/mmcblk0p2"
60+#define CONFIG_MMCROOT "/dev/mmcblk2p2"
61 #if defined(CONFIG_MX6Q)
62 #define CONFIG_DEFAULT_FDT_FILE "imx6q-sabresd-ldo.dtb"
63 #elif defined(CONFIG_MX6DL)
64diff --git a/include/configs/mx6slevk.h b/include/configs/mx6slevk.h
65index 3b051d7..1b5b616 100644
66--- a/include/configs/mx6slevk.h
67+++ b/include/configs/mx6slevk.h
68@@ -89,7 +89,7 @@
69 "ip_dyn=yes\0" \
70 "mmcdev=0\0" \
71 "mmcpart=1\0" \
72- "mmcroot=/dev/mmcblk0p2 rootwait rw\0" \
73+ "mmcroot=/dev/mmcblk1p2 rootwait rw\0" \
74 "mmcargs=setenv bootargs console=${console},${baudrate} " \
75 "root=${mmcroot}\0" \
76 "loadbootscript=" \
77diff --git a/include/configs/mx6sxsabresd.h b/include/configs/mx6sxsabresd.h
78index e02ea18..dce4851 100644
79--- a/include/configs/mx6sxsabresd.h
80+++ b/include/configs/mx6sxsabresd.h
81@@ -61,7 +61,7 @@
82 "ip_dyn=yes\0" \
83 "mmcdev=0\0" \
84 "mmcpart=1\0" \
85- "mmcroot=/dev/mmcblk0p2 rootwait rw\0" \
86+ "mmcroot=/dev/mmcblk3p2 rootwait rw\0" \
87 "mmcargs=setenv bootargs console=${console},${baudrate} " \
88 "root=${mmcroot}\0" \
89 "loadbootscript=" \
90--
912.1.1
92
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2014.10.bb b/recipes-bsp/u-boot/u-boot-fslc_2014.10.bb
index 9fed4d9..1d80d0e 100644
--- a/recipes-bsp/u-boot/u-boot-fslc_2014.10.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc_2014.10.bb
@@ -4,3 +4,6 @@ PV = "v2014.10+git${SRCPV}"
4 4
5SRCREV = "5fd0b607d0ef44b8b93d64faace674955791dd7d" 5SRCREV = "5fd0b607d0ef44b8b93d64faace674955791dd7d"
6SRCBRANCH = "patches-2014.10" 6SRCBRANCH = "patches-2014.10"
7
8# Fix to allow booting with 3.10.31-1.1.0 Beta kernel
9SRC_URI += "file://iMX6-Change-mmcroot-to-use-fixed-mmc-block-index-for.patch"