summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-vpu
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2014-09-03 10:49:40 -0700
committerOtavio Salvador <otavio@ossystems.com.br>2014-09-04 21:40:03 -0300
commit6169078f3c1d36bed3a4ce60fd8c1d2d1d7b7020 (patch)
tree791e8dde63c87ff99d3d2fe56bd7db43e3f5a171 /recipes-bsp/imx-vpu
parent7b734e2094bc594e9a17e7dfdae6a9564fb7819a (diff)
downloadmeta-fsl-arm-6169078f3c1d36bed3a4ce60fd8c1d2d1d7b7020.tar.gz
imx-{lib,vpu}: obey CFLAGS, LDFLAGS
This quiets GNU_HASH warnings when building with an external toolchain. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/imx-vpu')
-rw-r--r--recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch27
-rw-r--r--recipes-bsp/imx-vpu/imx-vpu-3.10.17-1.0.0/obey-variables.patch27
-rw-r--r--recipes-bsp/imx-vpu/imx-vpu_11.09.02.bb1
-rw-r--r--recipes-bsp/imx-vpu/imx-vpu_3.10.17-1.0.0.bb5
4 files changed, 59 insertions, 1 deletions
diff --git a/recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch b/recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch
new file mode 100644
index 0000000..13f61b2
--- /dev/null
+++ b/recipes-bsp/imx-vpu/imx-vpu-11.09.02/obey-variables.patch
@@ -0,0 +1,27 @@
1Obey CFLAGS, LDFLAGS
2
3Signed-off-by: Christopher Larson <chris_larson@mentor.com>
4Upstream-status: Pending
5
6--- imx-vpu-11.09.02.orig/vpu/Makefile 2014-09-02 13:14:50.862005896 -0700
7+++ imx-vpu-11.09.02/vpu/Makefile 2014-09-02 13:15:15.018153222 -0700
8@@ -1,5 +1,6 @@
9 CC ?=$(CROSS_COMPILE)gcc
10 AR ?=$(CROSS_COMPILE)ar
11+CFLAGS ?= -O2
12
13 # list of platforms which want this test case
14 INCLUDE_LIST:= IMX27ADS IMX51 IMX53 IMX6Q
15@@ -33,10 +34,10 @@
16 endif
17
18 %.o: %.c
19- $(CC) -D$(PLATFORM) -Wall -O2 -fPIC -c $^ -o $@
20+ $(CC) -D$(PLATFORM) -Wall -fPIC $(CFLAGS) -c $^ -o $@
21
22 $(LIBNAME).so.$(SONAMEVERSION): $(OBJ)
23- $(CC) -shared -nostartfiles -Wl,-soname,$@ $^ -o $@
24+ $(CC) -shared -nostartfiles -Wl,-soname,$@ $^ -o $@ $(LDFLAGS)
25
26 $(LIBNAME).so: $(LIBNAME).so.$(SONAMEVERSION)
27 ln -s $< $@
diff --git a/recipes-bsp/imx-vpu/imx-vpu-3.10.17-1.0.0/obey-variables.patch b/recipes-bsp/imx-vpu/imx-vpu-3.10.17-1.0.0/obey-variables.patch
new file mode 100644
index 0000000..7071e9e
--- /dev/null
+++ b/recipes-bsp/imx-vpu/imx-vpu-3.10.17-1.0.0/obey-variables.patch
@@ -0,0 +1,27 @@
1Obey CFLAGS, LDFLAGS
2
3Signed-off-by: Christopher Larson <chris_larson@mentor.com>
4Upstream-status: Pending
5
6--- imx-vpu-3.10.17-1.0.0_beta.orig/vpu/Makefile
7+++ imx-vpu-3.10.17-1.0.0_beta/vpu/Makefile
8@@ -1,5 +1,6 @@
9 CC ?=$(CROSS_COMPILE)gcc
10 AR ?=$(CROSS_COMPILE)ar
11+CFLAGS ?= -O2
12
13 # list of platforms which want this test case
14 INCLUDE_LIST:= IMX27ADS IMX51 IMX53 IMX6Q
15@@ -33,10 +34,10 @@ all install :
16 endif
17
18 %.o: %.c
19- $(CC) -D$(PLATFORM) -Wall -O2 -fPIC -c $^ -o $@
20+ $(CC) -D$(PLATFORM) -Wall -fPIC $(CFLAGS) -c $^ -o $@
21
22 $(LIBNAME).so.$(SONAMEVERSION): $(OBJ)
23- $(CC) -shared -nostartfiles -Wl,-soname,$@ $^ -o $@ -lpthread
24+ $(CC) -shared -nostartfiles -Wl,-soname,$@ $^ -o $@ $(LDFLAGS) -lpthread
25
26 $(LIBNAME).so: $(LIBNAME).so.$(SONAMEVERSION)
27 ln -s $< $@
diff --git a/recipes-bsp/imx-vpu/imx-vpu_11.09.02.bb b/recipes-bsp/imx-vpu/imx-vpu_11.09.02.bb
index c40c703..c5dd9bd 100644
--- a/recipes-bsp/imx-vpu/imx-vpu_11.09.02.bb
+++ b/recipes-bsp/imx-vpu/imx-vpu_11.09.02.bb
@@ -1,6 +1,7 @@
1# Copyright (C) 2013 Freescale Semiconductor 1# Copyright (C) 2013 Freescale Semiconductor
2require imx-vpu.inc 2require imx-vpu.inc
3 3
4SRC_URI += "file://obey-variables.patch"
4SRC_URI[md5sum] = "1988a08687a09ef8590e66ff17ac6ed3" 5SRC_URI[md5sum] = "1988a08687a09ef8590e66ff17ac6ed3"
5SRC_URI[sha256sum] = "783f136aa9b9257d4bffbdaf05bdcb85d177c544c3f8a4674421ba7b065ed5c0" 6SRC_URI[sha256sum] = "783f136aa9b9257d4bffbdaf05bdcb85d177c544c3f8a4674421ba7b065ed5c0"
6 7
diff --git a/recipes-bsp/imx-vpu/imx-vpu_3.10.17-1.0.0.bb b/recipes-bsp/imx-vpu/imx-vpu_3.10.17-1.0.0.bb
index 7ed9590..6ef79e5 100644
--- a/recipes-bsp/imx-vpu/imx-vpu_3.10.17-1.0.0.bb
+++ b/recipes-bsp/imx-vpu/imx-vpu_3.10.17-1.0.0.bb
@@ -4,9 +4,12 @@ require imx-vpu.inc
4 4
5PE = "1" 5PE = "1"
6 6
7SRC_URI += "\
8 file://0001-IOGetVirtMem-returns-1-MAP_FAILED-on-failure.patch \
9 file://obey-variables.patch \
10"
7SRC_URI[md5sum] = "71ea1b803864101ebf88a1bab45514d2" 11SRC_URI[md5sum] = "71ea1b803864101ebf88a1bab45514d2"
8SRC_URI[sha256sum] = "cd8a7bd50ff3274db76a331cc6622d3ba4bb7c790ce778f303e49187df2dfd72" 12SRC_URI[sha256sum] = "cd8a7bd50ff3274db76a331cc6622d3ba4bb7c790ce778f303e49187df2dfd72"
9 13
10SRC_URI_append = " file://0001-IOGetVirtMem-returns-1-MAP_FAILED-on-failure.patch"
11 14
12COMPATIBLE_MACHINE = "(mx6)" 15COMPATIBLE_MACHINE = "(mx6)"