summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-test
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2014-01-17 16:04:59 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2014-03-05 13:32:11 -0300
commite9ff094fa624d743b1dd7311434f898309080067 (patch)
treebab620e99197816c06686a4b45a134d35fa0246c /recipes-bsp/imx-test
parente0d925bffad822651071e9d43a83e5506f6b3726 (diff)
downloadmeta-fsl-arm-e9ff094fa624d743b1dd7311434f898309080067.tar.gz
imx-test: Don't install clocks.sh in MX6 as it uses 3.10 kernel
Kernel 3.10 uses the common clock framework, so the clock tree information can be retrieved from the standard /sys/kernel/debug location, which means we don't really need a custom clocks.sh script for the 3.10 kernel. You just don't need to install it if you use a recent kernel that deploys the common clock tree framework (like it is the case for MX6 running 3.10). Change-Id: Ief01c62025faa2927a226f9cd670e52dabb304be Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/imx-test')
-rw-r--r--recipes-bsp/imx-test/imx-test.inc7
-rw-r--r--recipes-bsp/imx-test/imx-test_11.09.01.bb4
-rw-r--r--recipes-bsp/imx-test/imx-test_2.6.35.3-1.1.0.bb2
-rw-r--r--recipes-bsp/imx-test/imx-test_3.10.17-1.0.0.bb3
4 files changed, 10 insertions, 6 deletions
diff --git a/recipes-bsp/imx-test/imx-test.inc b/recipes-bsp/imx-test/imx-test.inc
index c03e865..78e14d8 100644
--- a/recipes-bsp/imx-test/imx-test.inc
+++ b/recipes-bsp/imx-test/imx-test.inc
@@ -18,8 +18,7 @@ PLATFORM_mx6sl = "IMX6S"
18PLATFORM_mx53 = "IMX53" 18PLATFORM_mx53 = "IMX53"
19PLATFORM_mx51 = "IMX51" 19PLATFORM_mx51 = "IMX51"
20 20
21SRC_URI = "${FSL_MIRROR}/imx-test-${PV}.tar.gz \ 21SRC_URI = "${FSL_MIRROR}/imx-test-${PV}.tar.gz"
22 file://clocks.sh"
23 22
24inherit module-base 23inherit module-base
25 24
@@ -48,8 +47,10 @@ do_compile() {
48do_install() { 47do_install() {
49 install -d ${D}/unit_tests 48 install -d ${D}/unit_tests
50 install -m 755 test-utils.sh ${D}/unit_tests/test-utils.sh 49 install -m 755 test-utils.sh ${D}/unit_tests/test-utils.sh
51 install -m 0755 ${WORKDIR}/clocks.sh ${D}/unit_tests/clocks.sh
52 install -m 755 ${S}/platform/${PLATFORM}/* ${D}/unit_tests/ 50 install -m 755 ${S}/platform/${PLATFORM}/* ${D}/unit_tests/
51 if [ -e ${WORKDIR}/clocks.sh ]; then
52 install -m 755 ${WORKDIR}/clocks.sh ${D}/unit_tests/clocks.sh
53 fi
53} 54}
54 55
55FILES_${PN} += "/unit_tests" 56FILES_${PN} += "/unit_tests"
diff --git a/recipes-bsp/imx-test/imx-test_11.09.01.bb b/recipes-bsp/imx-test/imx-test_11.09.01.bb
index 81df189..54a03f7 100644
--- a/recipes-bsp/imx-test/imx-test_11.09.01.bb
+++ b/recipes-bsp/imx-test/imx-test_11.09.01.bb
@@ -6,6 +6,8 @@ COMPATIBLE_MACHINE = "(mx5)"
6 6
7SRC_URI += "file://0001-ENGR00158471-fix-ipu-unit-test-application-missing-i.patch \ 7SRC_URI += "file://0001-ENGR00158471-fix-ipu-unit-test-application-missing-i.patch \
8 file://0002-ENGR00170223-vpu-Fix-encoder-with-rotation-90-or-270.patch \ 8 file://0002-ENGR00170223-vpu-Fix-encoder-with-rotation-90-or-270.patch \
9 file://0003-ENGR00162747-fix-asrc-sample-rate-convert-issue.patch" 9 file://0003-ENGR00162747-fix-asrc-sample-rate-convert-issue.patch \
10 file://clocks.sh"
11
10SRC_URI[md5sum] = "5512dc0340cb71087c78f13bb6710ee0" 12SRC_URI[md5sum] = "5512dc0340cb71087c78f13bb6710ee0"
11SRC_URI[sha256sum] = "b788ac9c787b665c49596726e0095cef9ad835be4c616d2454543ae5f41a81af" 13SRC_URI[sha256sum] = "b788ac9c787b665c49596726e0095cef9ad835be4c616d2454543ae5f41a81af"
diff --git a/recipes-bsp/imx-test/imx-test_2.6.35.3-1.1.0.bb b/recipes-bsp/imx-test/imx-test_2.6.35.3-1.1.0.bb
index 33febf8..2626276 100644
--- a/recipes-bsp/imx-test/imx-test_2.6.35.3-1.1.0.bb
+++ b/recipes-bsp/imx-test/imx-test_2.6.35.3-1.1.0.bb
@@ -5,6 +5,8 @@ DEPENDS = "virtual/kernel"
5PR = "${INC_PR}.0" 5PR = "${INC_PR}.0"
6PE = "1" 6PE = "1"
7 7
8SRC_URI += " file://clocks.sh"
9
8SRC_URI[md5sum] = "e30d557aea2ef3cc5840a3cfc81364bc" 10SRC_URI[md5sum] = "e30d557aea2ef3cc5840a3cfc81364bc"
9SRC_URI[sha256sum] = "ce7dc16bc2e7e56d9394d8d899a4cdd73e416f8cec4d4a8acec946c8922028bf" 11SRC_URI[sha256sum] = "ce7dc16bc2e7e56d9394d8d899a4cdd73e416f8cec4d4a8acec946c8922028bf"
10 12
diff --git a/recipes-bsp/imx-test/imx-test_3.10.17-1.0.0.bb b/recipes-bsp/imx-test/imx-test_3.10.17-1.0.0.bb
index b4362b8..80f4049 100644
--- a/recipes-bsp/imx-test/imx-test_3.10.17-1.0.0.bb
+++ b/recipes-bsp/imx-test/imx-test_3.10.17-1.0.0.bb
@@ -3,8 +3,7 @@
3include imx-test.inc 3include imx-test.inc
4 4
5# FIXME: Drop 'beta' suffix for GA release 5# FIXME: Drop 'beta' suffix for GA release
6SRC_URI = "${FSL_MIRROR}/${PN}-${PV}_beta.tar.gz \ 6SRC_URI = "${FSL_MIRROR}/${PN}-${PV}_beta.tar.gz"
7 file://clocks.sh"
8S="${WORKDIR}/${PN}-${PV}_beta" 7S="${WORKDIR}/${PN}-${PV}_beta"
9 8
10PE = "1" 9PE = "1"