summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-test
diff options
context:
space:
mode:
authorDaiane Angolini <daiane.angolini@freescale.com>2012-05-31 14:34:39 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2012-05-31 16:41:50 -0300
commit629489e2f298d2f6d4f5ea71805125bc7efa15d5 (patch)
treead17a008546b2724d9cd9cc4cb3360ea1d4ffb4f /recipes-bsp/imx-test
parent1f8aff8b32552539cf833d59407341eef6831679 (diff)
downloadmeta-fsl-arm-629489e2f298d2f6d4f5ea71805125bc7efa15d5.tar.gz
imx-test: Add imx-test.inc file
Rename imx-test_01.bb to imx-test_11.09.bb in order to use the Freescale release number of imx-test package. Add imx-test.inc to avoid dupplication of code if a new imx-test release was included. Signed-off-by: Daiane Angolini <daiane.angolini@freescale.com>
Diffstat (limited to 'recipes-bsp/imx-test')
-rw-r--r--recipes-bsp/imx-test/imx-test.inc27
-rw-r--r--recipes-bsp/imx-test/imx-test_0.1.bb38
-rw-r--r--recipes-bsp/imx-test/imx-test_11.09.01.bb9
3 files changed, 36 insertions, 38 deletions
diff --git a/recipes-bsp/imx-test/imx-test.inc b/recipes-bsp/imx-test/imx-test.inc
new file mode 100644
index 0000000..09250a7
--- /dev/null
+++ b/recipes-bsp/imx-test/imx-test.inc
@@ -0,0 +1,27 @@
1SUMMARY = "Test programs for IMX BSP"
2DESCRIPTION = "Unit tests for the IMX BSP"
3SECTION = "base"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
6
7INC_PR = "r1"
8
9PLATFORM_imx53ard = "IMX53"
10PLATFORM_imx53qsb = "IMX53"
11PLATFORM_imx51evk = "IMX51"
12
13SRC_URI = "file://imx-test-${PV}.tar.gz"
14
15do_compile() {
16 LDFLAGS="" make PLATFORM=${PLATFORM} LINUXPATH=${STAGING_KERNEL_DIR} \
17 KBUILD_OUTPUT=${STAGING_KERNEL_DIR} CROSS_COMPILE=${TARGET_PREFIX} V=1
18}
19
20do_install() {
21 install -d ${D}/unit_tests
22 install -m 755 test-utils.sh ${D}/unit_tests/test-utils.sh
23 install -m 755 ${S}/platform/${PLATFORM}/* ${D}/unit_tests/
24}
25
26FILES_${PN} += "/unit_tests"
27FILES_${PN}-dbg += "/unit_tests/.debug"
diff --git a/recipes-bsp/imx-test/imx-test_0.1.bb b/recipes-bsp/imx-test/imx-test_0.1.bb
deleted file mode 100644
index 6de7ae2..0000000
--- a/recipes-bsp/imx-test/imx-test_0.1.bb
+++ /dev/null
@@ -1,38 +0,0 @@
1SUMMARY = "Test programs for IMX BSP"
2DESCRIPTION = "Unit tests for the IMX BSP"
3SECTION = "base"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
6
7PR = "r3"
8
9COMPATIBLE_MACHINE = "(mx5)"
10
11TESTVERSION = "11.09.01"
12S = "${WORKDIR}/${PN}-${TESTVERSION}"
13
14SRC_URI = "file://imx-test-${TESTVERSION}.tar.gz \
15 file://0001-ENGR00158471-fix-ipu-unit-test-application-missing-i.patch \
16 file://0002-ENGR00170223-vpu-Fix-encoder-with-rotation-90-or-270.patch \
17 file://0003-ENGR00162747-fix-asrc-sample-rate-convert-issue.patch"
18
19TESTPLATFORM_imx53ard = "IMX53"
20TESTPLATFORM_imx53qsb = "IMX53"
21TESTPLATFORM_imx51evk = "IMX51"
22
23do_compile() {
24 # LDFLAGS="" else modules' compilation fails
25 LDFLAGS="" make PLATFORM=${TESTPLATFORM} LINUXPATH=${STAGING_KERNEL_DIR} \
26 KBUILD_OUTPUT=${STAGING_KERNEL_DIR} CROSS_COMPILE=${TARGET_PREFIX} V=1
27}
28
29do_install() {
30 install -d ${D}/unit_tests
31 install -m 755 test-utils.sh ${D}/unit_tests/test-utils.sh
32 install -m 755 ${S}/platform/${TESTPLATFORM}/* ${D}/unit_tests/
33 install -d ${D}/unit_tests/modules
34 cp ${S}/module_test/*.ko ${D}/unit_tests/modules
35}
36
37FILES_${PN} += "/unit_tests"
38FILES_${PN}-dbg += "/unit_tests/.debug"
diff --git a/recipes-bsp/imx-test/imx-test_11.09.01.bb b/recipes-bsp/imx-test/imx-test_11.09.01.bb
new file mode 100644
index 0000000..063547b
--- /dev/null
+++ b/recipes-bsp/imx-test/imx-test_11.09.01.bb
@@ -0,0 +1,9 @@
1include imx-test.inc
2
3PR = "${INC_PR}.0"
4
5COMPATIBLE_MACHINE = "(mx5)"
6
7SRC_URI += "file://0001-ENGR00158471-fix-ipu-unit-test-application-missing-i.patch \
8 file://0002-ENGR00170223-vpu-Fix-encoder-with-rotation-90-or-270.patch \
9 file://0003-ENGR00162747-fix-asrc-sample-rate-convert-issue.patch"