summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-bootlets
diff options
context:
space:
mode:
authorAlexandre Belloni <alexandre.belloni@free-electrons.com>2013-08-26 16:58:21 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2013-08-29 16:14:22 -0300
commit14edbd802b9b6d2181d8b10e14acc8debc708a36 (patch)
treec56784ada0a4ac643a6b016d536710e3d9fa5a85 /recipes-bsp/imx-bootlets
parentbbbe1e2fa1e607dc591057beaa130bb5e6746e98 (diff)
downloadmeta-fsl-arm-14edbd802b9b6d2181d8b10e14acc8debc708a36.tar.gz
imx-boolets: Add barebox support
Change-Id: Ifb5855a8c6c8d290f3aa699dc36712cb68fd4ddc Signed-off-by: Alexandre Belloni <alexandre.belloni@free-electrons.com>
Diffstat (limited to 'recipes-bsp/imx-bootlets')
-rw-r--r--recipes-bsp/imx-bootlets/imx-bootlets/add-command-script-for-barebox.patch46
-rw-r--r--recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb6
2 files changed, 51 insertions, 1 deletions
diff --git a/recipes-bsp/imx-bootlets/imx-bootlets/add-command-script-for-barebox.patch b/recipes-bsp/imx-bootlets/imx-bootlets/add-command-script-for-barebox.patch
new file mode 100644
index 0000000..1deca1c
--- /dev/null
+++ b/recipes-bsp/imx-bootlets/imx-bootlets/add-command-script-for-barebox.patch
@@ -0,0 +1,46 @@
1imx-bootlets: Add command script for barebox
2
3Upstream-Status: Inappropriate [configuration]
4
5Signed-off-by: Alexandre Belloni <alexandre.belloni@free-electrons.com>
6
7diff --git a/barebox_ivt.bd b/barebox_ivt.bd
8new file mode 100644
9index 0000000..79cbccf
10--- /dev/null
11+++ b/barebox_ivt.bd
12@@ -0,0 +1,34 @@
13+// STMP378x ROM command script to load and run barebox
14+
15+sources {
16+ power_prep="imx-bootlets-power_prep-@MACHINE@";
17+ sdram_prep="imx-bootlets-boot_prep-@MACHINE@";
18+ barebox="barebox-@MACHINE@.bin";
19+}
20+
21+section (0) {
22+
23+ //----------------------------------------------------------
24+ // Power Supply initialization
25+ //----------------------------------------------------------
26+
27+ load power_prep;
28+ load ivt (entry = power_prep:_start) > 0x8000;
29+ hab call 0x8000;
30+
31+ //----------------------------------------------------------
32+ // SDRAM initialization
33+ //----------------------------------------------------------
34+
35+ load sdram_prep;
36+ load ivt (entry = sdram_prep:_start) > 0x8000;
37+ hab call 0x8000;
38+ //----------------------------------------------------------
39+ // Load and call barebox - ELF ARM image
40+ //----------------------------------------------------------
41+
42+ load barebox;
43+ load ivt (entry = barebox:start) > 0x8000;
44+ hab call 0x8000;
45+
46+}
diff --git a/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb b/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb
index 6cea049..1ddfb6f 100644
--- a/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb
+++ b/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb
@@ -6,7 +6,8 @@ PR = "r2"
6 6
7SRC_URI = "http://download.ossystems.com.br/bsp/freescale/source/imx-bootlets-src-${PV}.tar.gz \ 7SRC_URI = "http://download.ossystems.com.br/bsp/freescale/source/imx-bootlets-src-${PV}.tar.gz \
8 file://linux-fix-paths.patch \ 8 file://linux-fix-paths.patch \
9 file://linux_prep-fix-cmdlines.patch" 9 file://linux_prep-fix-cmdlines.patch \
10 file://add-command-script-for-barebox.patch"
10 11
11SRC_URI[md5sum] = "cf0ab3822dca694b930a051501c1d0e4" 12SRC_URI[md5sum] = "cf0ab3822dca694b930a051501c1d0e4"
12SRC_URI[sha256sum] = "63f6068ae36884adef4259bbb1fe2591755718f22c46d0a59d854883dfab1ffc" 13SRC_URI[sha256sum] = "63f6068ae36884adef4259bbb1fe2591755718f22c46d0a59d854883dfab1ffc"
@@ -32,6 +33,7 @@ do_configure () {
32 # Use machine specific binaries 33 # Use machine specific binaries
33 sed 's,@MACHINE@,${MACHINE},g;s,@DTB@,-dtb,g' < linux.bd > linux.bd-dtb 34 sed 's,@MACHINE@,${MACHINE},g;s,@DTB@,-dtb,g' < linux.bd > linux.bd-dtb
34 sed -i 's,@MACHINE@,${MACHINE},g;s,@DTB@,,g' linux.bd 35 sed -i 's,@MACHINE@,${MACHINE},g;s,@DTB@,,g' linux.bd
36 sed -i 's,@MACHINE@,${MACHINE},g' barebox_ivt.bd
35} 37}
36 38
37do_compile () { 39do_compile () {
@@ -45,6 +47,7 @@ do_install () {
45 install -m 644 boot_prep/boot_prep power_prep/power_prep \ 47 install -m 644 boot_prep/boot_prep power_prep/power_prep \
46 linux_prep/output-target/linux_prep \ 48 linux_prep/output-target/linux_prep \
47 linux.bd linux.bd-dtb \ 49 linux.bd linux.bd-dtb \
50 barebox_ivt.bd \
48 ${D}/boot 51 ${D}/boot
49} 52}
50 53
@@ -56,6 +59,7 @@ do_deploy () {
56 for f in boot_prep/boot_prep \ 59 for f in boot_prep/boot_prep \
57 power_prep/power_prep \ 60 power_prep/power_prep \
58 linux_prep/output-target/linux_prep \ 61 linux_prep/output-target/linux_prep \
62 barebox_ivt.bd \
59 linux.bd linux.bd-dtb; do 63 linux.bd linux.bd-dtb; do
60 full_name="imx-bootlets-`basename $f`-${MACHINE}-${PV}-${PR}" 64 full_name="imx-bootlets-`basename $f`-${MACHINE}-${PV}-${PR}"
61 symlink_name="imx-bootlets-`basename $f`-${MACHINE}" 65 symlink_name="imx-bootlets-`basename $f`-${MACHINE}"