summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-bootlets
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-05-21 17:47:32 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2012-05-21 17:47:32 -0300
commitf5aa2841d445b1601d506a34fa86d43aa5b18d8e (patch)
tree3a50ba21b4448775d29f4223c78b8777a919cf32 /recipes-bsp/imx-bootlets
parent738ecbb43e0d3e1ada8eb3527886ed1e55740a8d (diff)
downloadmeta-fsl-arm-f5aa2841d445b1601d506a34fa86d43aa5b18d8e.tar.gz
imx-bootlets: avoid using linux-ivt module as it is mx25 dependant
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/imx-bootlets')
-rw-r--r--recipes-bsp/imx-bootlets/imx-bootlets/linux-fix-paths.patch (renamed from recipes-bsp/imx-bootlets/imx-bootlets/linux_ivt-fix-paths.patch)10
-rw-r--r--recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb10
2 files changed, 11 insertions, 9 deletions
diff --git a/recipes-bsp/imx-bootlets/imx-bootlets/linux_ivt-fix-paths.patch b/recipes-bsp/imx-bootlets/imx-bootlets/linux-fix-paths.patch
index 2ce5a0f..abcf5b0 100644
--- a/recipes-bsp/imx-bootlets/imx-bootlets/linux_ivt-fix-paths.patch
+++ b/recipes-bsp/imx-bootlets/imx-bootlets/linux-fix-paths.patch
@@ -7,18 +7,18 @@ Upstream-Status: Inappropriate [configuration]
7 7
8Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> 8Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
9 9
10diff --git a/linux_ivt.bd b/linux_ivt.bd 10diff --git a/linux.bd b/linux.bd
11index 516f4f2..366ac22 100644 11index 516f4f2..366ac22 100644
12--- a/linux_ivt.bd 12--- a/linux.bd
13+++ b/linux_ivt.bd 13+++ b/linux.bd
14@@ -4,10 +4,10 @@ options { 14@@ -4,10 +4,10 @@
15 flags = 0x01; 15 flags = 0x01;
16 } 16 }
17 sources { 17 sources {
18- power_prep="./power_prep/power_prep"; 18- power_prep="./power_prep/power_prep";
19- sdram_prep="./boot_prep/boot_prep"; 19- sdram_prep="./boot_prep/boot_prep";
20- linux_prep="./linux_prep/output-target/linux_prep"; 20- linux_prep="./linux_prep/output-target/linux_prep";
21- zImage="./zImage"; 21- zImage = "./zImage";
22+ power_prep="imx-bootlets-power_prep-@MACHINE@"; 22+ power_prep="imx-bootlets-power_prep-@MACHINE@";
23+ sdram_prep="imx-bootlets-boot_prep-@MACHINE@"; 23+ sdram_prep="imx-bootlets-boot_prep-@MACHINE@";
24+ linux_prep="imx-bootlets-linux_prep-@MACHINE@"; 24+ linux_prep="imx-bootlets-linux_prep-@MACHINE@";
diff --git a/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb b/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb
index 941b458..d2f51fd 100644
--- a/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb
+++ b/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb
@@ -2,8 +2,10 @@ DESCRIPTION = "i.MXS boot streams"
2LICENSE = "GPL-2.0" 2LICENSE = "GPL-2.0"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" 3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4 4
5PR = "r1"
6
5SRC_URI = "http://download.ossystems.com.br/bsp/freescale/source/imx-bootlets-src-${PV}.tar.gz \ 7SRC_URI = "http://download.ossystems.com.br/bsp/freescale/source/imx-bootlets-src-${PV}.tar.gz \
6 file://linux_ivt-fix-paths.patch \ 8 file://linux-fix-paths.patch \
7 file://linux_prep-fix-cmdlines.patch" 9 file://linux_prep-fix-cmdlines.patch"
8 10
9SRC_URI[md5sum] = "cf0ab3822dca694b930a051501c1d0e4" 11SRC_URI[md5sum] = "cf0ab3822dca694b930a051501c1d0e4"
@@ -28,7 +30,7 @@ python () {
28 30
29do_configure () { 31do_configure () {
30 # Use machine specific binaries 32 # Use machine specific binaries
31 sed -i 's,@MACHINE@,${MACHINE},g' linux_ivt.bd 33 sed -i 's,@MACHINE@,${MACHINE},g' linux.bd
32} 34}
33 35
34do_compile () { 36do_compile () {
@@ -40,7 +42,7 @@ do_compile () {
40do_install () { 42do_install () {
41 install -d ${D}/boot/ 43 install -d ${D}/boot/
42 install -m 644 boot_prep/boot_prep power_prep/power_prep \ 44 install -m 644 boot_prep/boot_prep power_prep/power_prep \
43 linux_prep/output-target/linux_prep linux_ivt.bd \ 45 linux_prep/output-target/linux_prep linux.bd \
44 ${D}/boot 46 ${D}/boot
45} 47}
46 48
@@ -52,7 +54,7 @@ do_deploy () {
52 for f in boot_prep/boot_prep \ 54 for f in boot_prep/boot_prep \
53 power_prep/power_prep \ 55 power_prep/power_prep \
54 linux_prep/output-target/linux_prep \ 56 linux_prep/output-target/linux_prep \
55 linux_ivt.bd; do 57 linux.bd; do
56 full_name="imx-bootlets-`basename $f`-${MACHINE}-${PV}-${PR}" 58 full_name="imx-bootlets-`basename $f`-${MACHINE}-${PV}-${PR}"
57 symlink_name="imx-bootlets-`basename $f`-${MACHINE}" 59 symlink_name="imx-bootlets-`basename $f`-${MACHINE}"
58 60