summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/firmware-imx/firmware-imx.inc
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-10 03:19:58 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-10 03:19:58 +0200
commitf98b448ee835646be48f530b3e6fe13b32b093f5 (patch)
tree9d1062f1e8893e72829df650f5e558c5fb255955 /recipes-bsp/firmware-imx/firmware-imx.inc
downloadmeta-fsl-arm-f98b448ee835646be48f530b3e6fe13b32b093f5.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'recipes-bsp/firmware-imx/firmware-imx.inc')
-rw-r--r--recipes-bsp/firmware-imx/firmware-imx.inc47
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes-bsp/firmware-imx/firmware-imx.inc b/recipes-bsp/firmware-imx/firmware-imx.inc
new file mode 100644
index 0000000..0f49937
--- /dev/null
+++ b/recipes-bsp/firmware-imx/firmware-imx.inc
@@ -0,0 +1,47 @@
1SUMMARY = "Freescale IMX firmware"
2DESCRIPTION = "Freescale IMX firmware such as for the VPU"
3SECTION = "base"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://licenses/vpu/EULA;md5=6469a8514eed615d6bf8c09f41846d8f"
6
7PE="1"
8
9SRC_URI = "${FSL_MIRROR}/firmware-imx-${PV}.bin;fsl-eula=true"
10
11inherit fsl-eula-unpack
12
13do_install() {
14 install -d ${D}/lib/firmware
15 cp -rfv firmware/* ${D}/lib/firmware/
16 find ${D}/lib/firmware -type f -exec chmod 644 '{}' ';'
17
18 # Remove files not going to be installed
19 find ${D}/lib/firmware/ -name Android.mk -exec rm '{}' ';'
20 rm ${D}/lib/firmware/LICENCE.atheros_firmware \
21 ${D}/lib/firmware/README
22
23 # FIXME: Remove firmware packaged in linux-firmware
24 rm -r ${D}/lib/firmware/ath6k ${D}/lib/firmware/ar3k
25}
26
27python populate_packages_prepend() {
28 vpudir = bb.data.expand('/lib/firmware/vpu', d)
29 do_split_packages(d, vpudir, '^vpu_fw_([^_]*).*\.bin',
30 output_pattern='firmware-imx-vpu-%s',
31 description='Freescale IMX Firmware %s',
32 extra_depends='',
33 prepend=True)
34
35 sdmadir = bb.data.expand('/lib/firmware/sdma', d)
36 do_split_packages(d, sdmadir, '^sdma-([^-]*).*\.bin',
37 output_pattern='firmware-imx-sdma-%s',
38 description='Freescale IMX Firmware %s',
39 extra_depends='',
40 prepend=True)
41}
42
43ALLOW_EMPTY_${PN} = "1"
44
45PACKAGES_DYNAMIC = "${PN}-vpu-* ${PN}-sdma-*"
46
47PACKAGE_ARCH = "${MACHINE_SOCARCH}"