summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/apptrk/apptrk_git.bb
diff options
context:
space:
mode:
authorChunrong Guo <B40290@freescale.com>2015-01-15 12:29:47 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2015-01-16 15:45:59 -0200
commitb9d5eaa990b00cd3fa930a4163522c0ef47283db (patch)
tree6c8e5b4e20cec270efd1aa9ca8f66966853c6f41 /recipes-bsp/apptrk/apptrk_git.bb
parentb74e5e690d8d4e149ea9de3f0fcca37bad93935f (diff)
downloadmeta-fsl-arm-b9d5eaa990b00cd3fa930a4163522c0ef47283db.tar.gz
apptrk: add recipes for Layerscape1 support
Debug agent for Freescale CodeWarrior debugger Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp/apptrk/apptrk_git.bb')
-rw-r--r--recipes-bsp/apptrk/apptrk_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-bsp/apptrk/apptrk_git.bb b/recipes-bsp/apptrk/apptrk_git.bb
new file mode 100644
index 0000000..4453cf8
--- /dev/null
+++ b/recipes-bsp/apptrk/apptrk_git.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Debug agent for Freescale CodeWarrior"
2SECTION = "apptrk"
3LICENSE = "Freescale-EULA"
4LIC_FILES_CHKSUM = "file://COPYING;md5=95560debfde180684364319811cc1421"
5
6DEPENDS = "elfutils"
7
8inherit kernel-arch
9
10SRC_URI = "git://git.freescale.com/ppc/sdk/apptrk.git;nobranch=1 \
11 file://apptrk-install-create-all-components-of-DEST.patch \
12 file://no-strip.patch \
13"
14SRCREV = "cbed10997c5e2a4aaa004fb0e1efec858bf1bbe1"
15
16S = "${WORKDIR}/git"
17
18EXTRA_OEMAKE = ""
19
20CFLAGS += " -I${STAGING_INCDIR}"
21
22do_install() {
23 oe_runmake install DESTDIR=${D}
24}