summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2016-08-22 14:11:39 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2016-08-23 20:57:36 -0300
commitd94c026e86bdd47e8b6a8f0a214b21640e787dd5 (patch)
tree6caabd6dd1f6746c670f0750b3bcebc35d811596
parent16639f4bcd2b9a358532278f2bef197fb2e496a9 (diff)
downloadmeta-fsl-arm-d94c026e86bdd47e8b6a8f0a214b21640e787dd5.tar.gz
imx-test: obey LDFLAGS settings
The gcc-cross default linker hash has been changed in OE-Core:fa436aeb, due that the broken recipes (which were not respecting the set LDFLAGS settings) are now exposed. This fixes the error setting the need Make flags so the build system obey the LDFLAGS setting. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-bsp/imx-test/imx-test.inc2
-rw-r--r--recipes-bsp/imx-test/imx-test_5.4.1.bb2
2 files changed, 3 insertions, 1 deletions
diff --git a/recipes-bsp/imx-test/imx-test.inc b/recipes-bsp/imx-test/imx-test.inc
index 10dbb4d..f0b26a1 100644
--- a/recipes-bsp/imx-test/imx-test.inc
+++ b/recipes-bsp/imx-test/imx-test.inc
@@ -40,7 +40,6 @@ do_make_scripts[depends] += "virtual/kernel:do_install"
40 40
41do_compile() { 41do_compile() {
42 CFLAGS="${TOOLCHAIN_OPTIONS}" 42 CFLAGS="${TOOLCHAIN_OPTIONS}"
43 LDFLAGS="${TOOLCHAIN_OPTIONS} -L${STAGING_LIBDIR}"
44 oe_runmake V=1 VERBOSE='' \ 43 oe_runmake V=1 VERBOSE='' \
45 CROSS_COMPILE=${TARGET_PREFIX} \ 44 CROSS_COMPILE=${TARGET_PREFIX} \
46 INC="-I${STAGING_INCDIR} \ 45 INC="-I${STAGING_INCDIR} \
@@ -52,6 +51,7 @@ do_compile() {
52 -I${STAGING_KERNEL_DIR}/arch/arm/include \ 51 -I${STAGING_KERNEL_DIR}/arch/arm/include \
53 -I${STAGING_KERNEL_DIR}/drivers/mxc/security/rng/include \ 52 -I${STAGING_KERNEL_DIR}/drivers/mxc/security/rng/include \
54 -I${STAGING_KERNEL_DIR}/drivers/mxc/security/sahara2/include" \ 53 -I${STAGING_KERNEL_DIR}/drivers/mxc/security/sahara2/include" \
54 CC="${CC} -L${STAGING_LIBDIR} ${LDFLAGS}" \
55 LINUXPATH=${STAGING_KERNEL_DIR} \ 55 LINUXPATH=${STAGING_KERNEL_DIR} \
56 KBUILD_OUTPUT=${STAGING_KERNEL_BUILDDIR} \ 56 KBUILD_OUTPUT=${STAGING_KERNEL_BUILDDIR} \
57 PLATFORM=${PLATFORM} 57 PLATFORM=${PLATFORM}
diff --git a/recipes-bsp/imx-test/imx-test_5.4.1.bb b/recipes-bsp/imx-test/imx-test_5.4.1.bb
index 04aad14..e33cc8d 100644
--- a/recipes-bsp/imx-test/imx-test_5.4.1.bb
+++ b/recipes-bsp/imx-test/imx-test_5.4.1.bb
@@ -5,4 +5,6 @@ include imx-test.inc
5SRC_URI[md5sum] = "fa1a5cdcfbdd6a3fed0ab4a5fd1f97bc" 5SRC_URI[md5sum] = "fa1a5cdcfbdd6a3fed0ab4a5fd1f97bc"
6SRC_URI[sha256sum] = "997ec10bdc6991e9687a2c2fa5816bb50b08d73bcfe4093f988a7cac4bf0b06a" 6SRC_URI[sha256sum] = "997ec10bdc6991e9687a2c2fa5816bb50b08d73bcfe4093f988a7cac4bf0b06a"
7 7
8PR = "r1"
9
8COMPATIBLE_MACHINE = "(mx6|mx6ul|mx7)" 10COMPATIBLE_MACHINE = "(mx6|mx6ul|mx7)"