summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2016-09-08 11:47:15 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2016-09-08 11:47:15 -0300
commitb0cebe99a08491f5e35d680b1c950090c2228cc3 (patch)
tree07a89b104da07ce2049d16012c1decba2f990f8d
parenta6b95df4d7ab122f1e5b7632e2273b75f853af4b (diff)
downloadmeta-fsl-arm-b0cebe99a08491f5e35d680b1c950090c2228cc3.tar.gz
qtbase: Add i.MX6UL overrideskrogoth-next
The Qt5 needs to specify different configuration settings for the i.MX6UL; this is a different fix than has been applied on master as for it, it has been included into the SoC features rework which uses the machine override expander. Change-Id: I182741e4de00ff3386d5512cb68f7f243817447e Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--qt5-layer/recipes-qt/qt5/qtbase_%.bbappend2
1 files changed, 2 insertions, 0 deletions
diff --git a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
index d336c0f..2bc9408 100644
--- a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
+++ b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
@@ -8,10 +8,12 @@ IS_MX6SL_mx6sl = "1"
8PACKAGECONFIG_GL_mx6q = "gles2" 8PACKAGECONFIG_GL_mx6q = "gles2"
9PACKAGECONFIG_GL_mx6dl = "gles2" 9PACKAGECONFIG_GL_mx6dl = "gles2"
10PACKAGECONFIG_GL_mx6sx = "gles2" 10PACKAGECONFIG_GL_mx6sx = "gles2"
11PACKAGECONFIG_GL_mx6ul = "gles2"
11PACKAGECONFIG_GL_mx6sl = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' gl', '', d)}" 12PACKAGECONFIG_GL_mx6sl = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' gl', '', d)}"
12QT_CONFIG_FLAGS_append_mx6q = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" 13QT_CONFIG_FLAGS_append_mx6q = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}"
13QT_CONFIG_FLAGS_append_mx6dl = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" 14QT_CONFIG_FLAGS_append_mx6dl = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}"
14QT_CONFIG_FLAGS_append_mx6sx = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" 15QT_CONFIG_FLAGS_append_mx6sx = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}"
16QT_CONFIG_FLAGS_append_mx6ul = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}"
15QT_CONFIG_FLAGS_append_mx6sl = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', \ 17QT_CONFIG_FLAGS_append_mx6sl = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', \
16 ' -no-opengl -linuxfb -no-eglfs', d)}" 18 ' -no-opengl -linuxfb -no-eglfs', d)}"
17 19