summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuqing Zhu <carol.zhu@nxp.com>2016-05-04 17:43:02 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-05-30 08:31:13 -0300
commit95c0afbc76f7c9fa1e186f7876d5214c6947ffde (patch)
treea08d2e660074c825017aa23b6256c8bace7cd5be
parentc6debb4b2565fda18c6b9fabc292778bad14aff7 (diff)
downloadmeta-fsl-arm-95c0afbc76f7c9fa1e186f7876d5214c6947ffde.tar.gz
pulseaudio: Remove the control for speaker/headphone widget for i.MX7D
In order to fix issue "headphone volume will be set to zero when pulseaudio can't detect the headphone jack status", remove the control in configuration file. Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-multimedia/pulseaudio/pulseaudio/imx/pulseaudio-remove-the-control-for-speaker-headphone-widge.patch73
-rw-r--r--recipes-multimedia/pulseaudio/pulseaudio_%.bbappend4
2 files changed, 76 insertions, 1 deletions
diff --git a/recipes-multimedia/pulseaudio/pulseaudio/imx/pulseaudio-remove-the-control-for-speaker-headphone-widge.patch b/recipes-multimedia/pulseaudio/pulseaudio/imx/pulseaudio-remove-the-control-for-speaker-headphone-widge.patch
new file mode 100644
index 0000000..019f9ba
--- /dev/null
+++ b/recipes-multimedia/pulseaudio/pulseaudio/imx/pulseaudio-remove-the-control-for-speaker-headphone-widge.patch
@@ -0,0 +1,73 @@
1From 015e048d3662b9f82e9aa5cd04d7c9de4eadb68d Mon Sep 17 00:00:00 2001
2From: Shengjiu Wang <shengjiu.wang@freescale.com>
3Date: Mon, 30 Mar 2015 10:26:14 +0800
4Subject: [PATCH] pulseaudio: remove the control for speaker/headphone widget
5
6In imx7d-sdb, there is no headphone jack, the jack detection is done
7by the codec itself. When headphone plugin, pulseaudio can't detect
8the headphone jack status, so it will set the heaphone volume to zero.
9Here fix this issue by remove the control in configuration.
10
11Upstream-Status: Inappropriate [i.MX specific]
12
13Signed-off-by: Shengjiu Wang <shengjiu.wang@freescale.com>
14---
15 .../alsa/mixer/paths/analog-output-headphones.conf | 8 ++++----
16 .../alsa/mixer/paths/analog-output-speaker.conf | 8 ++++----
17 2 files changed, 8 insertions(+), 8 deletions(-)
18
19diff --git a/src/modules/alsa/mixer/paths/analog-output-headphones.conf b/src/modules/alsa/mixer/paths/analog-output-headphones.conf
20index b6ee70b..a617976 100644
21--- a/src/modules/alsa/mixer/paths/analog-output-headphones.conf
22+++ b/src/modules/alsa/mixer/paths/analog-output-headphones.conf
23@@ -81,8 +81,8 @@ override-map.2 = all-left,all-right
24
25 [Element Headphone]
26 required-any = any
27-switch = mute
28-volume = merge
29+switch = on
30+volume = ignore
31 override-map.1 = all
32 override-map.2 = all-left,all-right
33
34@@ -105,8 +105,8 @@ switch = mute
35 volume = zero
36
37 [Element Speaker]
38-switch = off
39-volume = off
40+switch = on
41+volume = ignore
42
43 [Element Desktop Speaker]
44 switch = off
45diff --git a/src/modules/alsa/mixer/paths/analog-output-speaker.conf b/src/modules/alsa/mixer/paths/analog-output-speaker.conf
46index 39193dd..34bbb85 100644
47--- a/src/modules/alsa/mixer/paths/analog-output-speaker.conf
48+++ b/src/modules/alsa/mixer/paths/analog-output-speaker.conf
49@@ -73,8 +73,8 @@ volume = off
50 ; This profile path is intended to control the speaker, let's mute headphones
51 ; else there will be a spike when plugging in headphones
52 [Element Headphone]
53-switch = off
54-volume = off
55+switch = on
56+volume = ignore
57
58 [Element Headphone2]
59 switch = off
60@@ -93,8 +93,8 @@ override-map.2 = all-left,all-right
61
62 [Element Speaker]
63 required-any = any
64-switch = mute
65-volume = merge
66+switch = on
67+volume = ignore
68 override-map.1 = all
69 override-map.2 = all-left,all-right
70
71--
721.7.9.5
73
diff --git a/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend b/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend
index 68dc1c9..ebb8fcc 100644
--- a/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend
+++ b/recipes-multimedia/pulseaudio/pulseaudio_%.bbappend
@@ -5,7 +5,9 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/imx:"
5 5
6SRC_URI_append_mx6 = " file://daemon.conf file://default.pa" 6SRC_URI_append_mx6 = " file://daemon.conf file://default.pa"
7SRC_URI_append_mx6ul = " file://daemon.conf file://default.pa" 7SRC_URI_append_mx6ul = " file://daemon.conf file://default.pa"
8SRC_URI_append_mx7 = " file://daemon.conf file://default.pa" 8SRC_URI_append_mx7 = " file://daemon.conf file://default.pa \
9 file://pulseaudio-remove-the-control-for-speaker-headphone-widge.patch \
10"
9 11
10do_install_append() { 12do_install_append() {
11 if [ -e "${WORKDIR}/daemon.conf" ] && [ -e "${WORKDIR}/default.pa" ]; then 13 if [ -e "${WORKDIR}/daemon.conf" ] && [ -e "${WORKDIR}/default.pa" ]; then