summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2016-06-13 13:14:39 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2016-07-05 13:47:28 -0300
commit215c5fc3a31b92c11885785b3d3760d1e50156a6 (patch)
tree987c54c94e0f0292e4cf083e9609ab04ef1d54ab
parent356a33c381e26d6b0e4dc2bced0cd103faa2e45e (diff)
downloadmeta-fsl-arm-215c5fc3a31b92c11885785b3d3760d1e50156a6.tar.gz
weston: Fix weston window manager for i.MX 6UltraLite
The weston window manager failed to start on i.MX 6UltraLite EVK. 6UL has no GPU, so we need to use pixman. Fixed by removing EGL/GLES support, and by configuring to use Framebuffer backend as native. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-graphics/wayland/weston_%.bbappend7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes-graphics/wayland/weston_%.bbappend b/recipes-graphics/wayland/weston_%.bbappend
index b2f4466..f7bfd35 100644
--- a/recipes-graphics/wayland/weston_%.bbappend
+++ b/recipes-graphics/wayland/weston_%.bbappend
@@ -12,12 +12,19 @@ PACKAGECONFIG_append_mx6q = " cairo-glesv2"
12PACKAGECONFIG_append_mx6dl = " cairo-glesv2" 12PACKAGECONFIG_append_mx6dl = " cairo-glesv2"
13PACKAGECONFIG_append_mx6sx = " cairo-glesv2" 13PACKAGECONFIG_append_mx6sx = " cairo-glesv2"
14PACKAGECONFIG_remove_mx6sl = "egl" 14PACKAGECONFIG_remove_mx6sl = "egl"
15PACKAGECONFIG_remove_mx6ul = "egl"
15 16
16EXTRA_OECONF_append_mx6 = " \ 17EXTRA_OECONF_append_mx6 = " \
17 --disable-libunwind \ 18 --disable-libunwind \
18 --disable-xwayland-test \ 19 --disable-xwayland-test \
19 WESTON_NATIVE_BACKEND=fbdev-backend.so \ 20 WESTON_NATIVE_BACKEND=fbdev-backend.so \
20" 21"
22EXTRA_OECONF_append_mx6ul = " \
23 --disable-libunwind \
24 --disable-xwayland-test \
25 WESTON_NATIVE_BACKEND=fbdev-backend.so \
26"
27
21EXTRA_OEMAKE_append_mx6 = " \ 28EXTRA_OEMAKE_append_mx6 = " \
22 COMPOSITOR_CFLAGS="-I ${STAGING_INCDIR}/pixman-1 -DLINUX=1 -DEGL_API_FB -DEGL_API_WL" \ 29 COMPOSITOR_CFLAGS="-I ${STAGING_INCDIR}/pixman-1 -DLINUX=1 -DEGL_API_FB -DEGL_API_WL" \
23 FB_COMPOSITOR_CFLAGS="-DLINUX=1 -DEGL_API_FB -DEGL_API_WL" \ 30 FB_COMPOSITOR_CFLAGS="-DLINUX=1 -DEGL_API_FB -DEGL_API_WL" \