summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChunrong Guo <B40290@freescale.com>2015-11-17 16:47:49 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2015-11-23 13:45:14 -0200
commite296a9686665e518f181f1c04f2b65fc03eaac5f (patch)
tree82a23f5081d3afd48b973b9ad7c7553b01bf77dd
parentbadef44d5ae2644acc9afb96785d370de37b6ab1 (diff)
downloadmeta-fsl-arm-e296a9686665e518f181f1c04f2b65fc03eaac5f.tar.gz
u-boot-ls1: The finale u-boot binary is not named as u-boot.bin for sdcard/spi
Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-bsp/u-boot/u-boot-ls1_2015.01.bb25
1 files changed, 17 insertions, 8 deletions
diff --git a/recipes-bsp/u-boot/u-boot-ls1_2015.01.bb b/recipes-bsp/u-boot/u-boot-ls1_2015.01.bb
index 5b1e566..ae31763 100644
--- a/recipes-bsp/u-boot/u-boot-ls1_2015.01.bb
+++ b/recipes-bsp/u-boot/u-boot-ls1_2015.01.bb
@@ -25,17 +25,26 @@ DEPENDS += "change-file-endianess-native dtc-native"
25PROVIDES += "u-boot" 25PROVIDES += "u-boot"
26 26
27do_compile_append () { 27do_compile_append () {
28 if [ "x${UBOOT_CONFIG}" != "x" ] 28 unset i j
29 then 29 if [ "x${UBOOT_CONFIG}" != "x" ]; then
30 for config in ${UBOOT_MACHINE}; do 30 for config in ${UBOOT_MACHINE}; do
31 case "${config}" in 31 i=`expr $i + 1`;
32 *spi*) tclsh ${STAGING_BINDIR_NATIVE}/byte_swap.tcl ${S}/${config}/u-boot-dtb.bin ${S}/${config}/u-boot.swap.bin 8 32 for type in ${UBOOT_CONFIG}; do
33 mv ${S}/${config}/u-boot.swap.bin ${S}/u-boot-${type}.${UBOOT_SUFFIX};; 33 j=`expr $j + 1`;
34 *nand* | *sdcard*) mv ${S}/${config}/u-boot-with-spl-pbl.bin ${S}/${config}/u-boot.bin;; 34 if [ $j -eq $i ]; then
35 esac 35 case "${config}" in
36 *nand* | *sdcard*)
37 cp ${config}/u-boot-with-spl-pbl.bin ${config}/u-boot-${type}.${UBOOT_SUFFIX};;
38 *spi*)
39 tclsh ${STAGING_BINDIR_NATIVE}/byte_swap.tcl ${config}/u-boot-dtb.bin ${config}/u-boot.swap.bin 8
40 cp ${config}/u-boot.swap.bin ${config}/u-boot-${type}.${UBOOT_SUFFIX};;
41 esac
42 fi
43 done
44 unset j
36 done 45 done
46 unset i
37 fi 47 fi
38
39} 48}
40 49
41PACKAGES += "${PN}-images" 50PACKAGES += "${PN}-images"