summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeena Busireddy <neena.busireddy@freescale.com>2016-01-04 20:39:20 -0600
committerOtavio Salvador <otavio@ossystems.com.br>2016-02-11 18:09:47 -0200
commit84d64689deab3340fd32b86cd22c6b062333cc3d (patch)
tree4b5f8bb92c7c58f8a436b4bd7134749fbd7256c1
parent2fa1970fbaaa1be43bf003ecf8c4eaa677cb538e (diff)
downloadmeta-fsl-arm-84d64689deab3340fd32b86cd22c6b062333cc3d.tar.gz
xf86-video-imxfb-vivante: Upgrade to 5.0.11.p7.4 version
- License changed to MIT. - Remove the upstreamed patch. Signed-off-by: Neena Busireddy <neena.busireddy@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imxfb-vivante.inc2
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/0001-MGS-907-X11-EXA-Warnings-causes-GCC5.2-build-to-fail.patch137
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_5.0.11.p7.1.bb12
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_5.0.11.p7.4.bb11
4 files changed, 12 insertions, 150 deletions
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante.inc b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante.inc
index 9f856b3..aa37555 100644
--- a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante.inc
+++ b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante.inc
@@ -10,7 +10,7 @@ inherit autotools-brokensep update-rc.d pkgconfig
10 10
11DEPENDS += "virtual/xserver virtual/libx11 virtual/libgal-x11 imx-gpu-viv pixman" 11DEPENDS += "virtual/xserver virtual/libx11 virtual/libgal-x11 imx-gpu-viv pixman"
12 12
13LIC_FILES_CHKSUM = "file://COPYING-GPL-2;md5=59530bdf33659b29e73d4adb9f9f6552" 13LIC_FILES_CHKSUM = "file://COPYING-MIT;md5=b5e9d9f5c02ea831ab3ecf802bb7c4f3"
14 14
15SRC_URI = "${FSL_MIRROR}/xserver-xorg-video-imx-viv-${PV}.tar.gz \ 15SRC_URI = "${FSL_MIRROR}/xserver-xorg-video-imx-viv-${PV}.tar.gz \
16 file://rc.autohdmi" 16 file://rc.autohdmi"
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/0001-MGS-907-X11-EXA-Warnings-causes-GCC5.2-build-to-fail.patch b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/0001-MGS-907-X11-EXA-Warnings-causes-GCC5.2-build-to-fail.patch
deleted file mode 100644
index cb7e432..0000000
--- a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/0001-MGS-907-X11-EXA-Warnings-causes-GCC5.2-build-to-fail.patch
+++ /dev/null
@@ -1,137 +0,0 @@
1From 194e357faf3d7433ad4f1f2cf46f79d314ea5b38 Mon Sep 17 00:00:00 2001
2From: Prabhu <prabhu.sundararaj@freescale.com>
3Date: Wed, 29 Jul 2015 15:32:01 -0500
4Subject: [PATCH] MGS-907: X11 EXA: Warnings causes GCC5.2 build to fail
5
6VIV2DGPUSurfaceReAllocNonCached and imxRefreshModes were not
7declared causing compiler warning.
8
9Upstream Status: Pending
10
11Date: July 29, 2015
12Signed-off-by: Prabhu <prabhu.sundararaj@freescale.com>
13---
14 EXA/src/vivante_extension/vivante_ext.c | 4 ++--
15 EXA/src/vivante_fbdev/imx_display.c | 4 +++-
16 EXA/src/vivante_fbdev/vivante_fbdev_driver.c | 2 ++
17 EXA/src/vivante_gal/vivante_gal.h | 1 +
18 EXA/src/vivante_gal/vivante_gal_surface.c | 3 ++-
19 EXA/src/vivante_gal/vivante_priv.h | 4 ++++
20 6 files changed, 14 insertions(+), 4 deletions(-)
21 mode change 100755 => 100644 EXA/src/vivante_extension/vivante_ext.c
22 mode change 100755 => 100644 EXA/src/vivante_gal/vivante_gal_surface.c
23
24diff --git a/EXA/src/vivante_extension/vivante_ext.c b/EXA/src/vivante_extension/vivante_ext.c
25old mode 100755
26new mode 100644
27index 4bcc5ba..0d1085b
28--- a/EXA/src/vivante_extension/vivante_ext.c
29+++ b/EXA/src/vivante_extension/vivante_ext.c
30@@ -54,6 +54,7 @@
31 #include "vivante.h"
32 #include "vivante_priv.h"
33 #include "vivante_common.h"
34+#include "imx_display.h"
35
36 static unsigned char VIVEXTReqCode = 0;
37 static int VIVEXTErrorBase;
38@@ -162,8 +163,7 @@ static int ProcVIVEXTDrawableSetFlag(register ClientPtr client)
39 VivPtr pViv = VIVPTR_FROM_SCREEN(pScreen);
40 if(pViv)
41 {
42- VIVGPUPtr gpuctx = (VIVGPUPtr) pViv->mGrCtx.mGpu;
43- VIV2DGPUSurfaceReAllocNonCached(gpuctx, ppriv);
44+ VIV2DGPUSurfaceReAllocNonCached(&pViv->mGrCtx, ppriv);
45 // set tiled if asked
46 if(stuff->flag & VIVPIXMAP_FLAG_SHARED_TILED)
47 {
48diff --git a/EXA/src/vivante_fbdev/imx_display.c b/EXA/src/vivante_fbdev/imx_display.c
49index 876d37e..8d4eaa0 100644
50--- a/EXA/src/vivante_fbdev/imx_display.c
51+++ b/EXA/src/vivante_fbdev/imx_display.c
52@@ -27,6 +27,8 @@
53
54 #include <fcntl.h>
55 #include <errno.h>
56+#include <unistd.h>
57+#include <sys/ioctl.h>
58
59 #include <linux/fb.h>
60 #include "xf86DDC.h"
61@@ -83,7 +85,7 @@ GCD(int a, int b)
62 }
63
64 static int
65-LCM(a, b)
66+LCM(int a, int b)
67 {
68 return (a * b) / GCD(a, b);
69 }
70diff --git a/EXA/src/vivante_fbdev/vivante_fbdev_driver.c b/EXA/src/vivante_fbdev/vivante_fbdev_driver.c
71index ec407df..d35912a 100644
72--- a/EXA/src/vivante_fbdev/vivante_fbdev_driver.c
73+++ b/EXA/src/vivante_fbdev/vivante_fbdev_driver.c
74@@ -29,8 +29,10 @@
75 #include "vivante.h"
76 #include "vivante_exa.h"
77 #include "vivante_ext.h"
78+#include "vivante_dri.h"
79 #include "imx_display.h"
80 #include <errno.h>
81+#include <sys/ioctl.h>
82 #include <linux/fb.h>
83 #include <xorg/shmint.h>
84
85diff --git a/EXA/src/vivante_gal/vivante_gal.h b/EXA/src/vivante_gal/vivante_gal.h
86index e186eda..332c773 100644
87--- a/EXA/src/vivante_gal/vivante_gal.h
88+++ b/EXA/src/vivante_gal/vivante_gal.h
89@@ -260,6 +260,7 @@ extern "C" {
90 Bool VIV2DCacheOperation(GALINFOPTR galInfo, Viv2DPixmapPtr ppix, VIVFLUSHTYPE flush_type, int onLinearBuffer);
91 Bool VIV2DGPUUserMemMap(char* logical, unsigned int physical, unsigned int size, void ** mappingInfo, unsigned int * gpuAddress);
92 Bool VIV2DGPUUserMemUnMap(char* logical, unsigned int size, void * mappingInfo, unsigned int gpuAddress);
93+ Bool VIV2DGPUSurfaceReAllocNonCached(GALINFOPTR galInfo, Viv2DPixmapPtr ppriv);
94 Bool MapUserMemToGPU(GALINFOPTR galInfo, MemMapInfoPtr mmInfo);
95 void UnmapUserMem(GALINFOPTR galInfo, MemMapInfoPtr mmInfo);
96 /************************************************************************
97diff --git a/EXA/src/vivante_gal/vivante_gal_surface.c b/EXA/src/vivante_gal/vivante_gal_surface.c
98old mode 100755
99new mode 100644
100index 036b61b..0234814
101--- a/EXA/src/vivante_gal/vivante_gal_surface.c
102+++ b/EXA/src/vivante_gal/vivante_gal_surface.c
103@@ -673,7 +673,8 @@ static gctBOOL VIV2DGPUSurfaceAlloc(VIVGPUPtr gpuctx, gctUINT alignedWidth, gctU
104 return VIV2DGPUSurfaceAllocEx(gpuctx, alignedWidth, alignedHeight, bytesPerPixel, surface, getPixmapCachePolicy());
105 }
106
107-gctBOOL VIV2DGPUSurfaceReAllocNonCached(VIVGPUPtr gpuctx, Viv2DPixmapPtr ppriv) {
108+Bool VIV2DGPUSurfaceReAllocNonCached(GALINFOPTR galInfo, Viv2DPixmapPtr ppriv) {
109+ VIVGPUPtr gpuctx = (VIVGPUPtr)galInfo->mGpu;
110 GenericSurfacePtr oldSurf = gcvNULL;
111 GenericSurfacePtr newSurf = gcvNULL;
112 gctUINT32 alignedWidth;
113diff --git a/EXA/src/vivante_gal/vivante_priv.h b/EXA/src/vivante_gal/vivante_priv.h
114index e8ee3d2..05f5748 100644
115--- a/EXA/src/vivante_gal/vivante_priv.h
116+++ b/EXA/src/vivante_gal/vivante_priv.h
117@@ -29,6 +29,7 @@ extern "C" {
118 #include "HAL/gc_hal.h"
119 #include "HAL/gc_hal_raster.h"
120 #include "HAL/gc_hal_base.h"
121+#include "vivante_debug.h"
122
123 /************************************************************************
124 * PIXMAP_HANDLING_STUFF(START)
125@@ -97,6 +98,9 @@ extern "C" {
126 * DRIVER & DEVICE Structs (END)
127 *************************************************************************/
128
129+ gctBOOL VIV2DGPUSurfaceAllocEx(VIVGPUPtr gpuctx, gctUINT alignedWidth, gctUINT alignedHeight,
130+ gctUINT bytesPerPixel, GenericSurfacePtr * surface, enum PixmapCachePolicy cachePolicy);
131+
132 #ifdef __cplusplus
133 }
134 #endif
135--
1361.8.4.5
137
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_5.0.11.p7.1.bb b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_5.0.11.p7.1.bb
deleted file mode 100644
index 9fdd73a..0000000
--- a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_5.0.11.p7.1.bb
+++ /dev/null
@@ -1,12 +0,0 @@
1# Copyright (C) 2012-2015 Freescale Semiconductor
2# Copyright (C) 2012-2014 O.S. Systems Software LTDA.
3# Released under the MIT license (see COPYING.MIT for the terms)
4
5require xf86-video-imxfb-vivante.inc
6
7SRC_URI += "file://0001-MGS-907-X11-EXA-Warnings-causes-GCC5.2-build-to-fail.patch \
8 file://Stop-using-Git-to-write-local-version.patch \
9 file://Remove-dix-internal-header-usage.patch"
10
11SRC_URI[md5sum] = "05c54ed6d63e2a21dc18219e70869c29"
12SRC_URI[sha256sum] = "ab6a896cafba324105d26f52b7dad2c41d04d75cc9e48b66e8041a95660a04ee"
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_5.0.11.p7.4.bb b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_5.0.11.p7.4.bb
new file mode 100644
index 0000000..4c8af46
--- /dev/null
+++ b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_5.0.11.p7.4.bb
@@ -0,0 +1,11 @@
1# Copyright (C) 2012-2015 Freescale Semiconductor
2# Copyright (C) 2012-2014 O.S. Systems Software LTDA.
3# Released under the MIT license (see COPYING.MIT for the terms)
4
5require xf86-video-imxfb-vivante.inc
6
7SRC_URI += "file://Stop-using-Git-to-write-local-version.patch \
8 file://Remove-dix-internal-header-usage.patch"
9
10SRC_URI[md5sum] = "6e2d8ee518e9eef8421e9dcdc1ea79c3"
11SRC_URI[sha256sum] = "3effaf42bde64da8fad2dfe0dcef12d1cfbbbe189511dbd4612442129fd832cc"