summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-12-02 11:57:43 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2016-02-11 18:08:56 -0200
commit6e2c0ed3a1a40be4b75a1262b0f3107b429ecc5a (patch)
treeb521aae71bbec1452b04a1d9c824627936cdc209
parent9cbf0f90cf6e730296f9ac169b661582f61565c9 (diff)
downloadmeta-fsl-arm-6e2c0ed3a1a40be4b75a1262b0f3107b429ecc5a.tar.gz
xf86-video-imxfb-vivante: Stop using Git to write local version
The standard version does not use a Git repository so we should not use Git to identify the commit of the build as it can end getting the version from a wrong repository and can be misleading. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/Stop-using-Git-to-write-local-version.patch87
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_5.0.11.p7.1.bb3
2 files changed, 89 insertions, 1 deletions
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/Stop-using-Git-to-write-local-version.patch b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/Stop-using-Git-to-write-local-version.patch
new file mode 100644
index 0000000..f541e5c
--- /dev/null
+++ b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante/Stop-using-Git-to-write-local-version.patch
@@ -0,0 +1,87 @@
1From 69a92f4576a1e789ba2fcf957164d2c4013020c5 Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Wed, 2 Dec 2015 13:36:25 +0000
4Subject: [PATCH] Stop using Git to write local version
5Organization: O.S. Systems Software LTDA.
6
7The standard version does not use a Git repository so we should not
8use Git to identify the commit of the build as it can end getting the
9version from a wrong repository and can be misleading.
10
11Upstream-Status: Pending
12
13Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
14---
15 EXA/src/makefile.tc | 6 +++---
16 FslExt/src/makefile.tc | 6 +++---
17 util/autohdmi/makefile.tc | 6 +++---
18 util/pandisplay/makefile.tc | 6 +++---
19 4 files changed, 12 insertions(+), 12 deletions(-)
20
21diff --git a/EXA/src/makefile.tc b/EXA/src/makefile.tc
22index 0b9a9e6..ec6e68d 100644
23--- a/EXA/src/makefile.tc
24+++ b/EXA/src/makefile.tc
25@@ -52,8 +52,8 @@ prefix ?= /usr
26 sysroot ?= /
27
28 # get git commit number
29-COMMITNR := `git log -n 1 --format=%H`
30-DIRTY := `git diff-index --quiet HEAD || echo '-dirty'`
31-LOCAL_CFLAGS += -DCOMMIT="${COMMITNR}${DIRTY}"
32+#COMMITNR := `git log -n 1 --format=%H`
33+#DIRTY := `git diff-index --quiet HEAD || echo '-dirty'`
34+#LOCAL_CFLAGS += -DCOMMIT="${COMMITNR}${DIRTY}"
35
36
37diff --git a/FslExt/src/makefile.tc b/FslExt/src/makefile.tc
38index 0b9a9e6..ec6e68d 100644
39--- a/FslExt/src/makefile.tc
40+++ b/FslExt/src/makefile.tc
41@@ -52,8 +52,8 @@ prefix ?= /usr
42 sysroot ?= /
43
44 # get git commit number
45-COMMITNR := `git log -n 1 --format=%H`
46-DIRTY := `git diff-index --quiet HEAD || echo '-dirty'`
47-LOCAL_CFLAGS += -DCOMMIT="${COMMITNR}${DIRTY}"
48+#COMMITNR := `git log -n 1 --format=%H`
49+#DIRTY := `git diff-index --quiet HEAD || echo '-dirty'`
50+#LOCAL_CFLAGS += -DCOMMIT="${COMMITNR}${DIRTY}"
51
52
53diff --git a/util/autohdmi/makefile.tc b/util/autohdmi/makefile.tc
54index c9de0a6..d0a468c 100644
55--- a/util/autohdmi/makefile.tc
56+++ b/util/autohdmi/makefile.tc
57@@ -64,8 +64,8 @@ prefix ?= /usr
58 sysroot ?= /
59
60 # get git commit number
61-COMMITNR := `git log -n 1 --format=%H`
62-DIRTY := `git diff-index --quiet HEAD || echo '-dirty'`
63-LOCAL_CFLAGS += -DCOMMIT="${COMMITNR}${DIRTY}"
64+#COMMITNR := `git log -n 1 --format=%H`
65+#DIRTY := `git diff-index --quiet HEAD || echo '-dirty'`
66+#LOCAL_CFLAGS += -DCOMMIT="${COMMITNR}${DIRTY}"
67
68
69diff --git a/util/pandisplay/makefile.tc b/util/pandisplay/makefile.tc
70index 28732b9..bf54c20 100644
71--- a/util/pandisplay/makefile.tc
72+++ b/util/pandisplay/makefile.tc
73@@ -64,8 +64,8 @@ prefix ?= /usr
74 sysroot ?= /
75
76 # get git commit number
77-COMMITNR := `git log -n 1 --format=%H`
78-DIRTY := `git diff-index --quiet HEAD || echo '-dirty'`
79-LOCAL_CFLAGS += -DCOMMIT="${COMMITNR}${DIRTY}"
80+#COMMITNR := `git log -n 1 --format=%H`
81+#DIRTY := `git diff-index --quiet HEAD || echo '-dirty'`
82+#LOCAL_CFLAGS += -DCOMMIT="${COMMITNR}${DIRTY}"
83
84
85--
862.1.4
87
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_5.0.11.p7.1.bb b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_5.0.11.p7.1.bb
index 888d70b..d72e246 100644
--- a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_5.0.11.p7.1.bb
+++ b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_5.0.11.p7.1.bb
@@ -4,7 +4,8 @@
4 4
5require xf86-video-imxfb-vivante.inc 5require xf86-video-imxfb-vivante.inc
6 6
7SRC_URI += "file://0001-MGS-907-X11-EXA-Warnings-causes-GCC5.2-build-to-fail.patch" 7SRC_URI += "file://0001-MGS-907-X11-EXA-Warnings-causes-GCC5.2-build-to-fail.patch \
8 file://Stop-using-Git-to-write-local-version.patch"
8 9
9SRC_URI[md5sum] = "05c54ed6d63e2a21dc18219e70869c29" 10SRC_URI[md5sum] = "05c54ed6d63e2a21dc18219e70869c29"
10SRC_URI[sha256sum] = "ab6a896cafba324105d26f52b7dad2c41d04d75cc9e48b66e8041a95660a04ee" 11SRC_URI[sha256sum] = "ab6a896cafba324105d26f52b7dad2c41d04d75cc9e48b66e8041a95660a04ee"