summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGary Thomas <gary@mlbassoc.com>2016-04-15 15:02:53 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2016-04-23 12:02:10 -0300
commit996292e768478e0a8ce9ec488437e83c0ae8e4c2 (patch)
tree7262716917713e86207d1f7ba6f70bd2a22ce7f0
parentea924e2931dbd6d9802a2fe9c81b725f484089ea (diff)
downloadmeta-fsl-arm-996292e768478e0a8ce9ec488437e83c0ae8e4c2.tar.gz
imx-kobs: Fix compiler error with Linux kernel headers version >= 4.4
This patch fixes a build error with kernel includes (>= 4.4) <stdint.h> must be explicitly included to get uintX_t types. Change-Id: I3a0059a59bf578fdba0cf68370eec0e19fc10835 Signed-off-by: Gary Thomas <gary@mlbassoc.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-bsp/imx-kobs/imx-kobs/fix-compile.patch17
-rw-r--r--recipes-bsp/imx-kobs/imx-kobs_5.3.bb4
2 files changed, 20 insertions, 1 deletions
diff --git a/recipes-bsp/imx-kobs/imx-kobs/fix-compile.patch b/recipes-bsp/imx-kobs/imx-kobs/fix-compile.patch
new file mode 100644
index 0000000..2ac73ae
--- /dev/null
+++ b/recipes-bsp/imx-kobs/imx-kobs/fix-compile.patch
@@ -0,0 +1,17 @@
1This patch fixes a build error with kernel includes (>= 4.4) <stdint.h> must
2be explicitly included to get uintX_t types.
3
4Upstream-Status: Pending
5
6Index: imx-kobs-5.4/src/BootControlBlocks.h
7===================================================================
8--- imx-kobs-5.4.orig/src/BootControlBlocks.h
9+++ imx-kobs-5.4/src/BootControlBlocks.h
10@@ -54,6 +54,7 @@
11 //! This structure holds the timing for the NAND. This data is used by
12 //! rom_nand_hal_GpmiSetNandTiming to setup the GPMI hardware registers.
13
14+#include <stdint.h>
15 typedef struct _NAND_Timing {
16 uint8_t m_u8DataSetup;
17 uint8_t m_u8DataHold;
diff --git a/recipes-bsp/imx-kobs/imx-kobs_5.3.bb b/recipes-bsp/imx-kobs/imx-kobs_5.3.bb
index ccc4a24..d641cbf 100644
--- a/recipes-bsp/imx-kobs/imx-kobs_5.3.bb
+++ b/recipes-bsp/imx-kobs/imx-kobs_5.3.bb
@@ -5,7 +5,9 @@ SECTION = "base"
5LICENSE = "GPLv2" 5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833" 6LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
7 7
8SRC_URI = "${FSL_MIRROR}/imx-kobs-${PV}.tar.gz" 8SRC_URI = "${FSL_MIRROR}/imx-kobs-${PV}.tar.gz \
9 file://fix-compile.patch \
10"
9 11
10SRC_URI[md5sum] = "a2a9e1c3445d14c961577492313a41fb" 12SRC_URI[md5sum] = "a2a9e1c3445d14c961577492313a41fb"
11SRC_URI[sha256sum] = "45f729fc2b49556f1ca9df778f52bf5cc749cfe53664c8206daab29991c5f6c1" 13SRC_URI[sha256sum] = "45f729fc2b49556f1ca9df778f52bf5cc749cfe53664c8206daab29991c5f6c1"