summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLauren Post <lauren.post@freescale.com>2015-07-24 10:40:47 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-31 09:29:29 -0300
commitfd96dfcf0adda52cc37de23ad65891ea1a590163 (patch)
tree9db6de3ea713dd22dab0287a75b440992bf94812
parentc2a6240c00c8635c6ac98d5cac30827ae91f5d02 (diff)
downloadmeta-fsl-arm-fd96dfcf0adda52cc37de23ad65891ea1a590163.tar.gz
mesa: Support for mx6 without GPUs
Fix to support future mx6 i.MX 6UltraLite which does not have a GPU. This SoC will use mesa so mesa changes before should be more SoC specific to allow future mx6 SoC without GPU to use mesa. Signed-off-by: Lauren Post <lauren.post@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend19
1 files changed, 12 insertions, 7 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index ec11097..6cc7de7 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,17 +1,22 @@
1PACKAGECONFIG_remove_mx5 = "egl gles" 1PACKAGECONFIG_remove_mx5 = "egl gles"
2PROVIDES_remove_mx5 = "virtual/libgles1 virtual/libgles2 virtual/egl" 2PROVIDES_remove_mx5 = "virtual/libgles1 virtual/libgles2 virtual/egl"
3 3
4PACKAGECONFIG_remove_mx6 = "egl gles" 4PACKAGECONFIG_remove_mx6q = "egl gles"
5PACKAGECONFIG_remove_mx6dl = "egl gles"
6PACKAGECONFIG_remove_mx6sx = "egl gles"
7PACKAGECONFIG_remove_mx6sl = "egl gles"
5 8
6# i.MX6SL uses mesa software rendering 9# i.MX6SL uses mesa software rendering
7 10
8PROVIDES_remove_mx6 = "virtual/libgles1 virtual/libgles2 virtual/egl" 11PROVIDES_remove_mx6q = "virtual/libgles1 virtual/libgles2 virtual/egl virtual/libgl"
9PROVIDES_remove_mx6q = "virtual/libgl" 12PROVIDES_remove_mx6dl = "virtual/libgles1 virtual/libgles2 virtual/egl virtual/libgl"
10PROVIDES_remove_mx6dl = "virtual/libgl" 13PROVIDES_remove_mx6sx = "virtual/libgles1 virtual/libgles2 virtual/egl virtual/libgl"
11PROVIDES_remove_mx6sx = "virtual/libgl" 14PROVIDES_remove_mx6sl = "virtual/libgles1 virtual/libgles2 virtual/egl"
12 15
13USE_VIV_LIBGL = "yes" 16USE_VIV_LIBGL = "no"
14USE_VIV_LIBGL_mx6sl = "no" 17USE_VIV_LIBGL_mx6q = "yes"
18USE_VIV_LIBGL_mx6dl = "yes"
19USE_VIV_LIBGL_mx6sx = "yes"
15 20
16# FIXME: Dirty hack to allow use of Vivante GPU libGL binary 21# FIXME: Dirty hack to allow use of Vivante GPU libGL binary
17do_install_append_mx6 () { 22do_install_append_mx6 () {