summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-09-07 17:35:51 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2012-09-07 17:36:08 -0300
commitfa7ad4cc6cf5bc20cf7632ac1a22f3310149bfec (patch)
tree0a92ea61c38c966b803fcd5f35fb7dc6dea2db74
parente73369508843c7a2982656c05ed6e7ab759dcd66 (diff)
parenta8c56bc155e9576eb7a7d6546a610b2a6cab1837 (diff)
downloadmeta-fsl-arm-fa7ad4cc6cf5bc20cf7632ac1a22f3310149bfec.tar.gz
Merge remote branch 'freescale/denzil' into master
* freescale/denzil: qt4-embedded: enable OpenGL ES2 and OpenVG for mx5 SoCs qt4-x11-free: enable OpenGL ES2 and OpenVG for mx5 SoCs amd-gpu-x11-bin-mx51: Proper detect the building on Linux amd-gpu-x11-bin-mx51: Set compatibility as mx5 SoC family only
-rw-r--r--recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51/fix-linux-build-check.patch54
-rw-r--r--recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb8
-rw-r--r--recipes-qt/qt4/qt4-embedded_4.8.1.bbappend4
-rw-r--r--recipes-qt/qt4/qt4-x11-free_4.8.1.bbappend4
4 files changed, 66 insertions, 4 deletions
diff --git a/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51/fix-linux-build-check.patch b/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51/fix-linux-build-check.patch
new file mode 100644
index 0000000..946bfac
--- /dev/null
+++ b/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51/fix-linux-build-check.patch
@@ -0,0 +1,54 @@
1diff -Nur amd-gpu-x11-bin-mx51-11.09.01.orig/usr/include/EGL/eglext.h amd-gpu-x11-bin-mx51-11.09.01/usr/include/EGL/eglext.h
2--- amd-gpu-x11-bin-mx51-11.09.01.orig/usr/include/EGL/eglext.h 2012-08-18 12:43:19.431788396 -0300
3+++ amd-gpu-x11-bin-mx51-11.09.01/usr/include/EGL/eglext.h 2012-08-18 12:43:50.799909873 -0300
4@@ -164,11 +164,11 @@
5 * nanoseconds (unadjusted standard time). Here, it is defined as
6 * appropriate for an ISO C compiler.
7 */
8-#ifndef _LINUX
9+#ifndef __linux__
10 typedef uint64_t EGLTimeKHR;
11-#else // _LINUX
12+#else // __linux__
13 typedef unsigned long long EGLTimeKHR;
14-#endif // _LINUX
15+#endif // __linux__
16
17 #define EGL_SYNC_PRIOR_COMMANDS_COMPLETE_KHR 0xFFF8
18 #define EGL_SYNC_STATUS_KHR 0xFFF7
19diff -Nur amd-gpu-x11-bin-mx51-11.09.01.orig/usr/include/EGL/eglfslext.h amd-gpu-x11-bin-mx51-11.09.01/usr/include/EGL/eglfslext.h
20--- amd-gpu-x11-bin-mx51-11.09.01.orig/usr/include/EGL/eglfslext.h 2012-08-18 12:43:19.431788396 -0300
21+++ amd-gpu-x11-bin-mx51-11.09.01/usr/include/EGL/eglfslext.h 2012-08-18 12:43:50.759785714 -0300
22@@ -65,7 +65,7 @@
23 } eglYUVInfo;
24 #endif
25
26-#ifdef _LINUX
27+#ifdef __linux__
28 struct EGLImageInfoFSL
29 {
30 void *mem_virt[3]; //virtual addresses for Y/U/V planes
31diff -Nur amd-gpu-x11-bin-mx51-11.09.01.orig/usr/include/VG/ext.h amd-gpu-x11-bin-mx51-11.09.01/usr/include/VG/ext.h
32--- amd-gpu-x11-bin-mx51-11.09.01.orig/usr/include/VG/ext.h 2012-08-18 12:43:19.431788396 -0300
33+++ amd-gpu-x11-bin-mx51-11.09.01/usr/include/VG/ext.h 2012-08-18 12:43:50.799909873 -0300
34@@ -15,7 +15,7 @@
35 extern "C" {
36 #endif
37
38-#ifndef _LINUX
39+#ifndef __linux__
40 #include <VG/openvg.h>
41 #else
42 #include "openvg.h"
43diff -Nur amd-gpu-x11-bin-mx51-11.09.01.orig/usr/include/VG/openvg.h amd-gpu-x11-bin-mx51-11.09.01/usr/include/VG/openvg.h
44--- amd-gpu-x11-bin-mx51-11.09.01.orig/usr/include/VG/openvg.h 2012-08-18 12:43:19.431788396 -0300
45+++ amd-gpu-x11-bin-mx51-11.09.01/usr/include/VG/openvg.h 2012-08-18 12:43:50.799909873 -0300
46@@ -449,7 +449,7 @@
47 # endif
48 # elif defined(__APPLE__)
49 # define VG_API_CALL extern
50-# elif defined(_LINUX)
51+# elif defined(__linux__)
52 # if defined (OPENVG_DLL_EXPORTS)
53 # define VG_API_CALL extern
54 # else
diff --git a/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb b/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb
index 10f2e6e..49fdaab 100644
--- a/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb
+++ b/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb
@@ -4,14 +4,15 @@
4DESCRIPTION = "GPU driver and apps for x11 on mx51" 4DESCRIPTION = "GPU driver and apps for x11 on mx51"
5LICENSE = "MIT" 5LICENSE = "MIT"
6SECTION = "libs" 6SECTION = "libs"
7PR = "r6" 7PR = "r8"
8 8
9#todo: Replace for correct AMD license 9#todo: Replace for correct AMD license
10LIC_FILES_CHKSUM = "file://usr/include/VG/openvg.h;endline=30;md5=b0109611dd76961057d4c45ae6519802" 10LIC_FILES_CHKSUM = "file://usr/include/VG/openvg.h;endline=30;md5=b0109611dd76961057d4c45ae6519802"
11DEPENDS = "virtual/libx11 libz160" 11DEPENDS = "virtual/libx11 libz160"
12RDEPENDS = "libz160" 12RDEPENDS = "libz160"
13 13
14SRC_URI = "file://${PN}-${PV}.tar.gz" 14SRC_URI = "file://${PN}-${PV}.tar.gz \
15 file://fix-linux-build-check.patch"
15SRC_URI[md5sum] = "499a2cc08dd48a6c5f7db8d231428548" 16SRC_URI[md5sum] = "499a2cc08dd48a6c5f7db8d231428548"
16SRC_URI[sha256sum] = "6150d3d72a3f8abb26df1e31cee0f07f53c106c8d5de014c1175c8cb721fac29" 17SRC_URI[sha256sum] = "6150d3d72a3f8abb26df1e31cee0f07f53c106c8d5de014c1175c8cb721fac29"
17 18
@@ -40,3 +41,6 @@ FILES_${PN}-dev = "\
40 ${includedir}/KHR/*.h \ 41 ${includedir}/KHR/*.h \
41 ${includedir}/VG/*.h" 42 ${includedir}/VG/*.h"
42FILES_${PN}-staticdev = "${libdir}/*.a" 43FILES_${PN}-staticdev = "${libdir}/*.a"
44
45COMPATIBLE_MACHINE = "(mx5)"
46PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-qt/qt4/qt4-embedded_4.8.1.bbappend b/recipes-qt/qt4/qt4-embedded_4.8.1.bbappend
index 70d890f..1419814 100644
--- a/recipes-qt/qt4/qt4-embedded_4.8.1.bbappend
+++ b/recipes-qt/qt4/qt4-embedded_4.8.1.bbappend
@@ -5,6 +5,8 @@ SRC_URI_append_mx5 += "file://0001-Add-support-for-i.MX-codecs-to-phonon.patch"
5SRC_URI_append_mx6 += "file://0001-Add-support-for-i.MX-codecs-to-phonon.patch" 5SRC_URI_append_mx6 += "file://0001-Add-support-for-i.MX-codecs-to-phonon.patch"
6 6
7PACKAGE_ARCH_mx5 = "${MACHINE_ARCH}" 7PACKAGE_ARCH_mx5 = "${MACHINE_ARCH}"
8QT_GLFLAGS_mx5 = "-opengl es2 -openvg"
9
8PACKAGE_ARCH_mx6 = "${MACHINE_ARCH}" 10PACKAGE_ARCH_mx6 = "${MACHINE_ARCH}"
9 11
10PRINC := "${@int(PRINC) + 2}" 12PRINC := "${@int(PRINC) + 3}"
diff --git a/recipes-qt/qt4/qt4-x11-free_4.8.1.bbappend b/recipes-qt/qt4/qt4-x11-free_4.8.1.bbappend
index 70d890f..1419814 100644
--- a/recipes-qt/qt4/qt4-x11-free_4.8.1.bbappend
+++ b/recipes-qt/qt4/qt4-x11-free_4.8.1.bbappend
@@ -5,6 +5,8 @@ SRC_URI_append_mx5 += "file://0001-Add-support-for-i.MX-codecs-to-phonon.patch"
5SRC_URI_append_mx6 += "file://0001-Add-support-for-i.MX-codecs-to-phonon.patch" 5SRC_URI_append_mx6 += "file://0001-Add-support-for-i.MX-codecs-to-phonon.patch"
6 6
7PACKAGE_ARCH_mx5 = "${MACHINE_ARCH}" 7PACKAGE_ARCH_mx5 = "${MACHINE_ARCH}"
8QT_GLFLAGS_mx5 = "-opengl es2 -openvg"
9
8PACKAGE_ARCH_mx6 = "${MACHINE_ARCH}" 10PACKAGE_ARCH_mx6 = "${MACHINE_ARCH}"
9 11
10PRINC := "${@int(PRINC) + 2}" 12PRINC := "${@int(PRINC) + 3}"