summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeena Busireddy <neena.busireddy@freescale.com>2015-04-13 15:39:42 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2015-04-14 13:31:07 -0300
commite3cc9452aaa2895bbc8bdd7c8940b4dd2d14213e (patch)
tree1da2124894bff5639e1ee3666b65f42f8d27bf9a
parentfc553238c6210b2198582b08d075b5290718470c (diff)
downloadmeta-fsl-arm-e3cc9452aaa2895bbc8bdd7c8940b4dd2d14213e.tar.gz
xf86-video-imxfb-vivante: Add xf86-video-imxfb-vivante.inc file
Add xf86-video-imxfb-vivante.inc file to avoid duplication for new releases. Signed-off-by: Neena Busireddy <neena.busireddy@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imxfb-vivante.inc79
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_5.0.11.p4.4.bb76
2 files changed, 80 insertions, 75 deletions
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante.inc b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante.inc
new file mode 100644
index 0000000..684cdb4
--- /dev/null
+++ b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante.inc
@@ -0,0 +1,79 @@
1# Copyright (C) 2012-2015 Freescale Semiconductor
2# Copyright (C) 2012-2014 O.S. Systems Software LTDA.
3# Released under the MIT license (see COPYING.MIT for the terms)
4
5require recipes-graphics/xorg-driver/xorg-driver-video.inc
6
7PE = "3"
8
9inherit autotools-brokensep update-rc.d pkgconfig
10
11DEPENDS += "virtual/xserver virtual/libx11 virtual/libgal-x11 imx-gpu-viv pixman"
12
13LIC_FILES_CHKSUM = "file://EXA/src/vivante_fbdev/vivante.h;endline=19;md5=95cf961a2ceacdf7cf43caef25766779"
14
15SRC_URI = "${FSL_MIRROR}/xserver-xorg-video-imx-viv-${PV}.tar.gz \
16 file://rc.autohdmi"
17
18INITSCRIPT_PACKAGES = "xserver-xorg-extension-viv-autohdmi"
19INITSCRIPT_NAME = "rc.autohdmi"
20INITSCRIPT_PARAMS = "start 99 2 3 4 5 ."
21
22EXTRA_OEMAKE += "-C ${S} -d -f Makefile prefix=${D}/usr \
23 sysroot=${STAGING_DIR_TARGET} \
24 BUSID_HAS_NUMBER=1 \
25 BUILD_IN_YOCTO=1 \
26 XSERVER_GREATER_THAN_13=1"
27
28CFLAGS += "-I${STAGING_INCDIR}/xorg \
29 -I${STAGING_INCDIR}/drm \
30 -I../../DRI_1.10.4/src"
31
32S = "${WORKDIR}/xserver-xorg-video-imx-viv-${PV}/"
33
34PACKAGES =+ "xserver-xorg-extension-viv-autohdmi"
35
36# FIXME: The Freescale provided Makefile has hardcodec include paths
37# and this does not work in case prefix is different than /usr,
38# sed it.
39do_configure_prepend () {
40 sed -i 's,$(sysroot)/usr/include,${STAGING_INCDIR},g' \
41 ${S}EXA/src/makefile.linux
42}
43
44# FIXME: This is need as Freescale didn't use standard Makefile filename
45# thus oe_runmame thinks nothing is need to be done, use ln to
46# workaround it.
47base_do_compile () {
48 oe_runmake || die "make failed"
49}
50
51do_install_append () {
52 install -d ${D}${includedir}
53 cp -axr ${S}/EXA/src/vivante_gal/vivante_priv.h ${D}${includedir}
54 cp -axr ${S}/EXA/src/vivante_gal/vivante_gal.h ${D}${includedir}
55
56 install -d ${D}/${sysconfdir}/init.d
57 install -m 755 ${WORKDIR}/rc.autohdmi ${D}/${sysconfdir}/init.d/rc.autohdmi
58
59 find ${D}${includedir} -type f -exec chmod 660 {} \;
60}
61
62RDEPENDS_${PN} += "libvivante-dri-mx6 \
63 xserver-xorg-module-exa \
64 mesa-driver-swrast \
65 xserver-xorg-extension-dri \
66 xserver-xorg-extension-dri2 \
67 xserver-xorg-extension-glx"
68
69REALSOLIBS := "${SOLIBS}"
70SOLIBS = "${SOLIBSDEV}"
71
72FILES_${PN} = "${libdir}/*/*/*/vivante_drv${SOLIBS}"
73FILES_${PN}-dev = "${includedir} /usr/src ${libdir}/libfsl_x11_ext${SOLIBSDEV}"
74FILES_${PN}-dbg = "${libdir}/*/*/*/.debug ${libdir}/.debug/libfsl_x11_ext${SOLIBS} ${exec_prefix}/bin/.debug/autohdmi"
75
76FILES_xserver-xorg-extension-viv-autohdmi = " ${libdir}/libfsl_x11_ext${SOLIBS} ${exec_prefix}/bin/autohdmi ${sysconfdir}/init.d/rc.autohdmi"
77
78PACKAGE_ARCH = "${MACHINE_SOCARCH}"
79COMPATIBLE_MACHINE = "(mx6)"
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_5.0.11.p4.4.bb b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_5.0.11.p4.4.bb
index 5430f00..669846f 100644
--- a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_5.0.11.p4.4.bb
+++ b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_5.0.11.p4.4.bb
@@ -2,81 +2,7 @@
2# Copyright (C) 2012-2014 O.S. Systems Software LTDA. 2# Copyright (C) 2012-2014 O.S. Systems Software LTDA.
3# Released under the MIT license (see COPYING.MIT for the terms) 3# Released under the MIT license (see COPYING.MIT for the terms)
4 4
5require recipes-graphics/xorg-driver/xorg-driver-video.inc 5require xf86-video-imxfb-vivante.inc
6
7PE = "3"
8
9inherit autotools-brokensep update-rc.d pkgconfig
10
11DEPENDS += "virtual/xserver virtual/libx11 virtual/libgal-x11 imx-gpu-viv pixman"
12
13LIC_FILES_CHKSUM = "file://EXA/src/vivante_fbdev/vivante.h;endline=19;md5=95cf961a2ceacdf7cf43caef25766779"
14
15SRC_URI = "${FSL_MIRROR}/xserver-xorg-video-imx-viv-${PV}.tar.gz \
16 file://rc.autohdmi"
17 6
18SRC_URI[md5sum] = "6003295f7d586e5b6d4b5ffdb5d2f700" 7SRC_URI[md5sum] = "6003295f7d586e5b6d4b5ffdb5d2f700"
19SRC_URI[sha256sum] = "9ca2356ca35a734615a205cf307b3c41f6e22c171ff823b6d5422c5473a69947" 8SRC_URI[sha256sum] = "9ca2356ca35a734615a205cf307b3c41f6e22c171ff823b6d5422c5473a69947"
20
21INITSCRIPT_PACKAGES = "xserver-xorg-extension-viv-autohdmi"
22INITSCRIPT_NAME = "rc.autohdmi"
23INITSCRIPT_PARAMS = "start 99 2 3 4 5 ."
24
25EXTRA_OEMAKE += "-C ${S} -d -f Makefile prefix=${D}/usr \
26 sysroot=${STAGING_DIR_TARGET} \
27 BUSID_HAS_NUMBER=1 \
28 BUILD_IN_YOCTO=1 \
29 XSERVER_GREATER_THAN_13=1"
30
31CFLAGS += "-I${STAGING_INCDIR}/xorg \
32 -I${STAGING_INCDIR}/drm \
33 -I../../DRI_1.10.4/src"
34
35S = "${WORKDIR}/xserver-xorg-video-imx-viv-${PV}/"
36
37PACKAGES =+ "xserver-xorg-extension-viv-autohdmi"
38
39# FIXME: The Freescale provided Makefile has hardcodec include paths
40# and this does not work in case prefix is different than /usr,
41# sed it.
42do_configure_prepend () {
43 sed -i 's,$(sysroot)/usr/include,${STAGING_INCDIR},g' \
44 ${S}EXA/src/makefile.linux
45}
46
47# FIXME: This is need as Freescale didn't use standard Makefile filename
48# thus oe_runmame thinks nothing is need to be done, use ln to
49# workaround it.
50base_do_compile () {
51 oe_runmake || die "make failed"
52}
53
54do_install_append () {
55 install -d ${D}${includedir}
56 cp -axr ${S}/EXA/src/vivante_gal/vivante_priv.h ${D}${includedir}
57 cp -axr ${S}/EXA/src/vivante_gal/vivante_gal.h ${D}${includedir}
58
59 install -d ${D}/${sysconfdir}/init.d
60 install -m 755 ${WORKDIR}/rc.autohdmi ${D}/${sysconfdir}/init.d/rc.autohdmi
61
62 find ${D}${includedir} -type f -exec chmod 660 {} \;
63}
64
65RDEPENDS_${PN} += "libvivante-dri-mx6 \
66 xserver-xorg-module-exa \
67 mesa-driver-swrast \
68 xserver-xorg-extension-dri \
69 xserver-xorg-extension-dri2 \
70 xserver-xorg-extension-glx"
71
72REALSOLIBS := "${SOLIBS}"
73SOLIBS = "${SOLIBSDEV}"
74
75FILES_${PN} = "${libdir}/*/*/*/vivante_drv${SOLIBS}"
76FILES_${PN}-dev = "${includedir} /usr/src ${libdir}/libfsl_x11_ext${SOLIBSDEV}"
77FILES_${PN}-dbg = "${libdir}/*/*/*/.debug ${libdir}/.debug/libfsl_x11_ext${SOLIBS} ${exec_prefix}/bin/.debug/autohdmi"
78
79FILES_xserver-xorg-extension-viv-autohdmi = " ${libdir}/libfsl_x11_ext${SOLIBS} ${exec_prefix}/bin/autohdmi ${sysconfdir}/init.d/rc.autohdmi"
80
81PACKAGE_ARCH = "${MACHINE_SOCARCH}"
82COMPATIBLE_MACHINE = "(mx6)"