summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@freescale.com>2015-07-10 17:45:10 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-16 08:42:10 -0300
commitce8d6756ab3c4ad9b3d810da08cbc3cc73213869 (patch)
treeda35e8be6ef643145c853cab3ff1a7322bdfc28e
parentc2b7a4bf56095bf517debd2e56f9fa59a0f25435 (diff)
downloadmeta-fsl-arm-ce8d6756ab3c4ad9b3d810da08cbc3cc73213869.tar.gz
u-boot-ls1: update to revision v2015.01-630-g6ba8eed
Changes: 1. Rebased on git://git.denx.de/u-boot.git v2015.01-487-gab92da9 2. Applied another 143 FSL/backported patches (git log ab92da9..) 3. add DEPENDS on dtc-native as u-boot brings in device tree files 4. use u-boot-with-spl-pbl.bin for nand 5. replace with u-boot-dtb.bin when swapping the image endianness Signed-off-by: Ting Liu <ting.liu@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-bsp/u-boot/u-boot-ls1_2015.01.bb (renamed from recipes-bsp/u-boot/u-boot-ls1_2014.07.bb)13
1 files changed, 7 insertions, 6 deletions
diff --git a/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb b/recipes-bsp/u-boot/u-boot-ls1_2015.01.bb
index ad1dd4b..716105f 100644
--- a/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb
+++ b/recipes-bsp/u-boot/u-boot-ls1_2015.01.bb
@@ -1,6 +1,6 @@
1require recipes-bsp/u-boot/u-boot.inc 1require recipes-bsp/u-boot/u-boot.inc
2 2
3DESCRIPTION = "U-Boot which includes the support for QorIQ Layerscape1 series boards" 3DESCRIPTION = "U-Boot provided by Freescale with focus on QorIQ Layerscape1 boards"
4LICENSE = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1" 4LICENSE = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1"
5LIC_FILES_CHKSUM = " \ 5LIC_FILES_CHKSUM = " \
6 file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ 6 file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
@@ -10,17 +10,17 @@ LIC_FILES_CHKSUM = " \
10 file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \ 10 file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \
11" 11"
12 12
13SRCBRANCH = "sdk-v1.7.x" 13SRCBRANCH = "master"
14SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=${SRCBRANCH}" 14SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=${SRCBRANCH}"
15SRCREV = "659b6a23a8b1f3026200bc6352dbacef53f4dcb1" 15SRCREV = "6ba8eedbcdc4b063f59a63e6288b938af739e8ad"
16 16
17LOCALVERSION ?= "-${SRCBRANCH}" 17LOCALVERSION ?= "+ls1"
18 18
19S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
20 20
21inherit fsl-u-boot-localversion 21inherit fsl-u-boot-localversion
22 22
23DEPENDS += "change-file-endianess-native" 23DEPENDS += "change-file-endianess-native dtc-native"
24PROVIDES += "u-boot" 24PROVIDES += "u-boot"
25 25
26do_compile_append () { 26do_compile_append () {
@@ -28,9 +28,10 @@ do_compile_append () {
28 then 28 then
29 for config in ${UBOOT_MACHINE}; do 29 for config in ${UBOOT_MACHINE}; do
30 case "${config}" in 30 case "${config}" in
31 *spi*) tclsh ${STAGING_BINDIR_NATIVE}/byte_swap.tcl ${S}/${config}/u-boot.bin ${S}/${config}/u-boot.swap.bin 8 31 *spi*) tclsh ${STAGING_BINDIR_NATIVE}/byte_swap.tcl ${S}/${config}/u-boot-dtb.bin ${S}/${config}/u-boot.swap.bin 8
32 mv ${S}/${config}/u-boot.swap.bin ${S}/u-boot-${type}.${UBOOT_SUFFIX};; 32 mv ${S}/${config}/u-boot.swap.bin ${S}/u-boot-${type}.${UBOOT_SUFFIX};;
33 *sdcard*) mv ${S}/${config}/u-boot-with-spl-pbl.bin ${S}/${config}/u-boot.bin;; 33 *sdcard*) mv ${S}/${config}/u-boot-with-spl-pbl.bin ${S}/${config}/u-boot.bin;;
34 *nand*) mv ${S}/u-boot-with-spl-pbl.bin ${S}/u-boot.bin;;
34 esac 35 esac
35 done 36 done
36 fi 37 fi