summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Rafael Giani <dv@pseudoterminal.org>2015-06-08 11:47:00 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2015-06-10 12:10:09 -0300
commitcb3ff963b1bbff7d2c2a9e6344e4ea592a958154 (patch)
treeb97c81bd8a74f03dd6e54097c10ad2690ea87d3d
parentda3d17b725ee009831bcb595bd9802c7a9c1f928 (diff)
downloadmeta-fsl-arm-cb3ff963b1bbff7d2c2a9e6344e4ea592a958154.tar.gz
gstreamer1.0-plugins-imx: Update to version 0.10.2
Changes: - v4l2src: renamed imxv4l2src to imxv4l2videosrc to avoid name collisions with the FSL plugins - v4l2src: Call the buffer pool baseclass stop() function (fixes segfaults) - uniaudio: Create correct config header even if no codecs were found - audio: new MP3 encoder element using the libfslcodec MP3 encoder - g2d/ipu/pxp blitter sink: Respect aspect ratio also in 90/270 degree rotations - pxp: Remove broken/unsupported formats - eglvivsink: Fix double mutex unlock - phys mem meta naming cleanup Change-Id: Id2c72352f19cfeb6635af2ed0ec625867c28b7a7 Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx/0001-pxp-Check-for-new-format-specifier-from-the-new-FSL-.patch30
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.10.2.bb (renamed from recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.10.1.bb)5
2 files changed, 2 insertions, 33 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx/0001-pxp-Check-for-new-format-specifier-from-the-new-FSL-.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx/0001-pxp-Check-for-new-format-specifier-from-the-new-FSL-.patch
deleted file mode 100644
index 9390a00..0000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx/0001-pxp-Check-for-new-format-specifier-from-the-new-FSL-.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1From 66c2285aff440d2cdbd16ee6893bdbbbd814a08b Mon Sep 17 00:00:00 2001
2From: Carlos Rafael Giani <carlos.giani@streamunlimited.com>
3Date: Tue, 7 Apr 2015 18:34:05 +0200
4Subject: [PATCH] pxp: Check for new format specifier from the new FSL 3.14
5 kernel
6
7Signed-off-by: Carlos Rafael Giani <carlos.giani@streamunlimited.com>
8---
9 src/pxp/blitter.c | 4 ++++
10 1 file changed, 4 insertions(+)
11
12diff --git a/src/pxp/blitter.c b/src/pxp/blitter.c
13index b96b3b9..7f44d03 100644
14--- a/src/pxp/blitter.c
15+++ b/src/pxp/blitter.c
16@@ -391,7 +391,11 @@ static GstImxPxPFormatDetails const * gst_imx_pxp_blitter_get_pxp_format_details
17 case GST_VIDEO_FORMAT_YUY2: FORMAT_DETAILS(PXP_PIX_FMT_YUYV, 16);
18 case GST_VIDEO_FORMAT_UYVY: FORMAT_DETAILS(PXP_PIX_FMT_UYVY, 16);
19 case GST_VIDEO_FORMAT_YVYU: FORMAT_DETAILS(PXP_PIX_FMT_YVYU, 16);
20+#ifdef PXP_PIX_FMT_VUY444
21+ case GST_VIDEO_FORMAT_v308: FORMAT_DETAILS(PXP_PIX_FMT_VUY444, 24);
22+#else
23 case GST_VIDEO_FORMAT_v308: FORMAT_DETAILS(PXP_PIX_FMT_YUV444, 24);
24+#endif
25 case GST_VIDEO_FORMAT_IYU1: FORMAT_DETAILS(PXP_PIX_FMT_Y41P, 12);
26
27 /* planar formats; bits per pixel is always 8 for these */
28--
291.9.1
30
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.10.1.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.10.2.bb
index 0065f53..bfb7080 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.10.1.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.10.2.bb
@@ -12,9 +12,8 @@ RDEPENDS_gstreamer1.0-plugins-imx-imxaudio = "gstreamer1.0-plugins-good-audiopar
12RDEPENDS_gstreamer1.0-plugins-imx-imxvpu = "gstreamer1.0-plugins-bad-videoparsersbad" 12RDEPENDS_gstreamer1.0-plugins-imx-imxvpu = "gstreamer1.0-plugins-bad-videoparsersbad"
13 13
14SRCBRANCH ?= "master" 14SRCBRANCH ?= "master"
15SRCREV = "898e51dbdb01926d6423d0d31a9530ec6deb5192" 15SRCREV = "cd04f047e17cbdff5d8e075be7dccaf4522ad713"
16SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH} \ 16SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH}"
17 file://0001-pxp-Check-for-new-format-specifier-from-the-new-FSL-.patch"
18 17
19S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
20 19