summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@freescale.com>2015-07-10 17:45:09 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-16 08:42:10 -0300
commitc2b7a4bf56095bf517debd2e56f9fa59a0f25435 (patch)
treee7c1750f3daa1ce273fee4a570e9d65c0398b585
parent7508c1cae09d75aa864609c57bbdc2beb556a860 (diff)
downloadmeta-fsl-arm-c2b7a4bf56095bf517debd2e56f9fa59a0f25435.tar.gz
u-boot-ls1: merge u-boot-ls1.inc into recipe
There is no benefit to having a separate .inc file when we only support one version of u-boot-ls1. Signed-off-by: Ting Liu <ting.liu@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-bsp/u-boot/u-boot-ls1.inc17
-rw-r--r--recipes-bsp/u-boot/u-boot-ls1_2014.07.bb20
2 files changed, 18 insertions, 19 deletions
diff --git a/recipes-bsp/u-boot/u-boot-ls1.inc b/recipes-bsp/u-boot/u-boot-ls1.inc
deleted file mode 100644
index ccd37c6..0000000
--- a/recipes-bsp/u-boot/u-boot-ls1.inc
+++ /dev/null
@@ -1,17 +0,0 @@
1DESCRIPTION = "U-Boot which includes the support for QorIQ Layerscape1 series boards"
2LICENSE = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1"
3LIC_FILES_CHKSUM = " \
4 file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
5 file://Licenses/bsd-2-clause.txt;md5=6a31f076f5773aabd8ff86191ad6fdd5 \
6 file://Licenses/bsd-3-clause.txt;md5=4a1190eac56a9db675d58ebe86eaf50c \
7 file://Licenses/lgpl-2.0.txt;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
8 file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \
9"
10
11SRCBRANCH = "sdk-v1.7.x"
12SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=${SRCBRANCH}"
13SRCREV = "659b6a23a8b1f3026200bc6352dbacef53f4dcb1"
14
15LOCALVERSION ?= "-${SRCBRANCH}"
16
17S = "${WORKDIR}/git"
diff --git a/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb b/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb
index 010d2cc..ad1dd4b 100644
--- a/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb
+++ b/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb
@@ -1,9 +1,25 @@
1require recipes-bsp/u-boot/u-boot.inc 1require recipes-bsp/u-boot/u-boot.inc
2require u-boot-ls1.inc 2
3inherit fsl-u-boot-localversion 3DESCRIPTION = "U-Boot which includes the support for QorIQ Layerscape1 series boards"
4LICENSE = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1"
5LIC_FILES_CHKSUM = " \
6 file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://Licenses/bsd-2-clause.txt;md5=6a31f076f5773aabd8ff86191ad6fdd5 \
8 file://Licenses/bsd-3-clause.txt;md5=4a1190eac56a9db675d58ebe86eaf50c \
9 file://Licenses/lgpl-2.0.txt;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
10 file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \
11"
12
13SRCBRANCH = "sdk-v1.7.x"
14SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=${SRCBRANCH}"
15SRCREV = "659b6a23a8b1f3026200bc6352dbacef53f4dcb1"
4 16
5LOCALVERSION ?= "-${SRCBRANCH}" 17LOCALVERSION ?= "-${SRCBRANCH}"
6 18
19S = "${WORKDIR}/git"
20
21inherit fsl-u-boot-localversion
22
7DEPENDS += "change-file-endianess-native" 23DEPENDS += "change-file-endianess-native"
8PROVIDES += "u-boot" 24PROVIDES += "u-boot"
9 25