summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Vallee <fvallee@eukrea.fr>2015-06-24 11:27:02 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-06 14:50:59 -0300
commit86ced8119ef97ac70e26e68512bd97c7a398e9af (patch)
treef6ec18cf73b493c21204797623174e98c90156cb
parent7e035f717aada261cf63855031dd39d612aa5b61 (diff)
downloadmeta-fsl-arm-86ced8119ef97ac70e26e68512bd97c7a398e9af.tar.gz
amd-gpu-x11-mx51: use x11 compatible eglplatform.h
Freescale's default eglplatform.h contains framebuffer headers while X11 compatible headers are located in eglplatform_1.4.h [1], therefore overwrite eglplatform.h with eglplatform_1.4.h during install. This fixes EGL on X support through xcb. For instance Qt5 would fail to enable CFG_EGL_X [2] due to the following build error during configure : invalid conversion from 'EGLNativeDisplayType {aka void*}' to 'Display* {aka _XDisplay*}' [-fpermissive] This further resulted in a runtime error with Qt5_CinematicExperience: QXcbIntegration: Cannot create platform OpenGL context, neither GLX nor EGL are enabled [1]: http://lists.busybox.net/pipermail/buildroot/2014-November/111475.html [2]: https://codereview.qt-project.org/#/c/77523/ Signed-off-by: Florian Vallee <fvallee@eukrea.fr> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb b/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb
index d5dc8a8..7fc351b 100644
--- a/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb
+++ b/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb
@@ -17,3 +17,9 @@ SRC_URI[sha256sum] = "c7a6fa03b7aa2a375556c59908876554ba720c1e744baba2debb84a408
17RCONFLICTS_${PN} = "amd-gpu-bin-mx51" 17RCONFLICTS_${PN} = "amd-gpu-bin-mx51"
18 18
19COMPATIBLE_MACHINE = "${@base_contains('DISTRO_FEATURES', 'x11', '(mx5)', 'Invalid!', d)}" 19COMPATIBLE_MACHINE = "${@base_contains('DISTRO_FEATURES', 'x11', '(mx5)', 'Invalid!', d)}"
20
21do_install_append() {
22 # eglplatform_1.4.h contains X11 compatible headers
23 rm ${D}${includedir}/EGL/eglplatform.h
24 mv ${D}${includedir}/EGL/eglplatform_1.4.h ${D}${includedir}/EGL/eglplatform.h
25}