summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@freescale.com>2015-07-10 17:45:18 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-16 08:42:10 -0300
commit714adf181910a0004165efef191ca77504f0b048 (patch)
tree490099181a0ef299edde3727d3a6d52736765b83
parent5023df45d9bc9f7c378c2dbe9002c3b25f078d44 (diff)
downloadmeta-fsl-arm-714adf181910a0004165efef191ca77504f0b048.tar.gz
asf: use KBUILD_OUTPUT to point to build-artifacts
In poky commit 46cdaf1, the kernel build output was put into kernel-build-artifacts, and kernel-source is kept "pristine". KERNEL_PATH points to kernel-source, while KBUILD_OUTPUT points to build-artifacts which can be used for external module build. asf Makefile tries to include the .config, use KBUILD_OUTPUT to avoid build error. Signed-off-by: Ting Liu <ting.liu@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--openembedded-layer/recipes-kernel/asf/asf_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/openembedded-layer/recipes-kernel/asf/asf_git.bb b/openembedded-layer/recipes-kernel/asf/asf_git.bb
index bc8dcbc..7cf8f57 100644
--- a/openembedded-layer/recipes-kernel/asf/asf_git.bb
+++ b/openembedded-layer/recipes-kernel/asf/asf_git.bb
@@ -15,6 +15,12 @@ export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
15 15
16INHIBIT_PACKAGE_STRIP = "1" 16INHIBIT_PACKAGE_STRIP = "1"
17 17
18do_configure[depends] += "virtual/kernel:do_shared_workdir"
19do_configure_prepend () {
20 find ${S} -name Makefile -exec \
21 sed -i 's,$(KERNEL_PATH)/.config,$(KBUILD_OUTPUT)/.config,' {} \;
22}
23
18do_install(){ 24do_install(){
19 mkdir -p ${D}/${libexecdir} 25 mkdir -p ${D}/${libexecdir}
20 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/asf 26 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/asf