summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-20 20:50:36 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-31 09:29:30 -0300
commit5bb1276b4e67ed55066e2b63f457947b28ff755f (patch)
treeb1e793462515939557cd2bcf34e6273174d0b432
parent89aaae63cbd4cb2b996f9c1670b925a05a36fcf8 (diff)
downloadmeta-fsl-arm-5bb1276b4e67ed55066e2b63f457947b28ff755f.tar.gz
mesa: Fix override of x11 GLX support for i.MX6
The replacement of --enable-glx-tls for --enable-glx was not working due the way the variables are expanded. To fix the issue an annonymous function has been added to mangle it just before its use. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend12
1 files changed, 11 insertions, 1 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 6cc7de7..4904a0b 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -18,10 +18,20 @@ USE_VIV_LIBGL_mx6q = "yes"
18USE_VIV_LIBGL_mx6dl = "yes" 18USE_VIV_LIBGL_mx6dl = "yes"
19USE_VIV_LIBGL_mx6sx = "yes" 19USE_VIV_LIBGL_mx6sx = "yes"
20 20
21# FIXME: mesa should support 'x11-no-tls' option
22python () {
23 overrides = d.getVar("OVERRIDES", True).split(":")
24 if "mx6" not in overrides:
25 return
26
27 extra_oeconf = d.getVar("EXTRA_OECONF", True)
28 extra_oeconf = extra_oeconf.replace("--enable-glx-tls", "--enable-glx")
29 d.setVar("EXTRA_OECONF", extra_oeconf)
30}
31
21# FIXME: Dirty hack to allow use of Vivante GPU libGL binary 32# FIXME: Dirty hack to allow use of Vivante GPU libGL binary
22do_install_append_mx6 () { 33do_install_append_mx6 () {
23 if [ "${USE_VIV_LIBGL}" = "yes" ]; then 34 if [ "${USE_VIV_LIBGL}" = "yes" ]; then
24 rm -f ${D}${libdir}/libGL.* 35 rm -f ${D}${libdir}/libGL.*
25 fi 36 fi
26} 37}
27EXTRA_OECONF_mx6 := "${@'${EXTRA_OECONF}'.replace('--enable-glx-tls','--enable-glx')}"