summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-30 16:53:55 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-31 09:29:30 -0300
commit44a5115b6ece869cfb10714423e6956128dbaef8 (patch)
tree794de9d92b3000c587802c8b12bb20e56367dae3
parent9074254a1d1e7da4bc0797d56a566ecf09b316dc (diff)
downloadmeta-fsl-arm-44a5115b6ece869cfb10714423e6956128dbaef8.tar.gz
mesa-demos: Support for mx6 without GPUs
Fix to support future mx6 i.MX 6UltraLite which does not have a GPU. This SoC will use mesa so mesa changes before should be more SoC specific to allow future mx6 SoC without GPU to use mesa. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-graphics/mesa/mesa-demos_%.bbappend9
1 files changed, 8 insertions, 1 deletions
diff --git a/recipes-graphics/mesa/mesa-demos_%.bbappend b/recipes-graphics/mesa/mesa-demos_%.bbappend
index 65f3d53..c8d1667 100644
--- a/recipes-graphics/mesa/mesa-demos_%.bbappend
+++ b/recipes-graphics/mesa/mesa-demos_%.bbappend
@@ -9,4 +9,11 @@ SRC_URI_append_mx6dl = " ${MESA-DEMO-PATCH}"
9SRC_URI_append_mx6sx = " ${MESA-DEMO-PATCH}" 9SRC_URI_append_mx6sx = " ${MESA-DEMO-PATCH}"
10SRC_URI_append_mx6sl = " ${MESA-DEMO-PATCH}" 10SRC_URI_append_mx6sl = " ${MESA-DEMO-PATCH}"
11 11
12PACKAGECONFIG_remove_mx6sl = "gles1 gles2" 12REMOVE_GLU = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \
13 bb.utils.contains('DISTRO_FEATURES', 'wayland', 'glu', '', d), d)}"
14
15# only remove GLU on mx6 thave have a GPU
16PACKAGECONFIG_remove_mx6q = "${REMOVE_GLU}"
17PACKAGECONFIG_remove_mx6dl = "${REMOVE_GLU}"
18PACKAGECONFIG_remove_mx6sx = "${REMOVE_GLU}"
19PACKAGECONFIG_remove_mx6sl = "gles1 gles2 ${REMOVE_GLU}"