summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-04-08 11:39:19 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-04-09 08:57:12 -0300
commit1e5f8cea6a779c0dc374cdc3a9a6e2d0bdabbd32 (patch)
tree186c44fc5aaa61bf0028fe97ff29c6e1d2ef0ef9
parentdb048b08dfe6b28ed407f1d6e288d6240639289c (diff)
downloadmeta-fsl-arm-1e5f8cea6a779c0dc374cdc3a9a6e2d0bdabbd32.tar.gz
gstreamer1.0-plugins-imx: Fix build failure with FSL 3.14-based kernel
This checks pxp's new format specifier from the new FSL 3.14 kernel Change-Id: Icb511baa57d5a1e610d2b5319ccccfdfd379f4d3 Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx/0001-pxp-Check-for-new-format-specifier-from-the-new-FSL-.patch30
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.10.1.bb3
2 files changed, 32 insertions, 1 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx/0001-pxp-Check-for-new-format-specifier-from-the-new-FSL-.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx/0001-pxp-Check-for-new-format-specifier-from-the-new-FSL-.patch
new file mode 100644
index 0000000..9390a00
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx/0001-pxp-Check-for-new-format-specifier-from-the-new-FSL-.patch
@@ -0,0 +1,30 @@
1From 66c2285aff440d2cdbd16ee6893bdbbbd814a08b Mon Sep 17 00:00:00 2001
2From: Carlos Rafael Giani <carlos.giani@streamunlimited.com>
3Date: Tue, 7 Apr 2015 18:34:05 +0200
4Subject: [PATCH] pxp: Check for new format specifier from the new FSL 3.14
5 kernel
6
7Signed-off-by: Carlos Rafael Giani <carlos.giani@streamunlimited.com>
8---
9 src/pxp/blitter.c | 4 ++++
10 1 file changed, 4 insertions(+)
11
12diff --git a/src/pxp/blitter.c b/src/pxp/blitter.c
13index b96b3b9..7f44d03 100644
14--- a/src/pxp/blitter.c
15+++ b/src/pxp/blitter.c
16@@ -391,7 +391,11 @@ static GstImxPxPFormatDetails const * gst_imx_pxp_blitter_get_pxp_format_details
17 case GST_VIDEO_FORMAT_YUY2: FORMAT_DETAILS(PXP_PIX_FMT_YUYV, 16);
18 case GST_VIDEO_FORMAT_UYVY: FORMAT_DETAILS(PXP_PIX_FMT_UYVY, 16);
19 case GST_VIDEO_FORMAT_YVYU: FORMAT_DETAILS(PXP_PIX_FMT_YVYU, 16);
20+#ifdef PXP_PIX_FMT_VUY444
21+ case GST_VIDEO_FORMAT_v308: FORMAT_DETAILS(PXP_PIX_FMT_VUY444, 24);
22+#else
23 case GST_VIDEO_FORMAT_v308: FORMAT_DETAILS(PXP_PIX_FMT_YUV444, 24);
24+#endif
25 case GST_VIDEO_FORMAT_IYU1: FORMAT_DETAILS(PXP_PIX_FMT_Y41P, 12);
26
27 /* planar formats; bits per pixel is always 8 for these */
28--
291.9.1
30
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.10.1.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.10.1.bb
index 3f5061c..0065f53 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.10.1.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.10.1.bb
@@ -13,7 +13,8 @@ RDEPENDS_gstreamer1.0-plugins-imx-imxvpu = "gstreamer1.0-plugins-bad-videoparser
13 13
14SRCBRANCH ?= "master" 14SRCBRANCH ?= "master"
15SRCREV = "898e51dbdb01926d6423d0d31a9530ec6deb5192" 15SRCREV = "898e51dbdb01926d6423d0d31a9530ec6deb5192"
16SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH}" 16SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH} \
17 file://0001-pxp-Check-for-new-format-specifier-from-the-new-FSL-.patch"
17 18
18S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
19 20