diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2013-11-04 11:04:47 -0200 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2013-11-06 11:27:16 -0200 |
commit | ff8983cdc86a237e32229f83be1ecd78ff7101b5 (patch) | |
tree | cb7b8ac997daafdb920a36dacc6cdad72f4419d9 | |
parent | 95b32d716d4dc29c5d18303a9c3c155fcb20781a (diff) | |
download | meta-fsl-arm-ff8983cdc86a237e32229f83be1ecd78ff7101b5.tar.gz |
imx-vpu (3.10.9-1.0.0): Use imx-vpu.inc to avoid code duplication
The code in 3.10.9-1.0.0 version was duplicating the logic used in the
imx-vpu.inc so we removed this duplication.
Change-Id: Ie6fc0c5f1a43f7a3bc2b89c155e47b8fa5cdb1a7
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | recipes-bsp/imx-vpu/imx-vpu.inc | 1 | ||||
-rw-r--r-- | recipes-bsp/imx-vpu/imx-vpu_3.10.9-1.0.0.bb | 16 |
2 files changed, 2 insertions, 15 deletions
diff --git a/recipes-bsp/imx-vpu/imx-vpu.inc b/recipes-bsp/imx-vpu/imx-vpu.inc index 3c47d81..fd59770 100644 --- a/recipes-bsp/imx-vpu/imx-vpu.inc +++ b/recipes-bsp/imx-vpu/imx-vpu.inc | |||
@@ -6,6 +6,7 @@ DEPENDS = "virtual/kernel" | |||
6 | inherit fsl-eula-unpack | 6 | inherit fsl-eula-unpack |
7 | 7 | ||
8 | PLATFORM_mx5 = "IMX51" | 8 | PLATFORM_mx5 = "IMX51" |
9 | PLATFORM_mx6 = "IMX6Q" | ||
9 | 10 | ||
10 | SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true" | 11 | SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true" |
11 | 12 | ||
diff --git a/recipes-bsp/imx-vpu/imx-vpu_3.10.9-1.0.0.bb b/recipes-bsp/imx-vpu/imx-vpu_3.10.9-1.0.0.bb index 89b5225..b288a6a 100644 --- a/recipes-bsp/imx-vpu/imx-vpu_3.10.9-1.0.0.bb +++ b/recipes-bsp/imx-vpu/imx-vpu_3.10.9-1.0.0.bb | |||
@@ -1,23 +1,9 @@ | |||
1 | # Copyright (C) 2013 Freescale Semiconductor | 1 | # Copyright (C) 2013 Freescale Semiconductor |
2 | 2 | require imx-vpu.inc | |
3 | require recipes-bsp/imx-lib/imx-lib.inc | ||
4 | |||
5 | inherit fsl-eula-unpack | ||
6 | |||
7 | DESCRIPTION = "Freescale VPU library" | ||
8 | LICENSE = "Proprietary" | ||
9 | LIC_FILES_CHKSUM = "file://vpu/EULA.txt;md5=b063366b066c9f10037c59756a9ced54" | ||
10 | 3 | ||
11 | PE = "1" | 4 | PE = "1" |
12 | 5 | ||
13 | SRC_URI = "${FSL_MIRROR}/imx-vpu-${PV}.bin;fsl-eula=true" | ||
14 | SRC_URI[md5sum] = "61331c9ed2d4c1b3aeab9c35fd034ac3" | 6 | SRC_URI[md5sum] = "61331c9ed2d4c1b3aeab9c35fd034ac3" |
15 | SRC_URI[sha256sum] = "5dd86a26c8d3013e0d78308b1ccd8815730818e465787f55013b492d2d3c7710" | 7 | SRC_URI[sha256sum] = "5dd86a26c8d3013e0d78308b1ccd8815730818e465787f55013b492d2d3c7710" |
16 | 8 | ||
17 | do_compile () { | ||
18 | INCLUDE_DIR="-I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include" | ||
19 | |||
20 | oe_runmake CROSS_COMPILE="${HOST_PREFIX}" PLATFORM="${PLATFORM}" INCLUDE="${INCLUDE_DIR}" all | ||
21 | } | ||
22 | |||
23 | COMPATIBLE_MACHINE = "(mx6)" | 9 | COMPATIBLE_MACHINE = "(mx6)" |