diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2012-11-23 06:49:27 -0600 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2012-12-03 09:25:07 -0200 |
commit | 9db999519e05a001d6b31acc817a4ee09bea15c5 (patch) | |
tree | d38364f3f9566751b7b80aa43e90b331ed75dab6 | |
parent | dae92870d20861c4bde6e2e725e05b72ac783ab9 (diff) | |
download | meta-fsl-arm-9db999519e05a001d6b31acc817a4ee09bea15c5.tar.gz |
libfslcodec: Fix packaging so libraries are in ${libdir}
The libraries need to be installed in ${libdir} or gst-fsl-plugin
won't find them.
Change-Id: I2208ef5f9bf2d43e4e8087e9bc7191a93963795a
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r-- | recipes-multimedia/libfslcodec/libfslcodec_3.0.1.bb | 31 |
1 files changed, 16 insertions, 15 deletions
diff --git a/recipes-multimedia/libfslcodec/libfslcodec_3.0.1.bb b/recipes-multimedia/libfslcodec/libfslcodec_3.0.1.bb index 68e2266..6d391c5 100644 --- a/recipes-multimedia/libfslcodec/libfslcodec_3.0.1.bb +++ b/recipes-multimedia/libfslcodec/libfslcodec_3.0.1.bb | |||
@@ -5,6 +5,8 @@ LICENSE = "Proprietary" | |||
5 | SECTION = "multimedia" | 5 | SECTION = "multimedia" |
6 | LIC_FILES_CHKSUM = "file://EULA.txt;md5=ea4d5c069d7aef0838a110409ea78a01" | 6 | LIC_FILES_CHKSUM = "file://EULA.txt;md5=ea4d5c069d7aef0838a110409ea78a01" |
7 | 7 | ||
8 | PR = "r1" | ||
9 | |||
8 | inherit fsl-eula-unpack autotools pkgconfig | 10 | inherit fsl-eula-unpack autotools pkgconfig |
9 | 11 | ||
10 | SRC_URI[md5sum] = "9e0a765de73b32efa5d276fa90372ce1" | 12 | SRC_URI[md5sum] = "9e0a765de73b32efa5d276fa90372ce1" |
@@ -17,32 +19,31 @@ do_install_append() { | |||
17 | # FIXME: This link points to nowhere | 19 | # FIXME: This link points to nowhere |
18 | rm ${D}${libdir}/imx-mm/audio-codec/lib_src_ppp_arm11_elinux.so | 20 | rm ${D}${libdir}/imx-mm/audio-codec/lib_src_ppp_arm11_elinux.so |
19 | 21 | ||
22 | # LTIB move the files around or gst-fsl-plugin won't find them | ||
23 | for p in $(find ${D}${libdir}/imx-mm -mindepth 1 -maxdepth 1 -type d); do | ||
24 | mv $p/* ${D}${libdir} | ||
25 | rmdir $p | ||
26 | done | ||
27 | rmdir ${D}${libdir}/imx-mm | ||
28 | |||
20 | # FIXME: Drop examples | 29 | # FIXME: Drop examples |
21 | rm -r ${D}${datadir}/imx-mm | 30 | rm -r ${D}${datadir}/imx-mm |
22 | } | 31 | } |
23 | 32 | ||
24 | python populate_packages_prepend() { | 33 | python populate_packages_prepend() { |
25 | audiodir = bb.data.expand('${libdir}/imx-mm/audio-codec', d) | 34 | do_split_packages(d, d.getVar('libdir', True), '^lib_(.*)_elinux\.so\..*', |
26 | do_split_packages(d, audiodir, '^lib_(.*)_elinux\.so\..*', | 35 | aux_files_pattern_verbatim='${libdir}/lib_%s_elinux.so.*', |
27 | aux_files_pattern_verbatim='${libdir}/imx-mm/audio-codec/lib_%s_elinux.so.*', | ||
28 | output_pattern='libfslcodec-audio-%s', | 36 | output_pattern='libfslcodec-audio-%s', |
29 | description='Freescale IMX Codec (%s)', | 37 | description='Freescale IMX Codec (%s)', |
30 | extra_depends='', prepend=True) | 38 | extra_depends='', prepend=True) |
31 | 39 | ||
32 | audiowrapdir = bb.data.expand('${libdir}/imx-mm/audio-codec/wrap', d) | 40 | wrapdir = bb.data.expand('${libdir}/wrap', d) |
33 | do_split_packages(d, audiowrapdir, '^lib_(.*)_elinux\.so\..*', | 41 | do_split_packages(d, wrapdir, '^lib_(.*)_elinux\.so\..*', |
34 | aux_files_pattern_verbatim='${libdir}/imx-mm/audio-codec/wrap/lib_%s_elinux.so.*', | 42 | aux_files_pattern_verbatim='${libdir}/wrap/lib_%s_elinux.so.*', |
35 | output_pattern='libfslcodec-audio-wrap-%s', | 43 | output_pattern='libfslcodec-audio-wrap-%s', |
36 | description='Freescale IMX Codec Wrap (%s)', | 44 | description='Freescale IMX Codec Wrap (%s)', |
37 | extra_depends='', prepend=True) | 45 | extra_depends='', prepend=True) |
38 | 46 | ||
39 | videodir = bb.data.expand('${libdir}/imx-mm/video-codec', d) | ||
40 | do_split_packages(d, videodir, '^lib_(.*)_elinux\.so\..*', | ||
41 | aux_files_pattern_verbatim='${libdir}/imx-mm/video-codec/lib_%s_elinux.so.*', | ||
42 | output_pattern='libfslcodec-video-%s', | ||
43 | description='Freescale IMX Codec (%s)', | ||
44 | extra_depends='', prepend=True) | ||
45 | |||
46 | # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have | 47 | # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have |
47 | # the source we cannot fix it. Disable the insane check for now. | 48 | # the source we cannot fix it. Disable the insane check for now. |
48 | for p in d.getVar('PACKAGES', True).split(): | 49 | for p in d.getVar('PACKAGES', True).split(): |
@@ -52,8 +53,8 @@ python populate_packages_prepend() { | |||
52 | # Ensure we get warnings if we miss something | 53 | # Ensure we get warnings if we miss something |
53 | FILES_${PN} = "" | 54 | FILES_${PN} = "" |
54 | 55 | ||
55 | FILES_${PN}-dev += "${libdir}/imx-mm/*/*${SOLIBSDEV} \ | 56 | FILES_${PN}-dev += "${libdir}/*/*${SOLIBSDEV} \ |
56 | ${libdir}/imx-mm/*/*/*${SOLIBSDEV}" | 57 | ${libdir}/*/*/*${SOLIBSDEV}" |
57 | 58 | ||
58 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 59 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
59 | COMPATIBLE_MACHINE = "(mx6)" | 60 | COMPATIBLE_MACHINE = "(mx6)" |