summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2014-09-01 11:20:33 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2014-09-01 12:18:36 -0300
commitfbeb571edff8a3689362e8c47e7f269324c0cafd (patch)
treef09c1fb6ae701f325af3ae81782f4c42a810c4b3
parent435a1d8ef72d5317bd08ce2974b2cbd65a8b5793 (diff)
downloadmeta-fsl-arm-fbeb571edff8a3689362e8c47e7f269324c0cafd.tar.gz
u-boot-fslc: Use the new fsl-u-boot-localversion class
This uses the new class for LOCALVERSION handling. The local version is set for '+fslc' by default but can be overriden by users of this .inc file. Change-Id: Ic6089ffad89648ec5f3d2f8247e33fd5dd0e7fea Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mxsboot_2014.07.bb2
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc.inc3
2 files changed, 4 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2014.07.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2014.07.bb
index 0ac5861..8ea75ca 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2014.07.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2014.07.bb
@@ -13,6 +13,8 @@ SRC_URI = "git://github.com/Freescale/u-boot-imx.git;branch=${SRCBRANCH}"
13 13
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
15 15
16inherit fsl-u-boot-localversion
17
16EXTRA_OEMAKE = 'HOSTCC="${CC} ${CPPFLAGS}" HOSTLDFLAGS="-L${libdir} -L${base_libdir}" HOSTSTRIP=true CONFIG_MX28=y' 18EXTRA_OEMAKE = 'HOSTCC="${CC} ${CPPFLAGS}" HOSTLDFLAGS="-L${libdir} -L${base_libdir}" HOSTSTRIP=true CONFIG_MX28=y'
17 19
18do_compile () { 20do_compile () {
diff --git a/recipes-bsp/u-boot/u-boot-fslc.inc b/recipes-bsp/u-boot/u-boot-fslc.inc
index 4ed19d6..a1e4de8 100644
--- a/recipes-bsp/u-boot/u-boot-fslc.inc
+++ b/recipes-bsp/u-boot/u-boot-fslc.inc
@@ -3,6 +3,8 @@
3 3
4require recipes-bsp/u-boot/u-boot.inc 4require recipes-bsp/u-boot/u-boot.inc
5 5
6inherit fsl-u-boot-localversion
7
6DESCRIPTION = "U-boot bootloader for Freescale ARM platforms" 8DESCRIPTION = "U-boot bootloader for Freescale ARM platforms"
7LICENSE = "GPLv2+" 9LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb" 10LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
@@ -26,4 +28,3 @@ EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \
26 HOSTSTRIP=true' 28 HOSTSTRIP=true'
27 29
28PACKAGE_ARCH = "${MACHINE_ARCH}" 30PACKAGE_ARCH = "${MACHINE_ARCH}"
29