summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2014-08-29 16:11:32 -0700
committerOtavio Salvador <otavio@ossystems.com.br>2014-08-30 18:29:42 -0300
commitf082dda2ca452041ae62500f85cbb5ee44ddb277 (patch)
treed7e7d4e2dc041340ed3b844c5e2d12c8ac82a024
parent88e8842fba7b3ea6e5f84a5c6d7066047b2bab30 (diff)
downloadmeta-fsl-arm-f082dda2ca452041ae62500f85cbb5ee44ddb277.tar.gz
xf86-video-imxfb: Fix build with glibc 2.20
This issue is unearthed with glibc 2.20 but the patch is good with eglibc 2.19 as well Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imxfb/glibc-2.20.patch57
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imxfb_11.09.01.bb1
2 files changed, 58 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb/glibc-2.20.patch b/recipes-graphics/xorg-driver/xf86-video-imxfb/glibc-2.20.patch
new file mode 100644
index 0000000..3b1b84d
--- /dev/null
+++ b/recipes-graphics/xorg-driver/xf86-video-imxfb/glibc-2.20.patch
@@ -0,0 +1,57 @@
1Fix build errors seen with glibc 2.20
2
3/home/ubuntu/work/upstream/openembedded-core/build/tmp-glibc/sysroots/imx53qsb/usr/include/xorg/os.h:579:1: error: expected identifier or '(' before '__extension__'
4 strndup(const char *str, size_t n);
5 ^
6
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8Upstream-Status: Pending
9Index: xserver-xorg-video-imx-11.09.01/src/imx_accel.c
10===================================================================
11--- xserver-xorg-video-imx-11.09.01.orig/src/imx_accel.c 2011-07-26 14:22:47.000000000 -0700
12+++ xserver-xorg-video-imx-11.09.01/src/imx_accel.c 2014-08-29 15:54:43.648070587 -0700
13@@ -21,6 +21,7 @@
14 * CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
15 * SOFTWARE.
16 */
17+#include <xorg-server.h>
18
19 #include <stdint.h>
20 #include "xf86.h"
21Index: xserver-xorg-video-imx-11.09.01/src/imx_exa_offscreen.c
22===================================================================
23--- xserver-xorg-video-imx-11.09.01.orig/src/imx_exa_offscreen.c 2014-08-29 15:26:31.992070587 -0700
24+++ xserver-xorg-video-imx-11.09.01/src/imx_exa_offscreen.c 2014-08-29 15:54:54.632070587 -0700
25@@ -53,7 +53,7 @@
26 * When allocating, the contiguous block of areas with the minimum eviction
27 * cost is found and evicted in order to make room for the new allocation.
28 */
29-
30+#include <xorg-server.h>
31
32 #include "xf86.h"
33 #include "exa.h"
34Index: xserver-xorg-video-imx-11.09.01/src/imx_exa_z160.c
35===================================================================
36--- xserver-xorg-video-imx-11.09.01.orig/src/imx_exa_z160.c 2014-08-29 15:26:31.992070587 -0700
37+++ xserver-xorg-video-imx-11.09.01/src/imx_exa_z160.c 2014-08-29 15:54:36.056070587 -0700
38@@ -21,6 +21,7 @@
39 * CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
40 * SOFTWARE.
41 */
42+#include <xorg-server.h>
43
44 #include "xf86.h"
45 #include "xf86_OSproc.h"
46Index: xserver-xorg-video-imx-11.09.01/src/imx_ext.c
47===================================================================
48--- xserver-xorg-video-imx-11.09.01.orig/src/imx_ext.c 2014-08-29 15:26:32.064070587 -0700
49+++ xserver-xorg-video-imx-11.09.01/src/imx_ext.c 2014-08-29 15:55:18.048070587 -0700
50@@ -21,6 +21,7 @@
51 * CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
52 * SOFTWARE.
53 */
54+#include <xorg-server.h>
55
56 #include <X11/X.h>
57 #include <X11/Xproto.h>
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb_11.09.01.bb b/recipes-graphics/xorg-driver/xf86-video-imxfb_11.09.01.bb
index 443cd4f..2c36340 100644
--- a/recipes-graphics/xorg-driver/xf86-video-imxfb_11.09.01.bb
+++ b/recipes-graphics/xorg-driver/xf86-video-imxfb_11.09.01.bb
@@ -14,6 +14,7 @@ SRC_URI = "${FSL_MIRROR}/xserver-xorg-video-imx-${PV}.tar.gz \
14 file://ext-Update-to-newer-swap-macros.patch \ 14 file://ext-Update-to-newer-swap-macros.patch \
15 file://Fix-error-unknown-type-name-uint.patch \ 15 file://Fix-error-unknown-type-name-uint.patch \
16 file://xserver-1.14-compat.patch \ 16 file://xserver-1.14-compat.patch \
17 file://glibc-2.20.patch \
17" 18"
18SRC_URI[md5sum] = "d19148399b5d1c4dab90d0cc6f2c4789" 19SRC_URI[md5sum] = "d19148399b5d1c4dab90d0cc6f2c4789"
19SRC_URI[sha256sum] = "d7d85e9f13c6dd58addab89847f3a8a67f6382a54135c7978c9a95368af024d4" 20SRC_URI[sha256sum] = "d7d85e9f13c6dd58addab89847f3a8a67f6382a54135c7978c9a95368af024d4"